Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
20759 Discussions

Poor performance of Left 4 Dead 2

Steve_Asahi
Beginner
4,926 Views

I've encountered millions of crashes when playing L4D2 using Arc A770 graphics card.

At first, the game can launch, but crashes when finish loading a map. Windows event manager gave me this:

 

AppName left4dead2.exe 
  AppVersion 0.0.0.0 
  AppTimeStamp 6318b4f8 
  ModuleName igd9trinity32.dll 
  ModuleVersion 31.0.101.4255 
  ModuleTimeStamp 64138401 
  ExceptionCode c0000409 
  FaultingOffset 00920360 
  ProcessId 0x5674 
  ProcessCreationTime 0x1d96b63dd7892f0 
  AppPath D:\Program Files\SteamGames\steamapps\common\Left 4 Dead 2\left4dead2.exe 
  ModulePath C:\WINDOWS\System32\DriverStore\FileRepository\iigd_dch_d.inf_amd64_3a3e27d30209a539\igd9trinity32.dll 
  IntegratorReportId 47c4519a-9fa4-479d-8f3c-d77b910473cb 
  PackageFullName  
  PackageRelativeAppId  

 

So I googled it and someone says "ddu the driver and reinstall", so I did. But after that the event log became like this:

 

AppName left4dead2.exe 
  AppVersion 0.0.0.0 
  AppTimeStamp 6318b4f8 
  ModuleName KERNELBASE.dll 
  ModuleVersion 10.0.25330.1000 
  ModuleTimeStamp ca43b786 
  ExceptionCode c00000fd 
  FaultingOffset 0014966d 
  ProcessId 0x3144 
  ProcessCreationTime 0x1d96b9b6c8a770c 
  AppPath D:\Program Files\SteamGames\steamapps\common\Left 4 Dead 2\left4dead2.exe 
  ModulePath C:\WINDOWS\System32\KERNELBASE.dll 
  IntegratorReportId bebe57b5-6191-49ba-a358-4c1574b708da 
  PackageFullName  
  PackageRelativeAppId  

 

Since Intel Arc must translate when rendering DX9, I added "-vulkan" for launching the game using DXVK. Now I can play it, barely.

Vulkan mode in this game performs very bad. Especially it cannot run at fullscreen mode otherwise "Failed to create D3D device" will show up. Also, even I managed to entered the game, it still very laggy. The FPS is great, but it will stutter randomly (framerate drop to 1 FPS), and the game still crashes.

I'm not sure if this "KERNELBASE.dll" is the real issue here, since I'm using Windows 11 Canary channel. But I didn't have any of these problems when using my GTX1070Ti.

0 Kudos
16 Replies
Jean_Intel
Employee
4,898 Views

Hello Steve_Asahi,

 

Thank you for posing in the Intel Communities. We understand that you are experiencing performance issues when playing Left 4 Dead 2, we are more than glad to help you with this issue

 

To better undesrtand your issue, please provide us with the following:

 

  • Does the issue persist on different driver versions?
  • What are the games distribution service? ( Blizzard, Epic, Origin, Steam, Xbox, Ubisoft connect).
  • Do you receive an error message when the game crashes? If so, provide us with a screenshot of the error message you receive.
  • Share a video showing the issues you are experiencing and a screenshot of the graphics settings.
  • Provide us with a screenshot of the graphics setting you are using.
  • Create a system report using the following applications:

 

  • Intel®️ System Support Utility (Intel®️ SSU) 
    • Download the Intel SSU
    • Open the application and click "Scan" to see the system and device information. By default, Intel®️ SSU will take you to the "Summary View."
    • Click on the menu where it says: "Summary" to change it to "Detailed View."
    • To save your scan: click "Next"; then "Save."
  • Intel® Graphics Command Center:
    • Open the Intel Graphics Command Center
    • Navigate to the Support tab
    • Select System Diagnostic
    • Click Generate Report
    • Select Save and name the output file.

 

Best regards,

Jean O. 

Intel Customer Support Technician

 

0 Kudos
Steve_Asahi
Beginner
4,886 Views
  • Does the issue persist on different driver versions?

I haven't tested it yet.

  • What are the games distribution service? ( Blizzard, Epic, Origin, Steam, Xbox, Ubisoft connect).

I'm using Steam.

  • Do you receive an error message when the game crashes? If so, provide us with a screenshot of the error message you receive.

No. When the game crashes, it shows nothing but just disappearing. A .mdmp file will be created under the game folder, but I cannot analyze it since I don't have the tool.

 

Further more, I was using these graphics settings when the issue happens:

3840*2160p, borderless window, 4x MSAA, filtering mode: billnear, Vsync: off, shader detail: high, effect detail: high, texture detail: high, multicore rendering: enabled, paged pool memory available: high.

But after some research, I found out these new settings can mitigate the problem significantly:

2x MSAA, shader detail: medium.

Also at the launch options in Steam, I added these to the game:

-vulkan -novid -processheap

In Intel Arc Control, I added l4d2 manually and set the compatibility mode to disabled.

Now I can play through the game without crashing, almostly. It still stutters time to time, but never drops to 1FPS anymore. My friend says the stuttering is related to something called shader cache. But anyway, I definitely cannot play it under DX9 mode.

0 Kudos
Jean_Intel
Employee
4,871 Views

Hello Steve_Asahi,

 

Thanks for the information you provided.

 

We are glad to know that the game is working with no crashes and the stutter is not as frequent. We would like to further investigate this matter, but we noticed that there is still some information missing. Share with us the following:

 

  • Share a video showing the issues you are experiencing.
  • System reports:
    • Intel® System Support Utility.
    • Intel® Graphics Command Center.

 

Best regards,

Jean O.

Intel Customer Support Technician


0 Kudos
Jean_Intel
Employee
4,837 Views

Hello Steve_Asahi,


We hope you are doing fine.


Were you able to check the previous post?

Let us know if you still need assistance.


Best regards, 

Jean O.  

Intel Customer Support Technician


0 Kudos
Steve_Asahi
Beginner
4,824 Views

Sorry for being late. Here are my logs and video link.

https://www.youtube.com/watch?v=yQn2eckOiUY 

Please note that this video is recorded with all mods enabled, all settings high.

I didn't have the time to record new footages with my own solution (shader detail: medium) but basically the stuttering issue that shows in this video can be mitigated (with all mods enabled also).

0 Kudos
Jean_Intel
Employee
4,798 Views

Hello Steve_Asahi,

 

Thank you for the information provided.

 

Since you are running the Windows 11 Canary Channel (25336). Could you check if the issue can be reproduced when using the latest production OS version, 22621? It is important to add that Microsoft informs that the Canary Channel builds can be unstable.

 

Also, you mentioned that you are playing the game with Mods, and in the video you shared, the Mods are enabled. Does the issue appear when using the Vanilla game version (no Mods are included)?

 

Best regards,

Jean O.

Intel Customer Support Technician


0 Kudos
Jean_Intel
Employee
4,757 Views

Hello Steve_Asahi,


We hope you are doing fine.


Were you able to check the previous post?

Let us know if you still need assistance.


Best regards, 

Jean O.  

Intel Customer Support Technician


0 Kudos
Steve_Asahi
Beginner
4,752 Views

Yes, I will try all of them when I have the time. Maybe 2 or 3 days later I can post the update.

0 Kudos
Jean_Intel
Employee
4,749 Views

Hello Steve_Asahi,

 

Thanks for your response.

 

We would wait for you to try the recommendations we provided before. Please, share with us the outcome one you have the information. Let us know if you face any inconvenience trying the suggestions.

 

Best regards,

Jean O. 

Intel Customer Support Technician


0 Kudos
Steve_Asahi
Beginner
4,663 Views

Sorry for the waiting. I've tested the game under fresh installed Windows 11 22H2, and here's the full video:

https://youtu.be/Zy52r8-5sZA

 

Basically, I tested DX9 and Vulkan mode, both of them worked fine, except for some weird behavior of the Vulkan (I think that's the game, not GPU). MOD certainly affected the performance, but if I set Shader Detail to medium, everything works okay. If I turn off all MODs, then Shader Detail can set to high under DX9 mode, but still crashes under Vulkan.

So now, the best solution for me is: DX9 mode, Windowed (borderless), Vsync off, Shader Detail set to medium, other things keep the same.

By the way, when I'm using my old GTX 1070Ti, everything can be maxed out, including the shader detail, without any serious performance issue. So I think all of them boils down to this "Shader" thing.

0 Kudos
Jean_Intel
Employee
4,647 Views

Hello Steve_Asahi,

 

Thank you for the information provided.

 

We will look further into this scenario and provide a response once we have further details.

 

Best regards,

Jean O.

Intel Customer Support Technician


0 Kudos
Jean_Intel
Employee
4,616 Views

Hello Steve_Asahi,

 

Thanks for waiting for a response.

 

We would like to let you know that there is a new driver version that just came out,  31.0.101.4314. Please, try updating your system to this driver version, and test if the issue can be reproduced.

 

Also, we want to confirm if this issue is only present on a specific map of the game or if it could occur on any map.

 

Best regards,

Jean O.

Intel Customer Support Technician


0 Kudos
Steve_Asahi
Beginner
4,521 Views

I've updated to 31.0.101.4314. The issue persists.

This issue can occur on any map. I cannot use High or Very High for Shader detail anyway.

0 Kudos
Jean_Intel
Employee
4,508 Views

Hello Steve_Asahi,

 

We will resume our investigation regarding this matter. We will post back as soon as we have further details.

 

Best regards,

Jean O.

Intel Customer Support Technician


0 Kudos
Jean_Intel
Employee
4,478 Views

Hello Steve_Asahi,

 

Thanks for your patience.

 

We like to notify you that we are working on improvements for DX9 titles, and future driver updates should add up to it. We are working on improvements for Left 4 Dead 2, but this takes time, and unfortunately, we do not have an Estimated time.

 

Since this requires more effort on our end, we are considering closing this thread to void duplication of efforts; however, we would like to know if you are ok to close it.

 

Best regards,

Jean O.

Intel Customer Support Technician


0 Kudos
Jean_Intel
Employee
4,337 Views

Hello Steve_Asahi,

 

We hope you are doing fine.

 

We have not heard back from you. So we will close this thread. If you need any additional information, submit a new question, as this thread will no longer be monitored.

 

Best regards.

Jean O. 

Intel Customer Support Technician.


0 Kudos
Reply