Community
cancel
Showing results for 
Search instead for 
Did you mean: 
DBLac1
Beginner
672 Views

System CPU usage spikes when on an eGPU laptop setup

Laptop is ThinkPad P1 i7/8850H chipset. eGPU is Aorus Gaming Box RTX 2070. There are massive spikes in CPU usage ONLY when the laptop's display is off but the primary external display is on. If laptop and external displays are both on, there is no CPU spike, but if you turn the laptop display off, the setup becomes laggy again due to high System CPU usage spikes. Disabling the intel graphics adapter in device manager will stop the spikes (and activate the internal laptop display as well).

Tags (2)
0 Kudos
10 Replies
Wanner_G_Intel
Moderator
340 Views

Hello DBLac1,

 

Thank you for posting on this Intel Community.

 

To better assist you, we would like to have more information about this issue:

 

1. How are you monitoring this problem? Could you please attach pictures?

2. Are the applications running with the external GPU?

3. Are you following the recommendations to keep the computer working with the lid closed/screen turned off?

 

Windows setting > Control Panel > Hardware and Sound > Power Options > System settings.

Make sure you are using the High Performance Power Option, too.

 

4. Is your system up to date?

 

Driver and Firmware for the AORUS RTX 2070 GAMING BOX 

P1 (Type 20MD, 20ME) Laptop

 

Note: This link is being offered for your convenience and should not be viewed as an endorsement by Intel of the content, products, or services offered there.

 

If the issue persists, please run the Intel® System Support Utility (Intel® SSU) and attach the report to gather more information.

 

1. Download the Intel® System Support Utility and save the application in your computer.

2. Open the application and click "Scan" to see system and device information. The Intel® SSU defaults to the "Summary View" on the output screen following the scan. Click the menu where it says "Summary" to change to "Detailed View".

3. To save your scan, click Next and click Save.

 

Wanner G.

Intel Customer Support Technician

Under Contract to Intel Corporation

DBLac1
Beginner
340 Views

I have all software updated, thank you for the links! Applications are run on the external GPU, and steps have been taken to ensure the laptop display is bypassed and disabled. The HDMI cable is attached to the Aorus 2070 Box, so it does not run through the laptop. After a fresh restart, there isn't a problem with high system interrupts/system CPU usage. It seems to happen more frequently after waking from sleep. Let me know if you can see anything in the scan, which I've attached. If not, I will try to reproduce the problem and then run the scan again (I've just freshly booted and connected the laptop as I'm back from work). Regards, Douglas
DBLac1
Beginner
340 Views

Problem has started again:
Wanner_G_Intel
Moderator
340 Views

Hello DBLac1,

 

Thank you for the update.

 

It seems that the report was not attached. Could you please attach from the thread options?

 

Wanner G.

Intel Customer Support Technician

Under Contract to Intel Corporation

DBLac1
Beginner
340 Views

Sorry, it was attached to the email I sent but it didn't show up here.

Wanner_G_Intel
Moderator
340 Views

Hello DBLac1,

 

Thank you for attaching the report.

 

Could you please let us know the tool you are using the check the high processor usage spikes? If possible, please attach pictures, too.

 

Also, to check the health of the processor, please run the Intel® Processor Diagnostic Tool and attach the report to this thread.

 

Wanner G.

Intel Customer Support Technician

Under Contract to Intel Corporation

DBLac1
Beginner
340 Views

Please see attached screenshot. CPU diagnostic was run; all passed.

Wanner_G_Intel
Moderator
340 Views

Hello DBLac1,

 

Thank you for the update.

 

For testing purposes, we recommend disabling all background applications and try using only the external monitor to check if the issue is related to a recently installed application/software.

 

1. In the Windows Search bar, type msconfig and open System Configuration.

2. Under the Services tab, check the “Hide all Microsoft services” box.

3. Click “Disable all” to disable all active third-party services.

4. Now, select the Startup tab and go to Task Manager.

5. Prevent all programs from starting with the system and confirm changes.

6. Restart your PC.

 

If the issue persists, we recommend contacting your Original Equipment Manufacturer (OEM) and check for hardware compatibility.

 

Wanner G.

Intel Customer Support Technician

Under Contract to Intel Corporation

Wanner_G_Intel
Moderator
340 Views

Hello DBLac1,

 

If you need further assistance, please let us know.

 

Wanner G.

Intel Customer Support Technician

Under Contract to Intel Corporation

Wanner_G_Intel
Moderator
340 Views

Hello DBLac1,

 

We have not heard back from you, so we will close this inquiry. If you need further assistance, please post a new question.

 

Wanner G.

Intel Customer Support Technician

Under Contract to Intel Corporation

Reply