Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
19875 Discussions

The Intel integrated graphics driver cannot find the 75hz option using hdmi output.

number201724
Beginner
6,520 Views

I bought 2 nuc12wski7 and NUC12DCMi9, I found that when I use HDMI cable, I can't set 75hz refresh rate.

I use the same monitor, the same cable, plug it into an amd or nvidia graphics card and it can set 75hz correctly.

 

Whether it is the integrated graphics card of i9-12900 or the integrated graphics card of I7 1260P, the output of 75hz cannot be set under the windows platform.

intel graphics command center can recognize that the display supports 1080p 75hz, but it cannot be set.

 

But I can display 75hz correctly using ubuntu 22.04 linux.

 

Is there any solution please?

 

 

Monitor: ASUS PA247CV

 

 

 

 

0 Kudos
31 Replies
Jean_Intel
Moderator
5,080 Views

Hello number201724,


Thank you for posting on the Intel️® communities.  


In order to have a better understanding of your issue, please provide me with the following:

  • When did the issue start?
  • Have you made sure that the issue persists when using another video port (Thunderbolt)?
  • Did you make sure that the unit is up to date? You can try using the Intel® DSA to scan your system for Intel driver and software updates.


I would recommend a clean installation of the graphics driver, as sometimes corrupted files from previous installations of drivers can linger on a system which can cause driver updates to not work as expected. Please, install the latest driver version available for your unit, 31.0.101.3222.


Best regards, 

Jean O.  

Intel Customer Support Technician


0 Kudos
number201724
Beginner
5,076 Views

When did the issue start?

I've had this problem ever since I bought the NUC.

 

Have you made sure that the issue persists when using another video port (Thunderbolt)?

No problem with Thunderbolt, just hdmi.I have the same situation with multiple monitors.

 

Did you make sure that the unit is up to date? You can try using the Intel® DSA to scan your system for Intel driver and software updates.

Yes, I've tried reinstalling the latest drivers and the same thing happens with a complete removal of the drivers.

 

 

 

0 Kudos
Jean_Intel
Moderator
5,065 Views

Hello number201724


Thanks for your response.


Please, create a report using the following software:

  • Intel®️ System Support Utility (Intel®️ SSU)  
    • Download the Intel SSU
    • Open the application and click on "Scan" to see the system and device information. By default, Intel®️ SSU will take you to the "Summary View." 
    • Click on the menu where it says: "Summary" to change it to "Detailed View." 
    • To save your scan: click on "Next"; then "Save." 


  • Create a report using the Intel® Graphics Command Center:
    • Open the Intel Graphics Command Center
    • Navigate to the Support tab
    • Select System Diagnostic
    • Click Generate Report
    • Select Save and name the output file.


Best regards, 

Jean O.  

Intel Customer Support Technician


0 Kudos
number201724
Beginner
5,032 Views

Attached is the diagnostic log

0 Kudos
Jean_Intel
Moderator
4,994 Views

Hello number201724,


Thanks for your response.


I will proceed to check the issue internally and post back soon with more details. 


Best regards, 

Jean O.  

Intel Customer Support Technician


0 Kudos
number201724
Beginner
4,979 Views

OK, looking forward to your reply. 🙂

0 Kudos
Jean_Intel
Moderator
4,842 Views

Hello number201724,


Thanks for waiting for a response.


I have tested and tried this configuration and I can set up the system to 75Hz with no issues. It may indicate that the issue is a compatibility type issue between the display and the driver.


I would also suggest trying Asus Driver. In case the issue persists, I would recommend you try contacting Asus support. 


Best regards, 

Jean O.  

Intel Customer Support Technician


0 Kudos
number201724
Beginner
4,826 Views

Hello

I have the same problem with two PA247CV. This problem only occurs on intel graphics cards. I use amd and nvidia without this problem, and the same machine, linux can set 75hz.

0 Kudos
Jean_Intel
Moderator
4,821 Views

Hello number201724,


Again, the problem seems to be due to a compatibility issue between the display and the driver. Based on this information I found an Asus driver for this display that you should try. In case the problem is still present after trying the driver, I recommend you contact Asus Support for further troubleshooting.


Best regards, 

Jean O.  

Intel Customer Support Technician


0 Kudos
number201724
Beginner
4,812 Views

The asus driver is just a color profile. This is definitely a problem with the intel display driver. It is obvious that the mode supported by the monitor can be listed in the driver, but the user is not allowed to choose. Only 640x480 or 800x600 allows the use of 75hz, and if it is a problem with the monitor, then linux should not be able to choose. 1080p 75hz

 

 

1920 x 1080 (50p Hz)
1920 x 1080 (60p Hz)
1920 x 1080 (60i Hz)
1920 x 1080 (75p Hz)
0 Kudos
Jean_Intel
Moderator
4,797 Views

Hello number201724,


I will resume my investigation. I will post back as soon as I have more details.


Best regards, 

Jean O.  

Intel Customer Support Technician


0 Kudos
Jean_Intel
Moderator
4,750 Views

Hello number201724,


Thanks for waiting for a response.


This time I would suggest you use IGCC and set up a custom resolution.


  • Open the Intel® Graphics Command Center:
  • From the Windows Start Menu, search for Intel Graphics Command Center. Click the Intel Graphics Command Center icon to open the application.
  • Click the Display tab. In the Display General Settings, click the Custom button located next to the Resolution setting.
  • A warning message will appear. Click Okay to proceed.
  • A new window will appear with Basic Custom Resolution settings. If desired, click Advanced Settings for more options.
  • Enter the custom resolution or mode values based on your requirements. Click Yes to accept the changes.
  • In the Resolution drop-down menu, scroll down and find the custom resolution along with an ‘X’ mark on the right side.


Best regards, 

Jean O.  

Intel Customer Support Technician


0 Kudos
number201724
Beginner
4,743 Views

Hi, I didn't find advanced settings. It only has resolution (width and height)

0 Kudos
Jean_Intel
Moderator
4,725 Views

Hello number201724,

 

Thanks for your reply.

 

The refresh rate option should be available below the width and height, as shown in the image attached. For more information, you can visit our article "How to Set Custom Resolutions and Modes in Intel® Graphics Command Center"

 

If your perspective regarding the Intel® Graphics Command Center is different than the one presented in the image, please provide me with a screenshot.

 

Best regards, 

Jean O.  

Intel Customer Support Technician

 

0 Kudos
number201724
Beginner
4,716 Views

Hi Jean

 

Please check the screenshot, my IGCC is not the same as yours.

 

0 Kudos
Jean_Intel
Moderator
4,707 Views

Hello number201724,


Thanks for the information you provided.


I will once again do further research regarding this matter. I will post back once I have more details and information to share.


Best regards, 

Jean O.  

Intel Customer Support Technician¿


0 Kudos
Jean_Intel
Moderator
4,666 Views

Hello number201724,


Thanks for waiting for a response


Based on the information you have provided, it seems that this may be a driver issue in combination with this particular monitor since is working with Linux but not Windows.


Best regards, 

Jean O.  

Intel Customer Support Technician


0 Kudos
number201724
Beginner
4,660 Views

Hello Jean

 

I think you need to escalate the issue to the driver development team to fix it because same monitor, same cable, same OS, nvidia(3080) and amd don't have this problem (6600xt and amd integrated graphics).

 

0 Kudos
Jean_Intel
Moderator
4,657 Views

Hello number201724,


Thanks for your reply.


This information will be shared with the Intel Nuc team and we will work on this matter.


Best regards, 

Jean O.  

Intel Customer Support Technician


0 Kudos
Jean_Intel
Moderator
4,503 Views

Hello number201724,

 

Thanks for waiting for a response.

 

Please make sure that you are running the latest Windows updates. Select Start > Settings > Update & Security > Windows Update, then select Check for updates. Install any update requested by the Operating System if needed.

 

Also, it would ask you to run Monitor asset manager on your system and capture the screenshot (see sample attached). We need this to check the EDID version your monitor is running.

 

Best regards, 

Jean O.  

Intel Customer Support Technician

 

0 Kudos
Reply