Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
5,881 Views

UHD Graphics Drivers - No Support for Full RGB output on HDMI?

Honestly, what is the reasoning for this?

I have been trying all sorts of registry hacks and workarounds for this, but it just looks like driver developers aren't wanting to give users any support to configure their own anymore?

I use two external monitors with my laptop, which has two GPUs controlled via Optimus -- one display is controlled via the NVIDIA GPU, and the other dispaly is controled via the integrated Intel chip (UHD Graphics 630). I am using Windows 10 Build 1803.

The NVIDIA one I can set to output with Full RGB range on the HDMI port no problem. The colors look correct on my monitor. The other monitor (identical model) that is controlled by the Intel chip has limited RGB output, and looks washed out and horrible in comparison.

Where I was once able to change the output level from "limited" to "full" on the old Intel HD drivers, the new Intel UHD drivers fail to give me that option. I am thus *forced* to use this washed out, god-awful limited RGB output.

How can I set it to full RGB output? There is no longer an "Advanced" tab in the "General Settings" page of the "Display" screen of the "Intel UHD Graphics Control Panel" to configure this. This is all I see:

0 Kudos
12 Replies
Highlighted
Moderator
1,376 Views

Hello smudge12,

I can confirm that we do support Full RGB output over HDMI, see below example of the available options:

This obviously begs the question why this is not the same in your case. Do you have any kind of adapter or converter (e.g. DP-to-HDMI or USB-to-HDMI)?

In order to dig deeper into this issue, we would appreciate if you post some additional data following the instructions listed here

Best Regards,

Ronald M.

0 Kudos
Highlighted
Beginner
1,376 Views

Thank you for the response Ronald,

Indeed, I am using a USB-C to HDMI converter.

What is odd is that if I add a DWORD key with a value of 1 named EnableRGBFullRange to the registry key Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e968-e325–11ce-bfc1–08002be10318}\xxxx, where xxxx is the display index, I can get it to display the full RGB range for a few minutes (or until the display changes), after which it reverts to limited.

So I know the USB-C connection is *capable* of the 8 bits-per-channel required for full RGB range. I just don't know why the option is unavailable to me.

0 Kudos
Highlighted
Beginner
1,376 Views

Okay, so I've now confirmed that the settings are intentionally and programmatically disabled in the UHD drivers 24.20.100.6136.

I went ahead and decompiled the UI binary to see what is going on, and here's what I discover:

There is only a single function prototype used to populate the advanced HDMI options, and there is not even a conditional evaluation to see if the hardware supports them. They are just disabled. That's it.

 

I analyzed the UI control which is bound to the Quantization Range setting to see if there are any cross-refernces where it might be re-enabled elsewhere, but there are not.

Why did Intel developers disable access to these options?

0 Kudos
Highlighted
Moderator
1,376 Views

Hi again,

This is something that was reported already to our development team, and we're currently looking into [Report ID# 1407164696].

Similar threads:

I recognize that the investigation progress has been slow, and while I cannot promise any particular outcome, I'll be sure to keep the Community updated on any new development.

I rather use this thread to post updates since it has a wider audience and it helps to increase visibility for anyone else having the same issue.

Best Regards,

Ronald M.

0 Kudos
Highlighted
Beginner
1,376 Views

Slow is a little bit of an understatement for such a simple problem to fix.

With the registry modification I mentioned in the first post, I can successfully enable the full Quantization level, but *ONLY* after hitting "Apply" in the intel display settings (it doesn't matter if anything has changed, it just seems to trigger a refresh of the display settings from registry, which then enables full RGB).

The problem with this fix is that it does not persist after reboot, nor after resuming from sleep or hibernation. So I have to manually open the Intel display settings, change anything and hit apply, to get full RGB re-enabled.

I did some additional reverse engineering of the settings application and managed to forcibly enable access to the Quantization settings, but changing from "limited" to "full" and visa versa does nothing. ONLY the registry modification enables full RGB levels. After digging more, while the setting and it's UI binding can be forcibly shown, they don't actually do anything anywhere else in the application. Almost like their support has been removed intentionally and entirely (which indicates why the UI bindings were hidden in the first place).

But the question remains: if I can clearly get full RGB support (albeit impermanently) and if the hardware clearly supports it, why was support for full RGB quantization removed from the UHD graphics drivers and from their UI? Again, it is clear from the .NET code that this was a deliberate choice on the part of the developers. But why?

I shouldn't have to do all this just to get my hardware working as it should with the capabilities it clearly already has.

0 Kudos
Highlighted
Moderator
1,376 Views

Hi smudge12,

I can confirm that the option indeed works as long as it is a straight HDMI-to-HDMI connection.

Internally we are investigating the situation when adapters are used, as this is a different use case.

Thank you for your patience, and as stated I'll be posting further updates on the aforementioned thread.

Best Regards,

Ronald M.

0 Kudos
Highlighted
Moderator
1,376 Views

Hello smudge12,

Our development team has concluded their investigation on this issue. It has been determined that our driver is only expected to show the 'Quantization Range' options for Native HDMI connections. On USB Type-C to HDMI or DP-to-HDMI adapters the connection type switches to DP. The option was showing on previous drivers due to a bug in the code that has been corrected now.

You can still set the desired video output range for Non-Native HDMI by opening the Intel Graphics Control Panel > go to Video > "Basic " or "Color Enhancement" > Input range > Driver Settings > Full.

I hope this information helps, and thank you very much for your patience while we worked on this one.

Best Regards,

Ronald M.

0 Kudos
Highlighted
Novice
1,376 Views

Hi,

Sorry for digging this out, but I have exactly the same issue (feature?). I'm using UHD630 with Club3D CAC-1080 Displayport - HDMI adapter. It is only way to get 4K@60Hz on Intel-based boards over HDMI as you're already aware of 😉 My display is Panasonic TX-50CX700E, 4K but not HDR capable. Windows 10, latest Intel drivers available as of today (x.6286)

CAC-1080 allows full RGB, also HDR modes. Unfortunately, the display is fixed to YCbCr 4:2:0 and there is no way to change it. Suggested setting "Full range" under "Video" gives strange effect - the displays flicks from "black" to "gray" and generally everything is heavilly banded all around, doesn't look like full range to me.

This is quite surprising, as I was using mainboard with UHD 505 (Asrock J4205-ITX) and DP->HDMI converter "bulit in" and the problem didn't exist, I got full RGB, all color ranges also Deep Color settings.

I wish I could it can be solved, as DP->HDMI converter is capable of full range of modes, same as GPU itself. I can provide debugs/logs, whatever is needed to fix this... I don't want to add another GPU to the HTPC just to have it fixed....

Thanks,

Tomek

Highlighted
Community Manager
1,376 Views

Hello smudge12,

 

 

Thank you for joining our Intel ® Community.

 

We totally understand your situation.

 

In this case since your issue refers to different problem that the original thread and the previously shared troubleshootingdid not work, please go ahead and create a separate ticket in our graphics community.

 

On the next ticket please include your relevant details following the instructions listed here:

 

/thread/77761 IMPORTANT - Required information for reporting Graphics issues

 

As well please include the report generated by our https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-Best Intel® System Support Utility for Windows*

 

Also you may use the following threads as reference to address your issue:

 

/thread/119192 https://communities.intel.com/thread/119192

 

/thread/117049 https://communities.intel.com/thread/117049

 

/thread/119192 https://communities.intel.com/thread/119192

 

 

I hope this helps.

 

Regards,

 

Diego S.

 

0 Kudos
Highlighted
Beginner
1,376 Views

Why was this considered a bug? Was there a misunderstanding on the part of the team? It was the only way to obtain the proper full range output. The work-around mentioned above (changing the "Input range" of video) does not replicate this as that only affects when playing a video from a video player (and I think it is also not truly changing the GPU output range anyways). There is no way currently to output full range via non-native HDMI despite the fact that they are fully capable of doing this (as done in driver 15.45) and that it is important to be able to do so. Unless there is some other explanation we are not aware of, it was a mistake to remove the output range from the driver for non-native HDMI outputs.

0 Kudos
Highlighted
Beginner
214 Views

Hello RonaldM_Intel.

 

It has been over two years and the problem has still not been fixed even in the newest (27.20) drivers!

To make things worse, almost no new Ultrabook features a native HDMI Output anymore, meaning all rely on USB-C to HDMI Adaptors! The proposed fix in the Video Subsetting only helps with Video Playback, not during normal work.

 

This is a huge problem! Please Intel, help your users to bring back the option.

0 Kudos
Highlighted
Beginner
169 Views

I was able to get my Problem fixed with using a USB-C to Displayport Adapter. Now it outputs in Full RGB Range and as a bonus I have the Saturation Slider back 🙂

So as I see it, the problem is a incompatibility between the intel drivers and the adapters. Still sad of Intel to not help those with USB-C to HDMI Adapters.

0 Kudos