Community
cancel
Showing results for 
Search instead for 
Did you mean: 
90 Views

glGetQueryObjectui64v sometimes never returning under Remote Desktop, Win 1809

We develop a 3D viewing application which we use via Windows Remote Desktop. This has worked fine until recently when the host computer updated to Windows 10 1809. Now, the view can be used for a little bit after launch, but then something happens that makes the next call to glGetQueryObjectui64v (for an object written to by glQueryCounter) get into an infinite loop. The glGetQueryObjectui64v function never returns but instead uses a full CPU core and hangs our application. 

We have verified that the problem goes away again if we roll back to Windows version 1803. 

We have tried different Intel Graphics Driver versions including v25.20.100.6323, v25.20.100.6444 (DCH) and 23.20.16.4973. The problem does not occur on computers which have a discrete, non-Intel graphics card. 

 

System details

Operating System: Windows 10 Pro (10.0.17763)
Physical Memory: 32613 MB
Vendor ID: 8086
Device ID: 1912
Device Revision: 06
Graphics Output Protocol (GOP) Version: 9.0.1047
Current Resolution: 1920 x 1080

Processor: Intel(R) Core(TM) i7-6700TE CPU @ 2.40GHz
Processor Speed: 2400 MHz
Processor Graphics in Use: Intel(R) HD Graphics 530
Shader Version: 5.1
OpenGL Version: 4.5
OpenCL Version: 2.1
Vulkan Version: 1.1.83

* Microsoft DirectX *
Runtime Version: 12.0
Hardware-Supported Version: 12.0

0 Kudos
0 Replies
Reply