Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ZBala
Beginner
1,263 Views

i7 8700k + iGPU HD630 + nVidia GTX 10603GB

Jump to solution

I use video encoding in Handbrake a LOT. Therefore I need to keep iGPU activated for me being able to use QSV when I encode. Now when I start ANY 3D application which runs obviously on my 1060 after a while screen flickers and I see the application screen and the desktop in a super-fast flickering manner. Alt-Tab solves the problem for a couple of minutes.

iGPU deactivated the problem disappears.

Any ideas?

0 Kudos

Accepted Solutions
Stefan3D
Honored Contributor II
86 Views

You did not mention your current driver version.

Try older or newer drivers from this list https://downloadcenter.intel.com/product/98909/Intel-HD-Graphics-630 Downloads for Intel® HD Graphics 630

Select OS from right pull-down menu. Hit "show more".

To bypass message "best driver is already installed", "customized computer manufacturer driver" or "computer is not validated" install driver via have disk method as described at:

https://www.windowscentral.com/how-install-intel-beta-graphics-drivers-surface (ignore prolog about MS surface)

View solution in original post

2 Replies
Stefan3D
Honored Contributor II
87 Views

You did not mention your current driver version.

Try older or newer drivers from this list https://downloadcenter.intel.com/product/98909/Intel-HD-Graphics-630 Downloads for Intel® HD Graphics 630

Select OS from right pull-down menu. Hit "show more".

To bypass message "best driver is already installed", "customized computer manufacturer driver" or "computer is not validated" install driver via have disk method as described at:

https://www.windowscentral.com/how-install-intel-beta-graphics-drivers-surface (ignore prolog about MS surface)

View solution in original post

ZBala
Beginner
86 Views

Thank you for your answer. Excellent. Problem solved!!!!!

Faulty driver: 15.65.5.4982

Proper driver: 15.60.2.4901

Cheers,

Zoltan