Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,919 Views

no hdmi audio device

no hdmi audio in windows audio property.

My environment is below.

Let me know how to enable hdmi audio.

Computer

ASRock Z370 Gaming-ITX/ac

Operating System

Microsoft Windows 10 Pro (64 ビット)

Processor

Intel® Core™ i5-8400 CPU @ 2.80GHz

Chipset

Intel® 200 Series Chipset Family

Graphics

Intel® UHD Graphics 630Up to date

Memory

16 GB

Storage

Microsoft Storage Space Device

PLEXTOR PX-512M8SeG

Generic STORAGE DEVICE USB Device

0 Kudos
8 Replies
Highlighted
Community Manager
32 Views

ryuu00: We will do our best to try to fix this problem.

If you right click on the sound icon on the lower right corner and then choose "playback devices", do you see the PC monitor or TV listed in there?

 

What is the model of the PC monitor or TV?

 

This problem, is it recently?

 

Did you make any recent software/hardware changes?

 

Do you have the option to use a different HDMI cable?

 

 

We recommend to install the drivers provided by the manufacturer of the motherboard, those drivers were customized by them to work with your specific platform, please install the graphics driver version 24.20.100.6169, chipset driver 10.1.17695.8086 and management engine driver version 11.8.50.3477:

 

https://www.asrock.com/mb/Intel/Fatal1ty%2520Z370%2520Gaming-ITXac/%23Download https://www.asrock.com/mb/Intel/Fatal1ty%20Z370%20Gaming-ITXac/# Download

 

 

If the problem remains then we can try to install the generic Intel graphics drivers, the latest version is 24.20.100.6286:

 

https://downloadcenter.intel.com/download/27988/Intel-Graphics-Driver-for-Windows-10%3Fproduct%3D126... https://downloadcenter.intel.com/download/27988/Intel-Graphics-Driver-for-Windows-10?product=126790

Any questions, please let me know.

Regards,

 

Alberto R
0 Kudos
Highlighted
Beginner
32 Views

>We will do our best to try to fix this problem.

Thank you.

>If you right click on the sound icon on the lower right corner and then choose "playback devices", do you see the PC monitor or TV listed in there?

There is no device.

>What is the model of the PC monitor or TV?

TV (Toshiba 55X920 and YAMAHA RX-A3070. Not good both direct connect TV and via AV amp.)

>This problem, is it recently?

This is my new PC.

This problem started from the beginning.

 

>Did you make any recent software/hardware changes?

No.

>Do you have the option to use a different HDMI cable?

I have two HDMI cables.

Both are available via NVIDIA graphics adapter.

>We recommend to install the drivers provided by the manufacturer of the motherboard, those drivers were customized by them to work with your specific platform, please install the graphics driver version 24.20.100.6169, chipset driver 10.1.17695.8086 and management engine driver version 11.8.50.3477:

 

>https://www.asrock.com/mb/Intel/Fatal1ty%2520Z370%2520Gaming-ITXac/%23Download https://www.asrock.com/mb/Intel/Fatal1ty%20Z370%20Gaming-ITXac/# Download

I try to use above old version driver. But no HDMI audio device.

>If the problem remains then we can try to install the generic Intel graphics drivers, the latest version is 24.20.100.6286:

 

>https://downloadcenter.intel.com/download/27988/Intel-Graphics-Driver-for-Windows-10%3Fproduct%3D126... https://downloadcenter.intel.com/download/27988/Intel-Graphics-Driver-for-Windows-10?product=126790

I try to use above version driver. But no HDMI audio device.

0 Kudos
Highlighted
Community Manager
32 Views

ryuu00: You are very welcome.

Are you using an Nvidia graphics card? When an external discrete video card is installed the onboard graphics gets automatically disabled and in that case the graphics drivers needed are the ones provided by Nvidia:

 

https://www.nvidia.com/Download/index.aspx https://www.nvidia.com/Download/index.aspx

If you have the option to disconnect the video card to use the HDMI port from the motherboard, then the graphics drivers needed are the ones provided by ASUS.

If the problem persists after that, then we recommend to get in contact directly with either Nvidia or ASUS support so they can provide more suggestions and further assistance. A BIOS update on the board might be needed and they ASUS will provide the instructions of how to do it.

 

https://www.asus.com/support/%23 https://www.asus.com/support/#

 

https://www.nvidia.com/object/support.html https://www.nvidia.com/object/support.html

 

 

On the following links you will find further details about this scenario:

 

https://answers.microsoft.com/en-us/windows/forum/windows_10-hardware-winpc/sound-not-working-on-win... https://answers.microsoft.com/en-us/windows/forum/windows_10-hardware-winpc/sound-not-working-on-win...

 

https://support.microsoft.com/en-us/help/4026994/windows-fix-sound-problems https://support.microsoft.com/en-us/help/4026994/windows-fix-sound-problems

The content on the above site is not controlled by Intel. This information is offered for your convenience and should not be viewed as an endorsement by Intel for the merchants or services offered there.

Any questions, please let me know.

Regards,

 

Alberto R
0 Kudos
Highlighted
Community Manager
32 Views

ryuu00: I just wanted to check if the information posted previously was useful for you and if you need further assistance on this matter?

 

 

Any questions, please let me know.

 

 

Regards,

 

Alberto R
0 Kudos
Highlighted
Beginner
32 Views

I'm sorry for waiting.

I'm busy now, please wait a few days.

0 Kudos
Highlighted
Community Manager
32 Views

ryuu00: No problem at all.

 

 

Sure, no problem, take your time, once you get the chance please let us know the results.

 

 

Any questions, please let me know.

 

 

Regards,

 

Alberto R
0 Kudos
Highlighted
Beginner
32 Views

Thank you for your help.

Resolved.

by BIOS setting.

I set Disabled to Onboard HD Audio.

When Onboard HD Audio is Disabled, BIOS hidden Onboard HDMI HD Audio.

0 Kudos
Highlighted
Community Manager
32 Views

ryuu00: You are very welcome. Perfect, excellent, we are glad to hear the problem got fixed and thank you for sharing those details.

 

 

Any other inquiry, do not hesitate in contact us again.

 

 

Regards,

 

Alberto R
0 Kudos