Intel® ARC™ Graphics
Get answers to your questions or issues when gaming on the world’s best discrete video cards with the latest news surrounding Intel® ARC™ Graphics
1670 Discussions

ARC A770-16 Crashing with Assetto Corsa CSP addon.

Saabjock
Novice
2,816 Views

Arc A770-16GB (with all drivers....including installed 31.0.101.5074) crashes during loading of Assetto Corsa with the CSP (Custom Shaders Patch) add-on by IIja Jusapov.

ARC positively identified as the culprit by removing driver and selecting Microsoft basic driver...at which time it loaded.

Earlier ARC drivers worked with this program...even in WMR, prior to firmware updates.

20231212_032750.jpg

0 Kudos
9 Replies
Jean_Intel
Employee
2,792 Views

Hello Saabjock,

 

Thank you for joining the Intel Communities one more time. We can see that you are experiencing issues when loading Assetto Corsa with the CSP (Custom Shaders Patch) add-on by IIja Jusapov. Since the game is presenting errors after you installed an addon mod to the game, the best course of action is to communicate with the mod developer for further support. If they determine that the issue is related to the graphics driver, we would be more than happy to continue the assistance.

 

Best regards

Jean O.

Intel Customer Support Technician


0 Kudos
Saabjock
Novice
2,763 Views

I've already reached out to both of the mod's developers....IIja Jusupov and Peter Boese.

Both have offered numerous steps to try.

Those steps have been unsuccessful in correcting the issue but it really is not an error on the part of their software.

The issue is not with the mods themselves. It is the Intel driver or firmware at issue.

The mods ran fine prior to the firmware updating done during the driver installation.

Please reference the two attached videos with CSP 0.2.1 and PURE 0.222 mods installed and running pre Intel firmware.

https://www.youtube.com/watch?v=VqQ096qnK8g&t=137s 

 https://www.youtube.com/watch?v=_mwhnCkFCDg

In terms of troubleshooting...

The loading process (to go on track) will run successfully if I de-selected the RainFX and Fake Shadows components in CSP.

That action obviously removes rain from the simulation.

If either of those two components are selected, I will have a reset of the driver.

As stated, this (crash) all started happening AFTER the Intel firmware updating on later drivers.

    I went as far as a complete removal and reinstallation of ALL Assetto Corsa + DLC software...including the Documents/Assetto Corsa directory. That move assured all config files were deleted and then reinstalled.

I also removed PURE 0.222 and troubleshot without it being installed.

I tried multiples of earlier Intel drivers...aven the one which previously worked and are listed in the video descriptions.

The final step was to use DDU to remove the Intel video and just use the basic Intel driver.

At that point everything loaded with both Rain FX and Fake Shadows FX selected.

I obviously could not run it like that because there was no graphics acceleration and it loaded at about two frames per second.

It did verify however, that the driver/firmware was indeed the issue.

 

 

 

0 Kudos
Jean_Intel
Employee
2,750 Views

Hello Saabjock,

 

Thank you for all the details you have shared. Allow us some time to look into this matter internally. We will be posting back as soon as we have more details about the problem.

 

Best regards,

Jean O.

Intel Customer Support Technician


0 Kudos
Jean_Intel
Employee
2,737 Views

Hello Saabjock,

 

Thank you for your patience. After looking into this matter internally, we want to make sure the base game works fine. If so, we want to let you know that if the Mod developer confirms that there is an issue with the Intel Drivers they can report it to our Developing Games on Intel Graphics or IGCIT GitHub Support, so we can work together to solve this problem.

 

Best regards,

Jean O.

Intel Customer Support Technician


0 Kudos
Saabjock
Novice
2,726 Views

The base game works just fine.

CSP worked fine as well prior to the firmware updating.

0 Kudos
Jean_Intel
Employee
2,617 Views

Hello Saabjock,

 

We understand that the base game works fine and the mod worked fine before the update. As we mentioned earlier, we recommend you pass the feedback to the mod developers sharing your findings so they can report the problem to us in our Developing Games on Intel Graphics or IGCIT GitHub Support to continue working together on a solution for this issue.

 

Best regards,

Jean O.

Intel Customer Support Technician


0 Kudos
Jean_Intel
Employee
2,542 Views

Hello Saabjock,


We will close this thread now, as we have not heard back from you. As we recommended before, you should pass the feedback to the mod developers so they can report the issue to us in the Intel Developing Games communities support. If you have any other questions, please open a new thread since this one will no longer be monitored.


Best regards,

Jean O.

Intel Customer Support Technician


0 Kudos
Saabjock
Novice
2,484 Views

Fixed with the new Intel driver 31.0.101.5084.

0 Kudos
Saabjock
Novice
2,183 Views
0 Kudos
Reply