Intel® ARC™ Graphics
Get answers to your questions or issues when gaming on the world’s best discrete video cards with the latest news surrounding Intel® ARC™ Graphics
1442 Discussions

Solidworks on an ARC A770

knarf
Novice
20,111 Views

Anyone running Solidworks (2022 SP4).?. 

 

Completely and utterly unusable in any capacity with Solid works. 

 I had to put GTX960 back in. 

 

A770 drivers upto date 

Solidworks patched

AMD 5900x with 64Gb RAM

 

0 Kudos
16 Replies
Luigiman54
Beginner
20,012 Views

I have a similar issue, I disabled "dynamic highlight from graphics view"  and anti-aliasing under display settings and it made a pretty big difference, but the quality of the preview is noticibly lower.

0 Kudos
RonaldM_Intel
Moderator
19,993 Views

Hello everyone,

 

I received a similar report a week ago, so I went ahead and tested SolidWorks 2022 on an Intel Arc A770 (Desktop) and also on Arc A370M.

I was able to observe SolidWorks 2022 was running on the Integrated Graphics instead of the Arc Graphics using Windows Task Manager (regardless of the configuration set in Windows to force the app to run on Arc Graphics).

Can you please confirm if this is the same scenario for you? It would help if you add the SSU report from your system.

 

Best Regards,

Ronald M.

 

0 Kudos
DJBLR
Beginner
19,705 Views

I have this exact issue and I haven't been able to solve it yet.  No matter what I do (even configuring windows to use the ARC card for Solidworks 2022 as you mentioned) it will still use the integrated card instead.  I even disabled the internal graphics card, but it still will not use ARC card.  PLEASE provide a resolution to make this work.  As other users have mentioned, Solidworks is virtually useless like this. 

Samsung Galaxy Book2 Pro, Intel ARC350, 32GB Ram: SSU attached

Thanks,

0 Kudos
knarf
Novice
19,942 Views

Hi RonaldM_Intel,

I'm on AMD 5900X, so no CPU GPU.

0 Kudos
Luigiman54
Beginner
19,935 Views

Same, I'm on Ryzen 7 3700X

0 Kudos
thegrantpa
Novice
19,797 Views

Same here. Totally unusable. Tried what Luigiman54 suggested, but no change. 

 

Solidworks 2021 Student Ed. 

A770 running 31.0.101.3793

i5-11600k (Solidworks is NOT running off iGPU)

32Gb RAM

 

 

0 Kudos
Luigiman54
Beginner
19,054 Views

The actual fix is to open SOLIDWORKS Rx 2022 and click "Click here to launch SOLIDWORKS while bypassing the Tools/Options settings". This forces it to use hardware OpenGL acceleration.

 

To force this permanently open the registry editor and go to Computer\HKEY_CURRENT_USER\SOFTWARE\SolidWorks\SOLIDWORKS 2022\Performance\Graphics\Hardware\Intel and set Workarounds to 9.

0 Kudos
DJBLR
Beginner
19,010 Views

Luigiman54, that worked!  Thank you so much!

0 Kudos
RayG
Beginner
18,762 Views

Can you please share your expierence with Intel ARC Gpu in regards to using it with Solidworks ? What changed when you applied the registry mod or forced running the software with Hardware OpenGL acceleration . ! Is it rinning smoother now , can you use all the features solid works offer .

i am asking because i want to buy this card or get my hands on ARC PRO A50 and use it with Solidworks

0 Kudos
hasankarabasan
Beginner
16,702 Views
How much has performance increased??
0 Kudos
Luigiman54
Beginner
16,670 Views
I get ~125fps in specviewperf 2020 SolidWorks viewport
0 Kudos
straat
Beginner
18,641 Views

I'm testing Solidworks 2023 on a Lenovo Slim 7 laptop, i7 12700H CPU + Arc 370M GPU, 32GB DDR5 with Windows 11 / 31.0.101.4091 driver

 

Using Rx to open Solidworks made no difference in my case.

With the above mentioned registry change, Solidworks runs on the A370M but it only seems to run smooth the very first time I rotate a model after opening. After that, it's horribly slow and parts change into boxy shapes while rotating the model.

 

When I change the Windows graphics preference setting to use the power saving GPU (integrated Iris Xe) it runs so much better.

 

After enabling realview by creating registry keys it seems to run as expected on both integrated Xe and Arc GPU.

These registry keys are in a different location for earlier versions of Solidworks.

 

 

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\SolidWorks\AllowList\Gl2Shaders\Other\Intel(R) Iris(R) Xe Graphics]
"Workarounds"=dword:00000008

[HKEY_CURRENT_USER\Software\SolidWorks\AllowList\Gl2Shaders\Other\Intel(R) Arc(TM) A370M Graphics]
"Workarounds"=dword:00000008

[HKEY_CURRENT_USER\Software\SolidWorks\AllowList\Intel\Intel(R) Iris(R) Xe Graphics]
"Workarounds"=dword:04000080

[HKEY_CURRENT_USER\Software\SolidWorks\AllowList\Intel\Intel(R) Arc(TM) A370M Graphics]
"Workarounds"=dword:04000080

 

 

 

Bobeca
Beginner
17,396 Views

Hey straat!

Kudos for the solution! I tested it with A750 and it works perfect. Had to change A370M to A750 and it worked flawlessly! 

It's not perfect solution but it is better than no solution. It will be nice to see an update from Intel and Solidworks on this issue.

Tested on Solidworks 2023 with the latest SP1 applied. I opened the biggest production line that I had available (1000+ parts) and it works perfect.

0 Kudos
hasankarabasan
Beginner
16,704 Views
How much has performance increased?
0 Kudos
Krieve
Beginner
13,334 Views

Worked perfectly for my A770 after modifying your file. I'm attaching it below in case anyone else with the 770 has the same issue. Thanks!

EDIT: I'm using Solidworks 2023 SP2.1 It should work on other versions as well.

 

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\SolidWorks\AllowList\Gl2Shaders\Other\Intel(R) Iris(R) Xe Graphics]
"Workarounds"=dword:00000008

[HKEY_CURRENT_USER\Software\SolidWorks\AllowList\Gl2Shaders\Other\Intel(R) Arc(TM) A770 Graphics]
"Workarounds"=dword:00000008

[HKEY_CURRENT_USER\Software\SolidWorks\AllowList\Intel\Intel(R) Iris(R) Xe Graphics]
"Workarounds"=dword:04000080

[HKEY_CURRENT_USER\Software\SolidWorks\AllowList\Intel\Intel(R) Arc(TM) A770 Graphics]
"Workarounds"=dword:04000080

 

0 Kudos
alchem
Beginner
13,391 Views

No matter the file size or complexity of the design, it's just too laggy

0 Kudos
Reply