Intel® ARC™ Graphics
Get answers to your questions or issues when gaming on the world’s best discrete video cards with the latest news surrounding Intel® ARC™ Graphics
1712 Discussions

Teams crash on Lenoxo X1 Yoga Gen 6

asdas12
Novice
1,032 Views

I'm consistently seeing Microsoft Teams crash when in a meeting and present my desktop.  I normally have a dual display configuration and present 1 screen as my desktop.  After about 30sec to 5min, then Teams will crash. 

IGD 31.0.101.4255 [3/16/2023] is the graphics driver installed on my laptop.  I tried upgrading to IGD 31.0.101.4255 to see if this Teams crash is resolved, but I see a driver regression causing display corruption.  For more details on the display corruption issue, see https://community.intel.com/t5/Intel-ARC-Graphics/Display-corruption-on-Lenovo-X1-laptop-when-power-is-plugged-in/m-p/1517488#M7161.

Since I have WinDbg installed, then when I load WinDbg after Teams crashes, then I see igd10um64xe at the top of the call stack.  This appears to be a different Intel Graphics driver issue, though I could be wrong.  Even if Teams is misbehaving at an app level, the Intel Graphics user mode driver should properly handle this kind of issue.  I upgraded to the latest Intel Graphics driver to see if this bug has been fixed, but now I see a display corruption with the latest IGD graphics driver. I have a minidump available that's available upon request for this Teams crash.

In summary, there are 2 different IGD issues - (1) IGD 31.0.101.4255 has the Teams issue, (2) 31.0.101.4644 [8/11/2023] has display corruption.  This post is for tracking Issue (1).

 

0:102> k

# Child-SP RetAddr Call Site
00 000000e5`0cffe730 00007ffc`79e2909a igd10um64xe!ctlClose+0x3819801
000000e5`0cffe760 00007ffc`79e225f8 igd10um64xe!ctlClose+0x37d9a02
000000e5`0cffe7a0 00007ffc`79e22f14 igd10um64xe!ctlClose+0x312f803
000000e5`0cffe8b0 00007ffc`7f4f1324 igd10um64xe!ctlClose+0x31c1404
000000e5`0cffe930 00007ffc`15109b39 d3d11!CContext::TID3D11DeviceContext_UpdateSubresource_<2>+0x4a4
000000e5`0cffea50 00007ffc`15108b32 ssScreenVVS2!DxgiDuplicateMonitorHw::drawPointer+0x33d
000000e5`0cffebd0 00007ffc`1510ab19 ssScreenVVS2!DxgiDuplicateMonitorHw::duplicateOutput+0x25e
000000e5`0cffed60 00007ffc`15129eb6 ssScreenVVS2!DxgiDuplicateDesktopHw::duplicateOutputHw+0x10d
000000e5`0cffee20 00007ffc`1511a5a8 ssScreenVVS2!DuplicateDesktopStrategy::CaptureFrame+0x306
000000e5`0cfff490 00007ffc`1511baa3 ssScreenVVS2!ThreadSafeSwitchableStrategyWrapper::CaptureFrame+0x48
000000e5`0cfff4d0 00007ffc`1511bc5a ssScreenVVS2!ScreenScraper::Impl::DesktopSharing::captureFrame+0x7f
000000e5`0cfff570 00007ffc`1511bd8e ssScreenVVS2!ScreenScraper::Impl::captureFrame+0x42
000000e5`0cfff5b0 00007ffc`1511559d ssScreenVVS2!ScreenScraper::captureFrame+0x1e
000000e5`0cfff5f0 00007ffc`151152d7 ssScreenVVS2!ScreenScraperBase::_deliverFrame+0x41
000000e5`0cfff650 00007ffb`eba745ea ssScreenVVS2!ScreenScraperBase::_captureProc+0x187
000000e5`0cfff6f0 00007ffb`eba7ef9c skypert!SplOpaqueUpperLayerThread::run+0x7a
000000e5`0cfff740 00007ffb`eba78b84 skypert!auf::priv::MRMWTransport::process1+0x68
000000e5`0cfff780 00007ffb`eba78887 skypert!auf::ThreadPoolExecutorImp::workLoop+0x14c
000000e5`0cfffa80 00007ffb`eba17b39 skypert!auf::tpImpThreadTrampoline+0x47
000000e5`0cfffac0 00007ffb`eba17cd7 skypert!spl::threadWinDispatch+0x19
000000e5`0cfffb00 00007ffc`96029363 skypert!spl::threadWinEntry+0x167
000000e5`0cfffb80 00007ffc`969c26ad ucrtbase!thread_start<unsigned int (__cdecl*)(void *),1>+0x93
000000e5`0cfffbb0 00007ffc`984aaa68 KERNEL32!BaseThreadInitThunk+0x1d
000000e5`0cfffbe0 00000000`00000000 ntdll!RtlUserThreadStart+0x28

0 Kudos
1 Solution
asdas12
Novice
925 Views

I found a workaround by disabling the GPU for Teams.  The workaround was...In Teams -> click 3 dot menu in top-right -> Settings -> General -> Click to enable "Disable GPU hardware acceleration".  Then, quit Teams by right-clicking on the Teams icon in the bottom-right taskbar and clicking Quit.  Then, delete everything in C:\Users\<username>\AppData\Roaming\Microsoft\teams\GPUCache\*.  Then, restart Teams by right-clicking on the Teams icon in the bottom-right taskbar and select Quit.

Teams hasn't crashed after doing a test meeting with camera+desktop presentation for 30min+.  Hope this helps someone else facing the same problem.  This causes the CPU to peak up to 60% since all that Teams GPU work is being processed in the CPU, so there is a reduction in power efficiency, but at least Teams is not crashing.  Just need to keep my computer plugged in when using Teams, which is fine for me.

Feel free to close this issue.

View solution in original post

0 Kudos
4 Replies
Alberto_R_Intel
Employee
986 Views

asdas12, Thank you for posting in the Intel® Communities Support.

 

We are sorry to hear about this issue and we will be more than glad to assist you with this matter. 

 

For this scenario, it is important to mention that it is always recommended to install the graphics driver provided by the manufacturer of the computer, since that driver was customized by them to work with your specific platform.

 

I looked on Lenovo's website and the latest graphics driver version they have available is 31.0.101.4255, which is the one you are reporting as showing the crash issue with Microsoft Teams:

https://pcsupport.lenovo.com/us/en/products/laptops-and-netbooks/thinkpad-x-series-laptops/thinkpad-x1-yoga-6th-gen-type-20xy-20y0/downloads/driver-list/component?name=Graphics%20Processing%20Units%20%28GPU%29%20and%20Server-AI%20Accelerators&id=635380F4-448F-4129-AA77-265289D96F6F

 

Even though you mentioned this post is for tracking issues, since the problem remains with the graphics driver provided by Lenovo, and additionally, when installing driver version 31.0.101.4644 there is a display corruption, please try a clean installation of our latest Intel® graphics driver version 31.0.101.4669, following the instructions in the links below:

https://www.intel.com/content/www/us/en/download/785597/intel-arc-iris-xe-graphics-windows.html?wapkw=iris%20xe%20graphics

https://www.intel.com/content/www/us/en/support/articles/000057389/graphics.html

 

We also suggest to get in contact directly with Lenovo Support to make sure the latest BIOS version is currently installed in your machine or, if necessary, to gather the instructions on how to update it:

https://support.lenovo.com/us/en

 

If the issue persists after that, just to confirm, when you refer to graphics corruption, could you please describe what is the specific graphics problem that you are observing?
Is there a picture that you can share about this issue?

 

Please attach the SSU report so we can verify further details about the components in your platform, check all the options in the report including the one that says "3rd party software logs":
https://www.intel.com/content/www/us/en/support/articles/000057926/memory-and-storage.html

 

Any questions, please let me know.

 

Regards,

Albert R.

 

Intel Customer Support Technician

 

0 Kudos
Jocelyn_Intel
Employee
954 Views

Hello, @asdas12  

 

I am checking this thread and I would like to know if you were able to review our previous post.  

 

Best regards,  

Jocelyn M.   

Intel Customer Support Technician. 


0 Kudos
asdas12
Novice
926 Views

I found a workaround by disabling the GPU for Teams.  The workaround was...In Teams -> click 3 dot menu in top-right -> Settings -> General -> Click to enable "Disable GPU hardware acceleration".  Then, quit Teams by right-clicking on the Teams icon in the bottom-right taskbar and clicking Quit.  Then, delete everything in C:\Users\<username>\AppData\Roaming\Microsoft\teams\GPUCache\*.  Then, restart Teams by right-clicking on the Teams icon in the bottom-right taskbar and select Quit.

Teams hasn't crashed after doing a test meeting with camera+desktop presentation for 30min+.  Hope this helps someone else facing the same problem.  This causes the CPU to peak up to 60% since all that Teams GPU work is being processed in the CPU, so there is a reduction in power efficiency, but at least Teams is not crashing.  Just need to keep my computer plugged in when using Teams, which is fine for me.

Feel free to close this issue.

0 Kudos
Jocelyn_Intel
Employee
922 Views

Hello, @asdas12

 

Thank you for the information provided, we appreciate you letting us know about this.


This thread will no longer be monitored, but if you need further assistance, feel free to contact us back and submit a new post. 

 

Have a great rest of the week. 

 

Best regards,  

Jocelyn M.   

Intel Customer Support Technician. 


0 Kudos
Reply