Intel® Business Client Software Development
Support for Intel® vPro™ software development and the technologies associated with Intel vPro platforms.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
1355 Discussions

Can I enable AMT without installing an operating system?

mike_h
Beginner
101 Views
Hi all, this AMT newbie is tearing his hair out...
I've got a newly-built Intel D965GF-based PC, no OS installed, and I'm trying to coax some response out of AMT by BIOS-twiddling alone, so far with no success at all. Configured the ME to be always on, set up AMT in small-business mode, DHCP enabled, changed the computer name from the default "iDBO", set a test domain-name. I've created a minimal network - a Netgear router acting as DHCP server and gateway, a laptop to monitor the router state, and the '965 PC.
AMT does nothing at all - doesn't even show up as connected to the router! Also tried setting a static IP address in the AMT configuration, but still can't get a response (using AMT Commander discovery, or PING, or using the browser to connect to :16992).
I've scanned through numerous documents, both from the Intel website and elsewhere, but none of them have made clear whether I need to install Windoze and some AMT/ME drivers on the test PC - I thought this was one of the main points of AMT, to administer a PC with a non-bootable OS?
All suggestions gratefully received...

Thanks, Mike

0 Kudos
6 Replies
john_prothro
Beginner
101 Views
Did you provision the unit? I did not see thatin your sequence of steps.
mike_h
Beginner
101 Views
Under "Provisioning Configuration", I set it to "Small-Medium Business", and all the server-address options disappeared (as expected). Is there something more I should be doing here?

Thanks, Mike

john_prothro
Beginner
101 Views
ok... this is going to sound dumb... I do not even know what you are talking about... what I mean by that is I am not familiar with the system/tool that you have apparently made the "provisioning configuration" selection on. I am used to doing it the very old fashion way... like with the sca in the sdk. However, all is not lost... someone that is familiar with your tool that you are using will chime in and read my silly post and realize that you do need help...
mike_h
Beginner
101 Views
Yeah, there was me thinking that using a gen-yew-wine Intel motherboard to evaluate AMT would be a good idea - all the instructions I've read so far describe slightly different BIOS options. The big stumbling block is that it shows no sign of even acquiring an IP address from the router, so just managing to discover it on the network would make my day...

Thanks anyway, Mike

mike_h
Beginner
101 Views
SORTED IT!

Setting a ME password of "Password_1" is allowed by the BIOS, but the ME engine doesn't like it. Changing the password to "Password1!" fixed the problem. Only took two days to find that - thanks Intel!

Gael_H_Intel
Moderator
101 Views

Hi,

I'm not sure I understand how your Bios was accepting the "Password_1" but the ME wasn't. When I tried to change my ME password to that, it rejected it right away. Maybe you are adding an additional password for your Bios? If that's the case then the Bios simply uses a different level of password strength, I suppose. But your comment was interesting so I did some digging around and there are a couple places in the SDK docs (Network Interface Guide, for example) that do spell out what the rules are for the ME password. I blogged it - if your are interested check it out. What I found out was that there are many interpretations for howstrong password is constructed. The blog below details what our NIG states. And Microsoft says that space characters do not count toward the characters that give the password it's strength (I'm figuring that the underscore may be considered a space character.)

Strong Passwords and Other Shades of Gray

Reply