Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Gael_H_Intel
Moderator
46 Views

I have a WMI Provider SDK Sample Question!

Jump to solution

Lance? Andy? RB? Anyone? I'm playing with the new Intel AMT SDK - trying to run the WMI samples. I'm not having much luck. WMI service is running... AMT is enabled (Duh...) :-) Has anyone tried these samples out yet?

0 Kudos
1 Solution
Lance_A_Intel
Employee
46 Views
Good info, thanks Gael.
Another case of needed the latest code.

View solution in original post

8 Replies
Andrew_S_Intel2
Employee
46 Views

For me, the SystemProperties.vbs sample just runs when I click on it (or run it from a command window). So it sounds like it's time for the typical questions!

1. What type of system are you running it on?
2. What kind of error are you getting, if any?
3. Does the system have the IMSS installed? The AMT WMI providerisn't part of IMSS, but it is part of the OS install package for AMT, so if IMSS isn't there, the WMI provider probably isn't there either.

Gael_H_Intel
Moderator
46 Views
Well, it's an OEM system - HP 8100 Elite, Small Form Factor. Yes - IMSS is installed. It crashes on line 24 - the first time it tries to access /root/Intel_ME. It looks like HP did not include the WMI portion of the Install. I'll go out and see if HP has the appropriate software on their website.

BTW - Our AMT 6.0 Toshiba Notebookhas it installed...
Gael_H_Intel
Moderator
46 Views
Here is an update. HP has updatedME Firmware on their support site - the system came with FW version 6.0.3.1195. Theirnewest version is6.0.3.1208- itwas added totheir site on February 19th and this FW fixes some issues with the MPS connections. So it will be a good idea for our community members to check their FW versions.

There is also a new Intel AMT LMS_SOL for AMT 6.xx on the HP Support site (updated on March 28.) I installed this package (sp46890.exe) and now the "Intel_ME"Namespaceshows up in the WMI Control Security Properties. Problem fixed- WMI Samples are not crashing.

Lance_A_Intel
Employee
47 Views
Good info, thanks Gael.
Another case of needed the latest code.

View solution in original post

Gael_H_Intel
Moderator
46 Views
Ok... Not that I'm vain, or anything like that, but could you mark my answer as "Best Answer?" It won't let me do it. And I think it wasthe best answer.
Lance_A_Intel
Employee
46 Views

Being the thread creator, you should be the only one that can mark best answer.

Gael_H_Intel
Moderator
46 Views
I can mark your posts and Andy's post as Best Answer, but not mine. Same is true for the Rating "Feature". I think it's a "Vanity" gaurd.
Lance_A_Intel
Employee
46 Views
Only you can select a best answer for this thread.
Apparently it won't let you select your own.I think it assumesthat all your posts are continuation of the question.
Reply