Intel® Business Client Software Development
Support for Intel® vPro™ software development and the technologies associated with Intel vPro platforms.

IPv4 AMT is not static


I am using Intel AMT version 9.5.35. I used the ACU_Wizard.exe in package IntelSCS_download_package_11.0.0.214\ACU_Wizard to configure Intel AMT password ( I have not enabled AMT vPro in BIOS setting ). I got the IPv4 address from ACUConfig_xxx.log for instance Then I used HLAPI to connect to my AMT to query Hardware Info and the result is successful in our company WiFi network. But after one day, when we came back to work, the IPv4 address was changed. I must use ACU_Wizard.exe to get IPv4 again and the result is

My question is how can I configure the IPv4 is static? 

My computer has FQDN static for instance

Thanks for your help.

0 Kudos
6 Replies

If you have configured your AMT device with ACUWizard then you have all the tools you will need.

In order to set a static IP using the wizard, use the option of "Configure/ Unconfigure this System"

  1. "Configuration Options" Window
    1. Select "Configure via Windows"
    2. Select "Next"
  2. "Configure via Windows" window
    1. Enter "Current Password"
    2. Enter "New Password"
    3. Enter "Confirm Password"
    4. Select "Override default settings"
    5. Select "Network Settings" button
  3. "Network Settings" window
    1. In IP section select "Use the Same IP as the host"
    2. Select "ok"
  4. "Configure via Windows" window
    1. select "Next"
  5. "Profile Encryption" window
    1. enter encryption password
    2. confirm password
    3. Select "Configure"





I tried with your help. But I got the error as following:

2016-03-09 09:18:09: Thread:8432(ERROR) : NetworkSettingClass, Category: LoadSourceForAMTIP Source: NetworkSettingsClass.cpp : NetworkSettings::NetworkSettingClass::LoadSourceForAMTIP Line: 926: Setting a static IP to the Intel(R) AMT device from the host dynamic IP is not permitted.  (HOSTSTATICIP)

Could you please help?

For another question is that I tried to use the ACUWizar​.exe to enable Intel vPro in other computer. I got the trace below:

2016-03-09 13:01:02: Thread:4872(DETAIL) : localhost, Category: GetWiredNetworkSettings Source: vProConfigurationInternal.cpp : vProConfigurationNamespace::vProConfigurationInternal::GetWiredNetworkSettings Line: 2273: -

I mean there is no the info about "-IPv4 Address- 192.168.x.x " in this case.

Could you please help?





Issue #1: I originally understood you wanted to configure the AMT to be static, but according to thread #8432 you have DHCP enabled within the OS. So setting a static IP will not be a good solution.

Question: In your configuration profile are you providing the Wifi connection info of SSID, Encryption scheme, Authentication and passphrase? If so, I would do the following

  1. Find out what the OS reports the Wireless IP to be.
  2. Use a web browser from a 2nd system and connect to the WebUI - http://<WirelessIPAdress>:16992 verifying the connection is available by logging in and verifying the system host name.
  3. temporarily shut down the firewall or allow ping on the vPro client
  4. Initiate a non terminating ping to the vPro device from another system, taking note of the Ping Example: Ping WirelessIPAdress
  5. Temporarily disable the wireless network adapter in the OS on the vPro Device
  6. On the system performing the ping the ping return should drop 2 packets, but pick up again with a different TTL
  7. Re-enabled the wireless network adapter

If the TTL changes in step 6, the profile is correct for your wireless network. If it doesn't pick back up then the Profile is incorrect for your wireless needs. Let me know of your results

Issue #2 - I am not familiar with that specific error message, I would suggest using the ACUWizard option to configure multiple machines and create a profile once in this screen. Create the profile as close as possible to your other method. Once done you will be asked to encrypt the profile and save it.

Once that is done you will need to grab the file from documents/SCS_Profile directory copy it to the configurator folder of the SCS download that you got the ACUWizard from. Then on the vPro device run as admin the command prompt the following string:

acuconfig.exe /lowsecurity /verbose /output file:configlog.txt configamt <profile.xml> /decryptionpassword <password>

As long as it exits with code "0" then it configured just fine, if not send via PM the generated logs


Thanks Joseph​ for your feedbacks.

I think the root cause is that I configured Wifi connection failed. So I got the trace GetWiredNetworkSettings Line: 2273: -. when I used the ACUWizard.exe to configure my AMT vPro without network cable plugin.

But I cannot configure the Wifi Configuration connection. Here is my network setting (SSID is baotran):

(I do not see the place where I setup Wireless IP in ACUWizard.exe)

Could you please advise and help?



The line of "enable synchronization" in your screen capture actually requires the Intel ProSet Wireless drivers to be installed. If your not getting a synchronization pop up, that indicates you are using the default windows or generic OEM Driver. Go to and search for "ProSet" for the download.

If you don't want to use the Intel Driver Package, on the AMT Device please go to the WebUI at http://localhost:16992 and login, there will be a place to add your wireless credentials. This isn't a very scalable solution, but it will get you up and running for testing.

For a more scalable alternative, within the ACUWizard, select configure multiple devices and create a profile. Which you then install from the command line by using acuconfig.exe(found in the same download as ACUWizard)

example: acuconfig.exe configamt profile.xml


Thanks Joseph.

I connected AMT vPro through WiFi successful.