Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
84 Views

Intel AMT Agent Connection Problem

Hi there,

i am fairly new to Intel AMT Technology but i have gone through so many videos, articles and tutorials on the web site. i am trying to contact to Intel AMT enabled device through Manageability tool kit but i does not connect to machine at all. intially i was thinking that there could be problem on the manageabilty console side but later on i found that the Intel AMT enabled agent does not show web-UI page at all when i type http://ip-address:16992

i have gone through the BIOS AMT settings videos as well which is at
http://software.intel.com/en-us/videos/how-to-setup-a-intel-amt-client-on-a-notebook-pc/

i dont have any luck in that at all, please help me to resolve this issue.

the machine which have intel AMT enabled has following configuration:

Dell Optiplex 755
Intel Core2 vPro

looking further for your suggestions.

thanks.
0 Kudos
9 Replies
Highlighted
84 Views

Quoting - tejs
Hi there,

i am fairly new to Intel AMT Technology but i have gone through so many videos, articles and tutorials on the web site. i am trying to contact to Intel AMT enabled device through Manageability tool kit but i does not connect to machine at all. intially i was thinking that there could be problem on the manageabilty console side but later on i found that the Intel AMT enabled agent does not show web-UI page at all when i type http://ip-address:16992

i have gone through the BIOS AMT settings videos as well which is at
http://software.intel.com/en-us/videos/how-to-setup-a-intel-amt-client-on-a-notebook-pc/

i dont have any luck in that at all, please help me to resolve this issue.

the machine which have intel AMT enabled has following configuration:

Dell Optiplex 755
Intel Core2 vPro

looking further for your suggestions.

thanks.

I've seen some indications of people who ran into issues provisioning an Optiplex 755 before. Your system has a vPro sticker on it, correct?

I did find this link on Dell's site that showed what to do when you got a new board to configure it for manageability: http://support.dell.com/support/topics/global.aspx/support/dsn/document?c=us&cs=04&l=en&s=bsd&docid=.... This isn't directly pertinent to you, but does have some information about how to confirm the board is set for AMT mode instead of ASF mode, as well as how to get into the MEBx with Ctrl+P, and confirm that the mode was AMT instead of ASF.

How far were you able to get on provisioning AMT? Were you able to get into the MEBx with Ctrl+P and change the password?

Andy
0 Kudos
Highlighted
Beginner
84 Views


I've seen some indications of people who ran into issues provisioning an Optiplex 755 before. Your system has a vPro sticker on it, correct?

I did find this link on Dell's site that showed what to do when you got a new board to configure it for manageability: http://support.dell.com/support/topics/global.aspx/support/dsn/document?c=us&cs=04&l=en&s=bsd&docid=.... This isn't directly pertinent to you, but does have some information about how to confirm the board is set for AMT mode instead of ASF mode, as well as how to get into the MEBx with Ctrl+P, and confirm that the mode was AMT instead of ASF.

How far were you able to get on provisioning AMT? Were you able to get into the MEBx with Ctrl+P and change the password?

Andy


Hi Andrew,

yes i am able to config MEBx and AMT settings using Ctrl+P command, this is all fine and machine boots and comes up with message saying that Intel AMT technology is enabled on your machine. but when i try to launch the WebUI just to make sure that everything is fine it does not come up with anything. it shows error page in internet explorer.

i have tried connecting to both the port i.e. 16992 and 16993 but no luck.

i gave another try with Manageabitlity Commander as well but could not suceed through that as well. this is the exception which i get from commander.

System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 192.168.0.26:16993
at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
at System.Net.Sockets.Socket.InternalConnect(EndPoint remoteEP)
at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Int32 timeout, Exception& exception)
--- End of inner exception stack trace ---
at System.Net.HttpWebRequest.GetRequestStream()
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
at SecurityAdministrationService.Invoke(String methodName, Object[] parameters)

please direct me.

many thanks.

Tej.


0 Kudos
Highlighted
84 Views

Quoting - tejs


Hi Andrew,

yes i am able to config MEBx and AMT settings using Ctrl+P command, this is all fine and machine boots and comes up with message saying that Intel AMT technology is enabled on your machine. but when i try to launch the WebUI just to make sure that everything is fine it does not come up with anything. it shows error page in internet explorer.

i have tried connecting to both the port i.e. 16992 and 16993 but no luck.

i gave another try with Manageabitlity Commander as well but could not suceed through that as well. this is the exception which i get from commander.

System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 192.168.0.26:16993
at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
at System.Net.Sockets.Socket.InternalConnect(EndPoint remoteEP)
at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Int32 timeout, Exception& exception)
--- End of inner exception stack trace ---
at System.Net.HttpWebRequest.GetRequestStream()
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
at SecurityAdministrationService.Invoke(String methodName, Object[] parameters)

please direct me.

many thanks.

Tej.



What settings did you set in the MEBx? If you configured in the MEBx, you configured for SMB mode, correct?

The main things to make sure that you set are:
A host name
Either DHCP on, or an IP address
SMB mode (of course)
Confirm that the power setting is set for on in all states (S0, S3-S5)

Also, there is a setting in the MEBx where you can enable or disable the WebUI, just confirm that's on.
0 Kudos
Highlighted
Beginner
84 Views

Hi all...
I also user the Optiples 775 for develop our own management tool for final year project of my campus. I there I used the manual configurations of Intel ME. i didnt get DHCP configurations. I suggest you to firstly go through with the manual configuration of the ME like manually give the IP address for the remote machine and check. I also user the small Business provisioning mode for the configurations. I think that is bit more easy for the testing purposes. And the learning purposes.

0 Kudos
Highlighted
Beginner
84 Views

Hmm finally it solves my problem and i am able to provision my machine properly, what i missing was changing the provision model to small business model and configuring the static IP address. setting these parameters solved my problem but i am still curious to know how changing the DHCP to dynamic and changing the provisioning mode to Enterprise impact the AMT device ?

if you guys can give me some inlight on that that would be great and also please let me know how to provision the machine for Enterprise mode.

many thanks.

Tej.
0 Kudos
Highlighted
Beginner
84 Views

HI all....


Isn't there any way of provise AMT Devices for take IP form the DHCP with out using use Intel SCS. are there any way of doing thins pls tel me. i also used the Small Business provisioning mode with Static IP addressing. but need to go enterprise version and the DHCP IP addressing.

thanks.
JaNa
0 Kudos
Highlighted
Valued Contributor I
84 Views

Hi JaNa,

An AMT system can be provisioned is several ways: SMB mode with static IP, SMB mode with DHCP, Enterprise mode with SCS, Enterprise mode with DTK Director, and Enterprise mode with SCA from the SDK. For testing purposes (not for production), the DTK Director is very easy to use to configure systems in Enterprise mode. Actually, it's easier than going into the MEBx on each machine and using SMB mode. Just go into DTK Director, setup a security profile, create a USB provisioning key, and insert the key into each target system. The systems will get an address from your DHCP server and they will start sending hello packets to the system running the Director. You must make sure that the system running the Director is named ProvisionServer, or you need to make sure that the USB provisioning key contains the setup server IP address field. Getting systems setup with a test provisioning server really isn't that difficult, you just need to make sure that you understand the process, so ask any questions that you need until you understand what you are trying to accomplish.

Regards,
Roger
0 Kudos
Highlighted
Beginner
84 Views

Hi, I use ASUS BM-5235(AMT 3.0) test INETL AMT DTK, install intel DTK on BM-5235(support Vpro)&My Notebook(Not support Vpro), I already setup BM-5235's MEBx, HOST NAME+DHCP+SMB mode+SOL/IDE-R,but have many problem: 1.use DTK's Commander Tool,I can connect to BM-5235, in 'remote control','SOL' & 'IDE-R' & 'Rediction Port' all display "enable", but,in 'Intel Management Engine','Remote Access' display "Unsupported". How to do make 'Remote Access' display "supported" ???????? 2.SOL must BM-5235 in WINXP and enable Serial Agent in DTK's 'Manaeability Outpost Tool', my notebook could be use SOL connect to BM-5235, it means when BM-5235 in BIOS do'nt enable Serial Agent i can't connect BM-5235, How to do make me can remote control BM-5235 BIOS???????? 3.BM-5235 XP enable Serial Agent, My notebook XP use command tool 'take control' connect to BM-5235, IDE-R active ,I mount a DVD ISO but i do'nt see anything both my notebook&BM-5235, use command 'upload /?' select a file upload to BM-5235 ,SOL display uploading, but after upload "terminal tool" no response and BM-5235 do'nt see the upload file.........
0 Kudos
Highlighted
Employee
84 Views

Hello wingvk,

Remote Access is not the indication for SOL & IDER. It is for features like Fast Call for Help which became available inAMT 4.0/5.0.

The start here guide has good info on getting your AMT system setup and confiured for use.

More specific information on enablingand using SOL & IDER can be found in the Redirection Library Design Guide.pdf, which is located in the DOCS folder of the AMT SDK.

You should alsotake a look at these videos:
SOL: http://software.intel.com/en-us/videos/demo-of-intel-amt-serial-over-lan-sol-feature/
IDER: http://software.intel.com/en-us/videos/demo-of-intel-amt-ide-redirect-feature/
0 Kudos