Intel® Business Client Software Development
Support for Intel® vPro™ software development and the technologies associated with Intel vPro platforms.

Intel FPT tool for Linux error 680 and 64

Mschauer
Beginner
684 Views

Hello, 

I have a problem with the FPT tool for Linux. I want to disable the Manufacture Mode of the ME.  Unfortunately I get the following error with the command FPT -closemnf NO. also an attempt to flash the BIOS ( FPT -f xx.bin ) brings the same error. 

I use the FPT version matching the installed ME version.

 

Intel (R) Flash Programming Tool Version: 12.0.72.1757
Copyright (C) 2005 - 2021, Intel Corporation. All rights reserved.


Error 680: Read MMIO failed.

Error 680: Read MMIO failed.

Error 64: Failed to initialize SPI interface.

FPT Operation Failed.

 

I have already tested different Linux versions. Debian 10 kernel 4.19. , Debain 11 kernel 5.10 , Ubuntu 16.4. unfortunately the same problem. 

 

at lspci -vvv i see the driver for HECI Controller is loaded. Kernel modules: mei_me

 

Basically I have also tested it with a Windows version. There everything worked. 

However, I need the Linux environment. 

 

Now the question . what is wrong ?  Bios setting , missing Linux kernel driver ? 

 

0 Kudos
0 Replies
Reply