Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
18 Views

Intel SCS and RCT.EXE Problems

Hi,
We have 2 Dell Optiplex 755 and have removed the battery on them to restore them back to factory settings (I hope this also resets the AMT back as well).. These machines are AMT 3.0 devices.

We have setup a windows server 2003 using VMWare, along with SQL Express, IIS, DotNet Framework 2. Then installed the Intel SCS and configured it to use another external CA on the network. This all appears to be working ok, from what we can see.

We installed the Verisign public root certificates on the machine as well, as the dell has 4 certificates on it by default, 2 of which are from verisign.

We were expecting the machines to start sending messages out to the provision server automatically. But can't seem to see anything coming through requesting..

So then tried running RCT.EXE on the DELLs to try and connect to the SCS..
This showed a little more progress, except it didn't seem to work. After checking the log file, we got the following:

-- Start --
Step Into: CheckAMT
Connected to HECI driver, version: 3.0.30.1086

BIOS Version: A03

Intel AMT code versions:
Flash: 3.0.4
Netstack: 3.0.4
AMTApps: 3.0.4
AMT: 3.0.4
Sku: 12
VendorID: 8086
Build Number: 1120
Recovery Version: 3.0.4
Recovery Build Num: 1120
Legacy Mode: False


Setup and Configuration:
In process

Provisioning TLS Mode:
PKI
Step Into: GetHostFQDN
host Name is gibbo1.amtestdomain.local
Step Into: CSCSER::PerformSCSRemoteConfiguration
Step Into: CSCSER::SCSSetAMTIdentity
Step Into: CSCSER::SCSCreateOTP
AMT version: 3.0 Step Into: StartConfiguration

BIOS Version: A03


Intel AMT code versions:
Flash: 3.0.4
Netstack: 3.0.4
AMTApps: 3.0.4
AMT: 3.0.4
  ; Sku: 12
VendorID: 8086
Build Number: 1120
Recovery Version: 3.0.4
Recovery Build Num: 1120
Legacy Mode: False


Setup and Configuration:
In process

Intel AMT Mode:
Non Legacy

Zero Touch Configuration:
enabled

Provisioning TLS Mode:
PKI

RNG seed status:
exists

PT_STATUS_INVALID_PT_MODE: Command is not permitted in current operating mode.
Activate Intel AMT configuration:
failure
PT_STATUS_INVALID_PT_MODE: Command is not permitted in current operating mode.Exit with code 2

-- End --

From what we can tell the error code 2, which means that it
'Platform is already in setup and configuration mode.'

After looking at the code, it looked like it was failing when the RCT.EXE was calling
SetProvisioningServerOTP.

Anybody got any ideas..

Many thanks
0 Kudos
2 Replies
Highlighted
Employee
18 Views

Hi Gibbo,

This forum is mainly intended for developers running into issues developing applicationsusing AMT SDK and SCS. For questions/problems related to SCS installation/usage mainly faced by end-users, IT-Admins, please use this site.

Thanks.

0 Kudos
Highlighted
Beginner
18 Views

Hi Akillendula,
Sorry did know that was another site just for scs and RCT..
I am a developer, just trying to get my head around everything at the moment..

Will post on the forum you suggested instead.

Many thanks

0 Kudos