Community
cancel
Showing results for 
Search instead for 
Did you mean: 
58 Views

Need help on calling the Remote Control file of SDK

I am getting the error when I try to call the RemoteControl sample which is provided in AMT SDK.

I am doing the following steps for executing the sample.

In windowsXP first I am connecting to the AMT machine by opening the winRM and listener after that I am giving the path of the RemoteControl.exe which is in bin folder by passing the arguments as follows

RemoteControl -api -host -user admin -pass -c

-c for getting the capabilities of remote control

The error I am getting is

The client cannot connect to the remote host specified in the request.WinRM service error returned: The winRM client cannot process the request.Uncrypted traffic is currently disabled in the client configuration.Change the client configuration.

0 Kudos
3 Replies
Andrew_S_Intel2
Employee
58 Views

That sounds like you need to configure WinRM to allow unencrypted traffic. That's pretty easy to do, just follow the instructions in Ajith's blog post about that here:http://software.intel.com/en-us/blogs/2007/12/13/does-amt-support-ws-man/ . Also, confirm that your installation of Windows XP has WinRM, WinRM is a separate install in Windows XP (it was first included by default in Windows Vista/Windows Server 2008).
IDZ_A_Intel
Employee
58 Views

Thanks for the reply Andrew.

I followed the path that is provided in the link. After congiguring WS-Man again I tried to run the Remote Control sample then it giving error like:

The client cannot connect to the remote host specified in the request

WinRM service error returned:The WinRM client cannot process the request.If the authentication scheme is different from Kerberos, or if the client computer is not joined to the domain, then HTTPS transport must be used or the destination machine must be added to the TrustedHosts configuration setting.Use winrm.cmd to configure the trustedhosts.

I am running the winrm.cmd but I am not getting how to configure.

Please help me out from this

Thanks in advance

Andrew_S_Intel2
Employee
58 Views

From reading the error, that sounds like the AMT System you are trying to connect to isn't in the trusted hosts list. How to add systems to the trusted hosts lists is in the link I posted previously, an example is in the 3rd bolded command line argument example:

winrm set winrm/config/client @{TrustedHosts="*.mydomain.com,myAmt1,192.168.0.101,localhost"}

At the most basic, you can add the IP address of your AMT system to the TrustedHost list.

Your AMT system is configured in SMB mode with just http enabled, correct? Or have you used SCS or another mechanism to configure TLS or Kerberos?

Reply