Intel® Business Client Software Development
Support for Intel® vPro™ software development and technologies associated with Intel vPro platforms.
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.

Unresponsive MEBx in laptop


I'm trying to understand what's going on with a 2nd hand Dell Latitude XT2.
Once the laptop has booted its OS, it works just fine, but the boot phase is very slow.
For what I can see something is not right with the Intel MEBx.

At the boot, first I see the Dell boot logo, then for 52-53 seconds I see a black screen with a blinking underline cursor, then finally the machine access the MBR and shows the OS bootscreen.
* during those 53s there is no attempt to access CD or HDD, and no activity on the ethernet (so no netboot)
* if from the F12 Boot options I select 'Intel Management Engine Boot Extensions (MEBx)' I get a screen titled 'Intel Management Engine Boot Extensions (MEBx) v.' and the text 'ME is initializing' which lasts once again for the exactly 53 seconds, then it goes to the OS boot screen without any further message.
* F12 + select HDD incurs in the same 53s penalty time before seeing the OS boot screen
* I tried to flash the BIOS using Dell utilities (which is a two-stages flashes, first Intel ME, then BIOS) and while the laptop BIOS gets correctly flashed, for the ME part it gets stuck for a few minutes until probably the flash tool timeouts and aborts. The messages on the screen are:
ME Firmware Image was found - CRC-32 is correct
Flashing ME Firmware image:
Initiating F/W Update... ME Firmware Update failed (Error Code: 8725)
-> Failed to receive last update status from the firmware
* I also tried to remove the socketed flash chip that should contain the BIOS and use an external programmer to reflash the BIOS, but it did not help, even if including also a 'reset to default settings' and removing the CMOS backup battery, and even with a different BIOS version.
* Windows seems to see an 'Intel Active Management Technology - SOL' device, but communication with that device doesn't seem to work.

Can anyone help me understand what's the problem with this laptop? If no simple fix is possible I'd be happy to entirely disable ME, but... is it possible, and how?
Or is it just a faulty mainboard?


0 Kudos
0 Replies