Community
cancel
Showing results for 
Search instead for 
Did you mean: 
sonofgrey
Beginner
167 Views

problem with HECI and network connection?

Hi all,

I have a Dell OptiPlex 755 which has Intel AMT stuff onboard.

I need to connect remotely to this pc regularly through VNC or FTP, but it seems to lost its connection every so much time. I can not connect to it anymore, but when someone on that pc uses internet, I can connect from the outside again. It sounded like power savings settings from the NIC at first, but these are off.

I now suspect this Intel AMT to be interfering because I see some events from the HECI driver in the System Event Log sometimes right before the connection is gone.
The event says "HECI driver has started successfully.".
Then followed by an event 33 e1express.
Then one from 4201 Tcpip "The system detected that network adapter DEVICETCPIP_{.....} was connected to the network, and has initiated normal operation over the network adapter.".
After that several services are (re-)started by "Service Control Manager".

What is happening here exactly?

Through the BIOS I disabled the Intel Management Engine because it was using a COM port. That pc needs lots of COM ports at fixed positions/assignments, and this Intel ME was intervening. Since I thought I did not need it, I disabled the device in the BIOS and in the device manager.
Under Device Manager > System Devices however, there's still a "Intel Management Engine Interface". Should I disable this too to keep this HECI driver from doing anything?

Thank you very much for pointing me in the right direction.
If you need extra info, I'd be happy to provide it to you!
0 Kudos
1 Reply
sonofgrey
Beginner
167 Views

Hi,

Just wanted to let you know that so far I have been able to properly connect to this pc through VNC for more than a week now. The events I mentioned earlier (tcpip,...) are also gone.

To get here I indeed disabled the "Intel Management Engine Interface" device (and renamed its HECI.sys driver) in the device manager. Apparently this was enough...I hope :)

Thanks for your support!
Reply