Intel® Collaboration Suite for WebRTC
Community support and discussions on the Intel® Collaboration Suite for WebRTC (Intel® CS for WebRTC).
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
For the latest information on Intel’s response to the Log4j/Log4Shell vulnerability, please see Intel-SA-00646

CPU Usage At MCU Server is High

Naresh_R_1
New Contributor I
166 Views

Hi,

Can someone help how to reduce CPU usage at server end

 

CPU Usage at server end is getting increasing when more streams added 

CPU Configuration is:

Processor: Intel Xeon CPU E550@2.83Ghz x 4,  Ram: 4Gb, 

Ubuntu 12.04 64 Bit, Kernel Linux: 3.13.0-32-generic

 

Thanks

Naresh

 

 

0 Kudos
6 Replies
Farrukh_M_
Beginner
166 Views

I have the same issue. Even with 1 stream, CPU goes to 96%. Maybe the issue is with the codec Intel is using?

Regards

 

Chunbo_H_Intel1
Employee
166 Views

Hi guys,

Can you tell me which conference mode you're using? Forward or mix?

Since now we create rooms which can produce both forward streams and mix streams, you can disable mix streams from etc/woogeen_config.js with config.erizoController.mixer.

Bernard
Black Belt
166 Views

You should definitely try to profile with VTune which will be able to find major hotspots in the code. Those hotspots can be a reason for CPU hog.

Chunbo_H_Intel1
Employee
166 Views

Yes, sure. Plenty of tools can be used for CPU hotspot.

Helping us with detailed information/analysis on this will be warmly welcome!

Bernard
Black Belt
166 Views

Usually some kind of loop or loop terminating condition or even synchronization issue can be responsible for overloading CPU.

Chunbo_H_Intel1
Employee
166 Views

Yes, that's the most and general case. Here, I think the CPU hotspot is the media configuration on MCU server...

As I mentioned, the default hybrid conference room will produce both mixed and forward streams at the same time, which consumes much CPU time.

And we're going to provide the default conference room without hybrid capability.

Reply