Intel® Collaboration Suite for WebRTC
Community support and discussions on the Intel® Collaboration Suite for WebRTC (Intel® CS for WebRTC).
Announcements
Intel Customer Support will be observing the Martin Luther King holiday on Monday, Jan. 17, and will return on Tues. Jan. 18.
For the latest information on Intel’s response to the Log4j/Log4Shell vulnerability, please see Intel-SA-00646
1135 Discussions

Socket connection error with sample sip_gateway

SaiSrinivas_D_
Beginner
170 Views

Hi All,

I am a developer looking for WebRTc to SIP gateway and found this Intel's product.

I have seen the code and wanted to run the sample sip gateway provided in the software bundle.

But I am running into the following error while loading it.

Failed to load resource: http://0.0.31.144:3001/socket.io/1/?t=1431602941967 ;

net::ERR_INVALID_ARGUMENT

What have I done:

  1. Copied the public folder of Release-v1.1.1/extras/sipgw_sample to my webserver.
  2. loaded the index.html page of public folder.
  3. i tried to login with a SIP account and it shows a connection error on the screen (screenshot attached)
  4. In the browser's console log, I found the socket connection error.

Note: the sample application is not connecting to socket.io.js in anyway. 

I have added the port number 3001 to the url and tried, but still the error is same.

Please help me resolve this error.

Thanks & Regards,

Srinivas

0 Kudos
1 Reply
Chunbo_H_Intel1
Employee
170 Views

Hi Sai,

Thanks for the tryout of SIP GW. We now have people working on your reported issue. Thanks!

Reply