Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor I
6 Views

Chrome Bandwidth upload issue

Dear Team,

Chrome is not using the bandwidth available for uploading and video quality getting reduced and poor. this issue we are facing from 2 days

Chrome Version: Version 76.0.3809.100 (Official Build) (64-bit)

 

Thanks

Naresh

Tags (2)
0 Kudos
12 Replies
Highlighted
New Contributor I
6 Views

I am definitely getting this

I am definitely getting this issue, and it is severe. It does not always occur.

It seemed to start with users who used chrome canary, but now it has made its way into chrome stable.

It seems that maybe 70% of chrome users are limited to about 96kbps upload rate. The video quality is horrible.

So far it seems that if someone has bad quality, or good quality, as long as they don't completely close all their chrome sessions, their quality (good or bad) will remain the same as before, once they return to the website. There's some kind of memory going on. This problem happens with people on ethernet, and wifi. We even have a user on Google Fibre with a 1gbps connection with this problem.

Please look into a fix for this asap <3 !

0 Kudos
Highlighted
New Contributor I
6 Views

Yes thats true. someone has

Yes thats true. someone has bad quality, or good quality, as long as they don't completely close all their chrome sessions, their quality (good or bad) will remain the same as before. once close the browser completely it may or may not work.

This problem is very severe as majority users uses chrome and video quality experience will be very bad.

This problem is not happening with Firefox

 

Thanks

Naresh

 

0 Kudos
Highlighted
6 Views

Please change x-google-max

Please change x-google-max-bitrate to x-google-min-bitrate in owt.js

Also while publishing video supply maxBitrate

It works.

 

Thanks

RP

0 Kudos
Highlighted
6 Views

Workaround for this issue is

Workaround for this issue is

Change x-google-max-bitrate to x-google-min-bitrate in owt.js 

Also supply maxBitrate while publising video.

 

 

0 Kudos
Highlighted
New Contributor I
6 Views

Since intel webrtc is based

Since intel webrtc is based on licode originally it is possible these are the same problems:

https://github.com/lynckia/licode/issues/1368

https://github.com/lynckia/licode/issues/1349

https://github.com/lynckia/licode/issues/1364

I hope this may help the team in finding a fix.

0 Kudos
Highlighted
Beginner
6 Views

We have also facing this

We have also facing this issue. We are tried this  "Change x-google-max-bitrate to x-google-min-bitrate in owt.js",  but issue still exists. 

 

0 Kudos
Highlighted
New Contributor I
6 Views

Hi, I tested changing  x

Hi, I tested changing  x-google-max-bitrate to x-google-min-bitrate in owt.js

Before, even when not stating a maxBitrate, this severe cam quality restriction was still happening.

Now though, when setting a maxBitrate to any figure, it seems to completely uncap the bitrate, as in, there is no way to truly set a max bitrate.

So this is GOOD, in that, we can finally unrestrict bitrate again, but bad in that now we have no way to restrict bitrate to anything reasonable.

 

Does anyone have any other fixes to implement a max bitrate back into this fix? Can we maybe modify owt.js to pass on both a x-google-min-bitrate AND a x-google-max-bitrate ?

maybe if we could set the minimum and the max to the same figure we will finally get what we want.

My main objective is to achieve about 250kbps bitrate on a 320x240 20fps stream. or 450kbps on a 640x480 20fps stream. With the suggested fix, it tries to use about 680kbps on 240p, and on 480p it maxes out my 1000kbps upload so it probably is trying to use even more than that.

 

edit: ok ok i did some further testing. it seems that after CLOSING the browser fully (all tabs) after making that change to owt.js, it is now properly hugging to the max bitrate (actually x-google-min-bitrate). I guess it had some memory of beforehand, and that caused it to uncap it entirely. What a strange annoying issue!!! I wouldn't be surprised if I see this uncapping happen at random again but I will see how things go. Happy in the meantime for this fix.

 

edit2: ugh, the bandwidth my website uses has more than DOUBLED now, this 'fix' is not a fix, in many instances the bitrate remains completely uncapped. We really need a fix that includes both the min and the max.

0 Kudos
Highlighted
New Contributor I
6 Views

Okay guys this issue so far

Okay guys this issue so far seems completely fixed on my end as long as you are specifying a maxBitrate when publishing a video.

in owt.js, change the line

"x-google-max-bitrate"

to

`x-google-max-bitrate=${c.maxBitrate.toString()}; x-google-min-bitrate`

Changing the "" to `` is important as it allows the ${blah} to be used. This will set both your minimum and maximum bitrate to your maxBitrate value, and appears to fix the issue for me so far. Changing it just to min-bitrate was causing most 240p streams to take up 700+kbps each.

0 Kudos
Highlighted
6 Views

Hi Team,

Hi Team,

issue not fixed our side changing bitrate 

"x-google-max-bitrate"   to     `x-google-max-bitrate=${c.maxBitrate.toString()}; x-google-min-bitrate`

please help me regarding this is blocking issue for us , in firefox it is working fine but in chrome browser we are getting this issue 

 

Thank you,

Nikhil

0 Kudos
Highlighted
Beginner
6 Views

@ Stephen  Use your method in

@ Stephen  Use your method in owt.js " x-google-max-bitrate=${c.maxBitrate.toString()}; x-google-min-bitrate " It did

 

But "conference.publish()" must be set   [{maxBitrate: 1562}] 

I don't know if it can be updated later 

 

Thank you !

0 Kudos
Highlighted
6 Views

Hi yt, xia,Even I tried with

Hi yt, xia,
Even I tried with maxBitrate: 1600 , sometimes it worked fine but sometimes same issue got repeated .

Thank You.
Jayaram K

0 Kudos
Highlighted
Employee
6 Views

Does this issue still happen

Does this issue still happen on latest Chrome browser ?

Could you please provide more detail reproduce steps ?  

 

Thanks

Yanbin

0 Kudos