Intel® Collaboration Suite for WebRTC
Community support and discussions on the Intel® Collaboration Suite for WebRTC (Intel® CS for WebRTC).
Announcements
Intel Customer Support will be observing the Martin Luther King holiday on Monday, Jan. 17, and will return on Tues. Jan. 18.
For the latest information on Intel’s response to the Log4j/Log4Shell vulnerability, please see Intel-SA-00646
1135 Discussions

Configuring external IP of WebRTC Gateway

Lars_O_
Beginner
149 Views

Hi,

I am trying to run the WebRTC Gateway on EC2 and I am running in to a problem where the remote candidate IP's returned to my browser is the local IP of the EC2 instance where the gateway is running, and not the external IP of the EC2 instance. Is it possible to configure the WebRTC Gateway to return the external IP of the machine it is running on and not the IP of the interface it is running on?

A more general question is also where I can find documentation of the gateway_config.json?

Thanks,

Lars

 

0 Kudos
5 Replies
Lars_O_
Beginner
149 Views

Note: this happens even when I set the publicIP field of gateway_config.json to the public IP of the machine.

Chunbo_H_Intel1
Employee
149 Views

Which version of SIP Gateway are you using?

Thanks!

Lars_O_
Beginner
149 Views

Hi Chunbo,

I'm using the 3.1 release.

Thanks,

Lars

 

Lei_Z_Intel1
Employee
149 Views

Hi, Lars

It should work with publicIP setting of gateway_config.json. But there is defect in current SIP Gateway. This will be fixed in coming v3.2.1 release. Thanks for your patience.

Best wishes,

Zhai Lei

Nithin_P_
New Contributor I
149 Views

Hi,

            I am using sdk version 3.3. I have configured mcu server in aws server. But the server taking private ip address of the instance for sdp creation.So unable to establish peer connection " woogeen.sdk.js:8 ERROR: publish failed: peer connection failed".

sdp offer like the following

......................................

c=IN IP4 0.0.0.0
a=rtcp:1 IN IP4 0.0.0.0
a=candidate:1 1 udp 2013266431 172.31.23.171 47623 typ host generation 0
a=ice-ufrag:DSf8
a=ice-pwd:n6jpgutZPo925c3DqhQrdq

...............................................................................

In the above sdp ip address is 172.31.23.171. But it is the private ip address of my instance. I need public ip address in place.

I did not configure private ip address anywhere webrtc server automatically ditect the private ip. How can force the intel webrtc server to take public ip address in place private one.

This my application url please check :    https://13.228.230.100:3004/

Thank you,

Reply