Intel® Collaboration Suite for WebRTC
Community support and discussions on the Intel® Collaboration Suite for WebRTC (Intel® CS for WebRTC).
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
For the latest information on Intel’s response to the Log4j/Log4Shell vulnerability, please see Intel-SA-00646

Portal/Controller in Release v3.1

Mark_d_10
Beginner
133 Views

Hi,

I'm trying to make a MCU cluster with version 3.1 In the manual is tells me:

8. Choose worker machines to run portals. These machines must be visible to cliients

9. Edit the configuration items of portals in Release-<Version>/controller/controller.toml.

  • Make sure the rabbit.port and rabbit.host point to the RabbitMQ
  • Make sure the controller.networkInterface is specified to the correct network interface which the clients’ signaling and control messages are expected to connect through.

So I changes the rabbit host, but when I try to start the portal it still tries to connect to localhost (127.0.0.1):

[root@node-1 Release-v3.1]# ./bin/daemon.sh start portal
starting portal, stdout -> /root/Release-v3.1/logs/woogeen-portal.stdout
2016-05-27 08:57:14.859  - ERROR: AMQPER - Connection error... { [Error: connect ECONNREFUSED 127.0.0.1:5672]
  code: 'ECONNREFUSED',
  errno: 'ECONNREFUSED',
  syscall: 'connect',
  address: '127.0.0.1',
  port: 5672 }
Error: connect ECONNREFUSED 127.0.0.1:5672
    at Object.exports._errnoException (util.js:870:11)
    at exports._exceptionWithHostPort (util.js:893:20)
    at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1061:14)

Of course it fails, because the rabbitmq is not running on this machine.

It works fine when i change it for video-agent, audio-agent, cluster-manger, recording-agent.Only for portal it isn't working.

How can I resolve this?

Thanks

 

0 Kudos
4 Replies
Chunbo_H_Intel1
Employee
133 Views

Hi Mark,

Please edit the configuration file before starting the portal.

Thanks!

han_x_
Beginner
133 Views

你好CHUNBO,我在测试中也遇到相同的问题。单独部署Portal到一台服务器,修改其controller.toml中的rabbit.port 和rabbit.host指向实际的rabbitMQ服务器。配置好后启动Portal,甚至试过重启机器后再启动Portal,都是如楼主所写的错误,Portal只连接本地的rabbitMQ!

请帮忙看看这个问题,多谢!

 

Mark_d_10
Beginner
133 Views

Hi Chunbo,

It doesn't matter what I put in the configuration file for the portal under the rabbit host section. It will always try to connect to localhost.

 

Chunbo_H_Intel1
Employee
133 Views

Hi Guys,

Our QA has verified this on both Ubuntu and CentOS cluster machines, and it turns out to be different wrong behaviors. We have already had fix for this, and planned to put it in next release.

Thanks for the patience!

Reply