Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner

Problem with sample application

Hi,

I've successully installed version 3.4 and can get to the admin console and configure rooms. I am now trying the sample app and have run into problems.

I've followed the readme instructions and get the below errors when trying to run this on the same server as the MCU and also tried running it on my mac as well. Please help as I have no way testing the server.

Kind regards

Steve

[root@localhost basic_example]# npm install

npm WARN woogeen.sdk@2.8.0 No repository field.

npm WARN woogeen.sdk@2.8.0 No license field.

[root@localhost basic_example]# node basicServer.js

events.js:160

      throw er; // Unhandled 'error' event

      ^

 

Error: listen EADDRINUSE :::3001

    at Object.exports._errnoException (util.js:1026:11)

    at exports._exceptionWithHostPort (util.js:1049:20)

    at Server._listen2 (net.js:1257:14)

    at listen (net.js:1293:10)

    at Server.listen (net.js:1389:5)

    at EventEmitter.listen (/usr/src/intelmcu/Release-v3.4/extras/basic_example/node_modules/express/lib/application.js:618:24)

    at Object.<anonymous> (/usr/src/intelmcu/Release-v3.4/extras/basic_example/basicServer.js:184:5)

    at Module._compile (module.js:570:32)

    at Object.Module._extensions..js (module.js:579:10)

    at Module.load (module.js:487:32)

[root@localhost basic_example]#

 

Stephens-MacBook-Pro:basic_example stephen.tyers$ node basicServer.js

Failed to setup secured server: Error: mac verify failure

    at Object.createSecureContext (_tls_common.js:151:17)

    at Server (_tls_wrap.js:804:25)

    at new Server (https.js:54:14)

    at Object.createServer (https.js:76:10)

    at cb (/Users/stephen.tyers/nodeapps/extras/basic_example/basicServer.js:190:13)

    at Gunzip.<anonymous> (/Users/stephen.tyers/nodeapps/extras/basic_example/cipher.js:51:5)

    at emitNone (events.js:110:20)

    at Gunzip.emit (events.js:207:7)

    at endReadableNT (_stream_readable.js:1059:12)

    at _combinedTickCallback (internal/process/next_tick.js:138:11)

Stephens-MacBook-Pro:basic_example stephen.tyers$

Tags (2)
0 Kudos
3 Replies
Highlighted
Beginner

i tried changing the port in

i tried changing the port in the basicserver.js to 4000 as it said it was clashing with something running 3001 on the MCU server. IT got further but now seems stuck on verifying the secured server. I followed the instructions and copied the certificate.pfx to the basicapp cert folder and run the tool to initialise the certificate. DO I just put in any password or is it something specific i need?? Also I just used the certificate that came with the MCU package. Should I generate my own using letsencrypt or something?

 

Kind regards

Steve

 

[root@localhost basic_example]# node basicServer.js

1 rooms in this service.

MyRoom Id: 5996b568e8b58b34a816f95e

Failed to setup secured server: Error: mac verify failure

    at Error (native)

    at Object.createSecureContext (_tls_common.js:137:17)

    at Server (_tls_wrap.js:751:25)

    at new Server (https.js:26:14)

    at Object.exports.createServer (https.js:47:10)

    at cb (/usr/src/intelmcu/Release-v3.4/extras/basic_example/basicServer.js:190:13)

    at Gunzip.<anonymous> (/usr/src/intelmcu/Release-v3.4/extras/basic_example/cipher.js:51:5)

    at emitNone (events.js:91:20)

    at Gunzip.emit (events.js:185:7)

    at endReadableNT (_stream_readable.js:974:12)

0 Kudos
Highlighted
Beginner

Hi,

Hi,

I have got further now. I installed letsencrypt on the mcu server and generated a certificate for my MCU server and exported to PFX format with a chosen password. I then ran the initcert.js in each of the three directories under Release and set the same chosen password. The MCU successfully started and I can look at the console and see the demo room in the list. 

I then followed the instructions for the basic example app and npm install, copied the certificate.pfx from letsencrypt over to the cert directory of the basic_sample app, then run initcert.js in basic_sample. Finally I have the server started after changing some listening ports that were clashing on the MCU, but now I am getting invalid token from the javascript console and app output(see below)??? Please help

server connection failed: invalid token  script2.js:373
Run SocketIO sample!!  intelmcu.fonebu.com:5004:43

Kind regards

Steve

 

[root@intelmcu basic_example]# node basicServer.js

1 rooms in this service.

MyRoom Id: 5999a9358d6efa145d82f1f0

GET / 200 13.885 ms - 1840

GET /socket.io.js 304 7.633 ms - -

GET /script2.js 304 5.348 ms - -

GET /woogeen.sdk.ui.js 304 6.693 ms - -

GET /woogeen.sdk.js 304 4.775 ms - -

GET /script3.js 304 3.804 ms - -

GET /adapter.js 304 1.769 ms - -

GET /favicon.ico 404 12.564 ms - 150

POST /createToken/ - - ms - -

GET /?mix=true 200 13.574 ms - 1840

GET /socket.io.js 304 3.115 ms - -

GET /adapter.js 304 2.584 ms - -

GET /woogeen.sdk.js 304 3.248 ms - -

GET /woogeen.sdk.ui.js 304 2.663 ms - -

GET /script2.js 304 2.347 ms - -

GET /script3.js 304 23.577 ms - -

express deprecated res.send(status): Use res.sendStatus(status) instead basicServer.js:99:9

POST /createToken/ 401 60123.780 ms - 12

GET /?room=5999a9358d6efa145d82f1f0 304 1.644 ms - -

GET /socket.io.js 304 2.257 ms - -

GET /script3.js 304 2.125 ms - -

GET /woogeen.sdk.js 304 2.698 ms - -

GET /adapter.js 304 2.733 ms - -

GET /woogeen.sdk.ui.js 304 2.572 ms - -

GET /script2.js 304 2.448 ms - -

POST /createToken/ 401 60085.461 ms - 12

^X^X^C

0 Kudos
Highlighted
Beginner

Hi all,

Hi all,
 
I am very new to webrtc thing and got one example related to webrtc named as " woogeen basic examples".
 
 
Accessing this link from chrome browser and linux 14.04 version shows us 2 windows, publish and subscribe
 
I tried analysing call flow using chrome developer tool and it was quite unstable in each access. 
Issues i faced during this Example was:
 
1) How to Disconnect it ? (I use to close the tab directly as there is no option of disconnection)
 
2) After websocket connection, Sending frames as well as Receiving frames are not in sequence everytime. 
 
SDP messages dont have any stable flow such as sometimes it can be with HTTP links and sometimes it can be under Websocket connection.
 
3) There are two streams i am getting like:
                streamId-1: 5a4cbe4ad1e9c516d26e7067-common
                streamId-2: 649442157782916600
What does it mean by streamId exactly.
 
 
The flow is too unstable to understand. If someone has worked on it Please help us to understand the flow once.
Thanks
0 Kudos