Intel® Collaboration Suite for WebRTC
Community support and discussions on the Intel® Collaboration Suite for WebRTC (Intel® CS for WebRTC).
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
For the latest information on Intel’s response to the Log4j/Log4Shell vulnerability, please see Intel-SA-00646

RabbitMQ Connectivity Problem

Choudhary__Shishir
1,003 Views
After following the single server configuration from https://software.intel.com/en-us/articles/intel-collaboration-suite-for-webrtc I get RabbitMQ connectivity error.

I even installed rabbitMQ myself (because the installation guide does not talk about installing rabbit mq), however I still get below error.

What could be wrong ? 

2018-12-04 22:01:40.901  - INFO: AmqpClient - Connection to rabbitMQ server error { Error: connect ECONNREFUSED 127.0.0.1:5672

    at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1191:14)

  errno: 'ECONNREFUSED',

  code: 'ECONNREFUSED',

  syscall: 'connect',

  address: '127.0.0.1',

  port: 5672 }

 

0 Kudos
2 Replies
Second_Chan
Novice
1,003 Views

ubuntu:

#hostname  localhost

#vi /etc/hosts

add

"127.0.0.1       localhost"

then restart rabbitmq 

#sudo /etc/init.d/rabbitmq-server restart

 

 

 

 

Qiujiao_W_Intel
Employee
1,003 Views

Did you install rabbitmq in a second device than where mcu modules are running? If so, you need to enable remote access in rabbitmq config as in https://www.rabbitmq.com/access-control.html :

This is configured via the loopback_users item in the configuration file.

If you wish to allow the guest user to connect from a remote host, you should set the loopback_users configuration to none. A complete RabbitMQ config file which does this would look like:

loopback_users = none

Or, in the classic config file format (rabbitmq.config):

[{rabbit, [{loopback_users, []}]}].

 

Reply