Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
5 Views

Request for MCU configuration details to work on AWS EC2

Jump to solution

Hello,

We are successfully installed Intel CS for WebRTC (MCU) v.4.1 on CentOS 7.X in our local server and able to run the sample application. Now, we are trying to install the MCU on Amazon (AWS) EC2 instance. By the way, we setup our own STUN/TURN server (CoTURN) in AWS in another instance. The MCU and STUN/TURN servers are in the same VPC. Can anybody please guide us what are the additions/modifications that are needs to be done in configuration files? What configuration files we need to change? Where I have to give STUN/TURN server IP address, credentials details? Where I have to give MCU public IP/private IP address details? Do I need to change network interface names? etc.

It would be really great help to us to move forward in the cloud.

Thank you in advance.

Best Regards,
Chandramouli.

Tags (2)
0 Kudos

Accepted Solutions
Highlighted
Employee
5 Views

How about you align all MCU

Jump to solution

How about you align all MCU access address through IP by removing hostname setting in portal configuration as following?  If that still not help, that should MCU server side problem, check if any error messages in portal server and other node logs.

portal/portal.toml:
    [portal]

    hostname = "ec2-13-55-35-25.us-east-2.compute.amazonaws.com"
    ip_address = "13.55.35.25"
    port = 8080

View solution in original post

0 Kudos
8 Replies
Highlighted
Beginner
5 Views

Hello,

Any help would be appreciated.

Thank you.

Best Regards,
Chandramouli.

0 Kudos
Highlighted
Employee
5 Views

For MCU installation in

Jump to solution

For MCU installation in public cloud, like AWS, please check the MCU Installation/MCU configurations for public access section in Conference Server Guide document. It shows which network interfaces need to be exposed to public network or use public addresses.

For Coturn installation and configurations in public cloud like AWS, please refer coturn documents.

 

0 Kudos
Highlighted
Beginner
5 Views

Hello Lei Zhai,

Jump to solution

Hello Lei Zhai,

We wish you a very happy new year and thank you for your reply. Sure. As you suggested, we will do as per the documentation and update you.

Thank you.

Best Regards,
Chandramouli.

0 Kudos
Highlighted
Beginner
5 Views

Hello,

As you suggested, I have gone through the documentation and tried to run the sample application in AWS cloud. But, unable to run it. I setup two servers in the same VPC. They are MCU server and STUN/TURN (CoTurn) server. As I see, STUN/TURN server is working fine. Also, as a initial step, I opened all ports from anywhere in the firewall. Also, I am using the certificates that is generated using "openssl". I also tried by using the default certificates. But, no luck. For your information, I am able to deploy the MCU server with in our network (office LAN) successfully with default certificates and openssl certificates as well. But, unable to deploy in AWS Cloud environment.

Below are the IP details of the servers (I changed the public IP (Elastic IP) address in the below configuration for security purpose.):

MCU server:
    Network interface: ens5
    Private IP address: 10.0.0.239
    Public (Elastic) IP address: 13.55.35.25
STUN/TURN server:
    Private IP address: 10.0.0.37
    Public IP address: 18.211.133.9

Added configuration settings:

audio_agent/agent.toml:
    [internal]
    ip_address = "10.0.0.239"
    network_interface = "ens5"
    maxport = 65535
    minport = 1025
nuve/nuve.toml:
    [nuve]
    port = 3000
portal/portal.toml:
    [portal]
    hostname = "ec2-13-55-35-25.us-east-2.compute.amazonaws.com"
    ip_address = "13.55.35.25"
    port = 8080
recording_agent/agent.toml:
    [internal]
    ip_address = "10.0.0.239"
    network_interface = "ens5"
    maxport = 65535
    minport = 1025
sip_agent/agent.toml:
    [internal]
    ip_address = "10.0.0.239"
    network_interface = "ens5"
    maxport = 65535
    minport = 1025
streaming_agent/agent.toml:
    [internal]
    ip_address = "10.0.0.239"
    network_interface = "ens5"
    maxport = 65535
    minport = 1025
video_agent/agent.toml:
    [internal]
    ip_address = "10.0.0.239"
    network_interface = "ens5"
    maxport = 65535
    minport = 1025
webrtc_agent/agent.toml:
    [internal]
    ip_address = "10.0.0.239"
    network_interface = "ens5"
    maxport = 65535
    minport = 1025
    [webrtc]
    network_interfaces = [{name = "ens5", replaced_ip_address = "13.55.35.25"}]
    maxport = 65535
    minport = 1025
    stunport = 3478
    stunserver = "18.211.133.9"

When I call the MCU server from Chrome browser in Windows 10 OS, I am not getting any errors or warnings in any of the MCU log file. But, unable to run the sample application. Please find the below console output (F12):

Failed to load resource: https://ec2-13-55-35-25.us-east-2.compute.amazonaws.com:8080/socket.io/?EIO=3&transport=polling&t=MW...
net::ERR_CERT_AUTHORITY_INVALID
    Request.create    @    socket.io.js:1
    Request        @    socket.io.js:1
    XHR.request    @    socket.io.js:1
    XHR.doPoll    @    socket.io.js:1
    Polling.poll    @    socket.io.js:1
    Polling.doOpen    @    socket.io.js:1
    Transport.open    @    socket.io.js:1
    Socket.open    @    socket.io.js:1
    Socket        @    socket.io.js:1
    Socket        @    socket.io.js:1
    Manager.open.Manager.connect    @    socket.io.js:2
    (anonymous)    @    socket.io.js:3

When I call the MCU server from Firefox browser in Windows 10 OS, I am not getting any errors or warnings in any of the MCU log file. But, unable to run the sample application. Please find the below console output (Inspect Element):

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://ec2-13-55-35-25.us-east-2.compute.amazonaws.com:8080/socket.io/?EIO=3&transport=polling&t=MW.... (Reason: CORS request did not succeed).

Hence, request you to help us to resolve the issue.

Thank you.

Best Regards,
Chandramouli.

0 Kudos
Highlighted
Beginner
5 Views

Hello,

Any help would be appreciated.

Thank you.

Best Regards,
Chandramouli.

0 Kudos
Highlighted
Employee
6 Views

How about you align all MCU

Jump to solution

How about you align all MCU access address through IP by removing hostname setting in portal configuration as following?  If that still not help, that should MCU server side problem, check if any error messages in portal server and other node logs.

portal/portal.toml:
    [portal]

    hostname = "ec2-13-55-35-25.us-east-2.compute.amazonaws.com"
    ip_address = "13.55.35.25"
    port = 8080

View solution in original post

0 Kudos
Highlighted
Beginner
5 Views

Hello Lei Zhai,

Jump to solution

Hello Lei Zhai,

Thank you very much for your reply. We will do it as you suggested and update you.

Thank you.

Best Regards,
Chandramouli.

0 Kudos
Highlighted
Beginner
5 Views

Hello Lei Zhai,

Jump to solution

Hello Lei Zhai,

As you suggested, I removed hostname line completely and now it is working fine.

Thank you very much.

Best Regards,
Chandramouli.

0 Kudos