Intel® Collaboration Suite for WebRTC
Community support and discussions on the Intel® Collaboration Suite for WebRTC (Intel® CS for WebRTC).
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
For the latest information on Intel’s response to the Log4j/Log4Shell vulnerability, please see Intel-SA-00646

SIP issue

david_c_1
Beginner
247 Views

Hi,

I encounter some problems if I create a room with SIP connectivity and in the session there is also a Mac client connected. Some users in the room do not receive any packets on the SIP stream even if they have successfully subscribed it.

I can not find any significant errors or warnings in the intelcs logs.

If in the session are present only windows or linux clients, the problem does not occur and everything works correctly.

Do you have any idea of ​​what the problem might be?

0 Kudos
3 Replies
david_c_1
Beginner
247 Views

Hi,

I integrate my previous post. I have identified this error in the logs:

 

2018-01-08 15:59:04.974  - DEBUG: AmqpClient - New message received { method: 'createInternalConnection',
 args: [ '5fe592f9e05f', 'in', { protocol: 'tcp' } ],
 corrID: 622,
 replyTo: 'amq.gen-NLUbKnl_G470LPwX5NhW5w' }
2018-01-08 15:59:04.978  - DEBUG: AmqpClient - New message received { method: 'linkup',
 args: [ 'Ias3I4kjRINjUu3KAATY-sub-5fe592f9e05f', '5fe592f9e05f', null ],
 corrID: 624,
 replyTo: 'amq.gen-NLUbKnl_G470LPwX5NhW5w' }
2018-01-08 15:59:04.978  - DEBUG: Connections - linkup, connectionId: Ias3I4kjRINjUu3KAATY-sub-5fe592f9e05f , audioFrom: 5fe592f9e05f , videoFrom: null
2018-01-08 15:59:04.978  - ERROR: Connections - Audio stream does not exist:5fe592f9e05f
2018-01-08 15:59:04.989  - DEBUG: AmqpClient - New message received { method: 'publish',
 args:
  [ '5fe592f9e05f',
    'internal',
    { controller: 'session.dcfc4a54-012d-a61d-39ab-8853310949c2.323',
      owner: 'sip:
xxxxxxxxxxxx@xxx.xxx.xxx.xxx',
      audio: [Object],
      video: false,
      ip: 'xxx.xxx.xxx.xxx',
      port: 0 } ],
 corrID: 625,
 replyTo: 'amq.gen-NLUbKnl_G470LPwX5NhW5w' }
2018-01-08 15:59:04.990  - DEBUG: WebrtcNode - publish, connectionId: 5fe592f9e05f connectionType: internal options: { controller: 'session.dcfc4a54-012d-a61d-39ab-8853310949c2.323',
 owner: 'sip:
xxxxxxxxxxxx@xxx.xxx.xxx.xxx',
 audio: { codec: 'opus_48000_2' },
 video: false,
 ip: '
xxx.xxx.xxx.xxx',
 port: 0 }

david_c_1
Beginner
247 Views

Hi,

Any updates?

david_c_1
Beginner
247 Views

Hi team,

if I delay the subscription of the sip stream with a setTimeout, it seems that the problem does not occur.

It seems that when I receive the "stream-added" event, the sip audio stream is not yet ready (see above webrtc-agent log file).

This only happens if I subscribe to a sip stream. 

 

 

Reply