Intel® Collaboration Suite for WebRTC
Community support and discussions on the Intel® Collaboration Suite for WebRTC (Intel® CS for WebRTC).
Announcements
Intel Customer Support will be observing the Martin Luther King holiday on Monday, Jan. 17, and will return on Tues. Jan. 18.
For the latest information on Intel’s response to the Log4j/Log4Shell vulnerability, please see Intel-SA-00646
1135 Discussions

Sample application is not working in MS Edge Browser

Nikhil_kumar__Doosar
137 Views

Hello Team,

Sample web application(v4.1) is not working in edge ,we are getting error messages like (Failed to create MediaStream, NotFoundError)

 

Thanks,

Nikhil

0 Kudos
8 Replies
YanbinZ_Intel
Employee
137 Views

Hi, Nikhil

Could you please provide Edge version  and reproduce steps?

Thanks

Yanbin

Nikhil_kumar__Doosar
137 Views

Hi Yanbin,

Simply we download the framework and started the MCU server in AWS.

Opened index.html from node server with port number 80 in in IE browser (v40.15063.0.0).  We got issue as "Failed to create media stream ". 

We are not getting our local stream too and not asking for camera permissions,

Ics.Base.MediaStreamFactory.createMediaStream returns the fail response.

Thanks,

Nikhil

YanbinZ_Intel
Employee
137 Views

Hi, Nikhil

 1. Could you please double confirm the camera can connected successful on Edge machine.  

  2. If that works fine in step1,  please update Edge browser to 42.17134.1.0 or latest one.

 

Thanks

Yanbin

Nikhil_kumar__Doosar
137 Views

Hi Yanbin,

Thanks for your reply edge version 42.1x is working fine , But in safari v12 we are  getting issue as "Receive remote stream without subscription". Our local stream is published successfully, and visible at other end.But at safari user end remote mixed stream is not subscribed.Please find below attachment for console log screenshot. 

Thanks,

Nikhil 

Nikhil_kumar__Doosar
137 Views

Hello,

Any help would be appreciated.

Thank you.

Best Regards,
Nikhil.

YanbinZ_Intel
Employee
137 Views

Hi, Nikhil

 We also found this issue on our release testing cycle.  It seems the safari issue and related to machine hardware. It works fine on some of machines while works abnormally on others during our testing.  We will monitor safari related fix closely . 

 

Thanks

Yanbin

Nikhil_kumar__Doosar
137 Views

Hi Yanbin,

Thanks for your reply.

Thanks,

Nikhil.

Nikhil_kumar__Doosar
137 Views

Hi Yanbin,

i am using edge browser with 42.17134.1.0  but it is working in some systems(sample application 4.1) and not working in few systems with showing error log 

ORTC18615: ORTC RTCDtlsTransport: DTLS handshake failed. hr=c004e00f. is it related to open ssl issue or any thing issue in client side or server side 

Thanks,

Nikhil

Reply