Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor I
203 Views

[v3.3] RabbitMQ configuration for MCU cluster deployment

Jump to solution

Hello there
I am using version 3.1.

1. One machine install RabbitMQ, MongoDB,Nuve, Cluster Manager, Portal, Access Agent. audio agent.

2. One machine install video agent.

Has been sure that rabbit.port and rabbit.host point to the RabbitMQ server,But the following error message appears when the web client logs in

           ERROR: server connection failed: initRoom failed.                              woogeen.sdk.js:219 
           INFO: Server disconnected                                                                        woogeen.sdk.js:219 

Debugging and checking for a long time, or so, can I help me?
thank you very much.

Tags (2)
0 Kudos

Accepted Solutions
Highlighted
Employee
203 Views

Good topic. Maybe you hit the RabbitMQ configuration issue and we will improve our product in further release. Now we use guest to access RabbitMQ, which only support accessing from localhost, so need some configuration to allow remote access.

============================================================================================================

"guest" user can only connect via localhost

By default, the guest user is prohibited from connecting to the broker remotely; it can only connect over a loopback interface (i.e. localhost). This applies both to AMQP and to any other protocols enabled via plugins. Any other users you create will not (by default) be restricted in this way.

This is configured via the loopback_users item in the configuration file.

If you wish to allow the guest user to connect from a remote host, you should set the loopback_usersconfiguration item to []. A complete rabbitmq.config which does this would look like:

[{rabbit, [{loopback_users, []}]}].

View solution in original post

0 Kudos
7 Replies
Highlighted
New Contributor I
203 Views

Can someone help me? Also, when the two servers are open, there is no problem

0 Kudos
Highlighted
Employee
203 Views

What do you mean 'when the two servers are open, there is no problem'?  Have you changed other configurations in video-agent? 

0 Kudos
Highlighted
New Contributor I
203 Views

Changed the video_agent / agent.toml rabbit.host.
I mean, the server did not see the opening of the error, but the web client can not log on.

0 Kudos
Highlighted
Employee
203 Views

Can you send us the log from both servers?

0 Kudos
Highlighted
New Contributor I
203 Views

This is a  error log file today.

http://pan.baidu.com/s/1i5bXoTB

 

Log_m1 is to start the RabbitMQ, MongoDB,Nuve, Cluster Manager, Portal, Access Agent. audio agent.

Log_m2 is to start the video agent.

0 Kudos
Highlighted
Employee
204 Views

Good topic. Maybe you hit the RabbitMQ configuration issue and we will improve our product in further release. Now we use guest to access RabbitMQ, which only support accessing from localhost, so need some configuration to allow remote access.

============================================================================================================

"guest" user can only connect via localhost

By default, the guest user is prohibited from connecting to the broker remotely; it can only connect over a loopback interface (i.e. localhost). This applies both to AMQP and to any other protocols enabled via plugins. Any other users you create will not (by default) be restricted in this way.

This is configured via the loopback_users item in the configuration file.

If you wish to allow the guest user to connect from a remote host, you should set the loopback_usersconfiguration item to []. A complete rabbitmq.config which does this would look like:

[{rabbit, [{loopback_users, []}]}].

View solution in original post

0 Kudos
Highlighted
New Contributor I
203 Views

Solved, is indeed guest can not remote access problems.
thank you very much.

0 Kudos