Intel® Developer Cloud
Help connecting to or getting started on Intel® Developer Cloud
162 Discussions

Unable to access JupyterLab on Developer Cloud

e87tn95h
Novice
748 Views

To whom it may concern,

I would not able to access JupyterLab on Intel developer cloud. My any web browser says "your connection is not private or not secure". Could you confirm your servers or services status?

Launch JupyterLab on cloud consoleLaunch JupyterLab on cloud consolePrivacy errorPrivacy error

Best regards,

Hiroshi

Labels (1)
12 Replies
Tomnjery
Beginner
703 Views

I also have this problem too.

0 Kudos
Athirah_Intel
Moderator
678 Views

Hi e87tn95h,

Thank you for reaching out to us.

 

I recommend trying the following steps:

  1. Clear Browser Data: Please try clearing your browser data (cookies, cache, etc.) first. Proceed to login to the IDC Cloud Console and launch the Jupyter Notebook training.
  2. Try Incognito Mode: If the above method does not resolve the issue, I suggest you try accessing the IDC Cloud Console and launching the Jupyter Notebook training by using "Incognito Mode" in Google Chrome or "Private Mode" if you are using Mozilla Firefox or Safari.

 

Please let us know if you have any further issues, and we'll be happy to help you.

 

 

Regards,

Athirah


0 Kudos
e87tn95h
Novice
600 Views

Hello Athirah,

Thank you for giving great reply. Clearing all browser data is important to replicate this problem.

  1. Please try clearing your browser data (cookies, cache, etc.) first.
  2. Go https://console.cloud.intel.com/training and sign-in with your credential.
  3. Just click [Launch JupyterLab] button at upper right.

Results on my side:

Google Chrome: Your connection is not privateGoogle Chrome: Your connection is not privateMicrosoft Edge: Your connection isn't privateMicrosoft Edge: Your connection isn't privateMozilla Firefox: Did not connect: potential security issueMozilla Firefox: Did not connect: potential security issue

Best regards,

Hiroshi

0 Kudos
Elmer_Intel
Moderator
571 Views

Hi e87tn95h,

 

Thank you for responding. For further investigation, please provide us with the Intel® Developer Cloud Instance Details as below:

 

Instance ID/Resource ID:

Instance Type:

Cloud Account ID: 

 

Please send the instance details to me via private message.

 

 

Regards,

Elmer

 

0 Kudos
Elmer_Intel
Moderator
550 Views

Hi e87tn95h,


We are investigating this issue with the relevant team and will get back to you soon. Your patience is greatly appreciated.



Regards,

Elmer


0 Kudos
Athirah_Intel
Moderator
497 Views

Hi e87tn95h,

We just got an update from the engineering team regarding this issue. 

 

Please follow the steps below:

 

1.Open a new tab in Chrome

2.In the address bar, type chrome://net-internals/#hsts and press Enter

3.The HSTS/PKP window will open

4.Under the Query HSTS/PKP domain section, in the Domain text box, type jupyter-batch-us-region-1.cloud.intel.com for which you want to delete the settings

5.Locate the Delete domain security policies section

6.Enter the same domain name into the box, then click the Delete button

 

Then, please click in "view certificate" and send us the screenshot.

 

 

Regards,

Athirah


0 Kudos
e87tn95h
Novice
485 Views

Hello Athirah,

 

> Then, please click in "view certificate" and send us the screenshot.

 

Certificate: DetailsCertificate: DetailsCertificate: GeneralCertificate: General

 

It looks like "self-signed key" are used with HTTPS. Regarding this connection, I would not able to trust you for now.

 

Best regards,

Hiroshi

0 Kudos
Athirah_Intel
Moderator
473 Views

Hi e87tn95h,

 

Thank you for sharing the screenshots. We apologize for the inconvenience you are currently experiencing. Let me relay this information to the engineering team for further investigation and will update you as soon as possible. Thank you for your patience.

 

 

Regards,

Athirah

 

0 Kudos
Athirah_Intel
Moderator
416 Views

Hi e87tn95h,

We just got an update from the engineering team regarding this issue.

 

For clarification purposes, have you tried the below steps?

 

1.Open a new tab in Chrome

2.In the address bar, type chrome://net-internals/#hsts and press Enter

3.The HSTS/PKP window will open

4.Under the Query HSTS/PKP domain section, in the Domain text box, type jupyter-batch-us-region-1.cloud.intel.com for which you want to delete the settings

5.Locate the Delete domain security policies section

6.Enter the same domain name into the box, then click the Delete button

 

Please let us know if this helps.

 

 

Regards,

Athirah


0 Kudos
e87tn95h
Novice
393 Views

Hello Athirah,

 

> For clarification purposes, have you tried the below steps?

Yes, sure. My chrome browser says "Not found" for querying HSTS/PKP domain.

 

chrome://net-internals/#hstschrome://net-internals/#hsts

 

However, it does not help that to secure or private this connection. This browser still show the same warning message.

Even if you could launch Jupyter Lab on developer cloud successfully, the browser will show "Not Secure" at address bar.
Isn't that so?

 

Best regards,

Hiroshi

0 Kudos
Zulkifli_Intel
Moderator
274 Views

Hi e87tn95h,


We noticed that you are using Firefox, HTTP Strict Transport Security (HSTS) error occurs when a browser detects a violation of an HSTS policy or expired SSL certificates. Suggest clearing this using the steps below:


1. Close all open tabs in Firefox.

2. Open the full History window with the keyboard shortcut Ctrl + Shift + H (Cmd + Shift + H on Mac). Use this window or the sidebar to make the options below available.

3. Find this site: jupyter-batch-us-region-1.cloud.intel.com that you want to delete the HSTS settings for – you can search for the site at the upper right if needed.

4. Right-click the site from the list of items and click Forget About This Site. This should clear the HSTS settings (and other cache data) for that domain.

5. Restart Firefox and visit the site. You should now be able to visit the site over HTTPS


Regards,

Zul


0 Kudos
e87tn95h
Novice
73 Views

Hello Zulkifli,

 

The issue mentioned by topic title: "Unable to access JupyterLab on Developer Cloud" may be avoidable, but your replies are not my type as solution. I believe that the root cause still be on your service and not be on my browsers, such as it is exactly "expired SSL certificates are used".

 

Best regards,

Hiroshi

0 Kudos
Reply