Intel® Distribution for Python*
Support and discussions for achieving faster Python* applications and core computational packages.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!

Intel version of pytables is broken

Stoudt__Craig
Beginner
156 Views
I'm running 64-bit python on Linux Mint.  Intel Distribution for Python (idp ) was installed via conda.
I have two environments: intel and anaconda.  First, let's look at the anaconda distribution. Read a dataset stored in a HDF5 formatted file:
>>> python --version
Python 3.6.5 :: Anaconda, Inc.
>>> python
>>> import pandas as pd
>>> file='some_file.h5'
>>> data=pd.read_hdf(file,'data')
>>> data[0:1]
   T(K)   Cp    S -[G-H(Tr)]/T  H-H(Tr)  delta-f H  delta-f G log Kf
0   0.0  0.0  0.0          inf  -10.024    -66.911    -66.911    inf
This is the expected behavior.  Now, let's try that with intel python:
>>> python --version
Python 3.6.3 :: Intel Corporation
>>> python
>>> import pandas as pd
>>> file='some_file.h5'
>>> data=pd.read_hdf(file,'data')
Illegal instruction
The python session crashes.
The culprit is the pytables package that ships with idp: pytables 3.4.2 np114py36_intel_4
I solved the problem by uninstalling pytables and then reinstalling from the conda defaults channel:
>>> conda remove -n intel pytables
>>> conda install -n intel pytables --override-channels -c defaults

My intel python now works as expected; however, note that this process resulted in the downgrading of several packages. Now, it is very difficult to upgrade the intel environment because conda wants to reinstall pytables 3.4.2 from the intel channel.  Perhaps there is a way to prevent this with an environment configuration file; unfortunately, my conda-fu is weak.

Also, note this appears to be a linux issue: I also tried this with idp installed on Windows 10 and there is no problem with pytables.

0 Kudos
0 Replies
Reply