Intel® Distribution for Python*
Support and discussions for achieving faster Python* applications and core computational packages.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!

error installing with PyPi

mcdonald__shawn
Beginner
424 Views

Hello -

I receive the following error when trying to install intel PyPi packages.

pip install intel-numpy

ERROR: Could not find a version that satisfies the requirement intel-numpy (from versions: none)
ERROR: No matching distribution found for intel-numpy

I also receive the same error when trying to install the following:

pip install intel-scipy

pip install tbb4py

Here is the pip list

Package              Version
-------------------- --------
absl-py              0.9.0
astor                0.8.1
cycler               0.10.0
gast                 0.2.2
google-pasta         0.2.0
grpcio               1.28.1
h5py                 2.10.0
Keras                2.3.1
Keras-Applications   1.0.8
Keras-Preprocessing  1.1.0
kiwisolver           1.2.0
Markdown             3.2.1
matplotlib           3.2.1
opencv-python        4.2.0.34
opt-einsum           3.2.1
pandas               1.0.3
Pillow               7.1.1
pip                  20.0.2
protobuf             3.11.3
pyparsing            2.4.7
python-dateutil      2.8.1
pytz                 2019.3
PyYAML               5.3.1
setuptools           41.2.0
six                  1.14.0
tensorboard          1.15.0
tensorflow-estimator 1.15.1
tensorflow-gpu       1.15.2
termcolor            1.1.0
Werkzeug             1.0.1
wheel                0.34.2
wrapt                1.12.1

 

0 Kudos
4 Replies
ArunJ_Intel
Moderator
424 Views

Hey Shawn,

Thanks for reaching out to us.

The pip  installation of intel-numpy is currently packaged for python 3.6 and below. So if you  are using python 3.7 or above please downgrade your python to 3.6 to have the installations working.

Please let us know if you are facing further issues.

 

Thanks

Arun Jose

ArunJ_Intel
Moderator
424 Views

Hey Shawn,

 

Hope you have got things working by downgrading python to 3.6. Regarding the issue  about packages not being compatible with python 3.7 we have forwarded it to SME  they would be checking on this.

 

Thanks

Arun Jose

 

 

mcdonald__shawn
Beginner
424 Views

Thank you Arun,  I was using Python 3.7 so that explains the errors!  

Please consider this "closed".

ArunJ_Intel
Moderator
424 Views

Thanks Shawn, for the confirmation. We are closing the case please feel free to raise a new case for further issues.

Reply