Community
cancel
Showing results for 
Search instead for 
Did you mean: 
abhi1
Beginner
596 Views

AVX support missing NCSDKv2 installation fails

make install ./uninstall-opencv.sh OpenCV uninstall starting Reading installer configuration variables from ./ncsdk.conf You are using pip version 8.1.1, however version 19.1.1 is available. You should consider upgrading via the 'pip install --upgrade pip' command. OpenCV uninstall finished   make install starting. ./install.sh Movidius Neural Compute Toolkit Installation Intel(R) Advanced Vector Extensions, Intel(R) AVX, support required but not detected. Will exit Makefile:47: recipe for target 'install' failed make: *** [install] Error 1

while running make. I get this error. I'm using Cuda version

 

nvcc --version nvcc: NVIDIA (R) Cuda compiler driver Copyright (c) 2005-2019 NVIDIA Corporation Built on Wed_Apr_24_19:10:27_PDT_2019 Cuda compilation tools, release 10.1, V10.1.168

CPU: Intel Xeon(R) CPU X5650 @ 2.67 GHz x 24

 

Even if I go to install.sh & remove AVX check. I get some other error while caffee installation

 

collect2: error: ld returned 1 exit status examples/CMakeFiles/convert_cifar_data.dir/build.make:134: recipe for target 'examples/cifar10/convert_cifar_data' failed make[3]: *** [examples/cifar10/convert_cifar_data] Error 1 make[3]: Leaving directory '/opt/movidius/ssd-caffe/build' CMakeFiles/Makefile2:1037: recipe for target 'examples/CMakeFiles/convert_cifar_data.dir/all' failed make[2]: *** [examples/CMakeFiles/convert_cifar_data.dir/all] Error 2 make[2]: Leaving directory '/opt/movidius/ssd-caffe/build' Makefile:127: recipe for target 'all' failed make[1]: *** [all] Error 2 make[1]: Leaving directory '/opt/movidius/ssd-caffe/build' Installation failed. Error on line 673 Makefile:47: recipe for target 'install' failed make: *** [install] Error 1

 

 

Tags (1)
0 Kudos
2 Replies
Sahira_Intel
Moderator
137 Views

Hi AArya8,

Are you using the NCS1?

It looks like your Intel Xeon x5650 CPU doesn't support AVX instructions. Tensorflow 1.6 and later started using AVX instructions in their prebuilt binaries. So you would have to use Tensorflow 1.5 or below or build from source.

 

Please let me know if you have any further questions.

Best Regards,

Sahira

abhi1
Beginner
137 Views

@Sahira_Intel​ I didn't get your answer. I have tensorflow-gpu installed 1.13.1. Maybe there's a problem with installing 1.13.1 CPU which ncsdk2 installs.....while doing make install

 

Is it the problem you are point to? Should I install tensorflow-cpu 1.5 lower in `virtual env`? & then try to install ncsdk2? Kind of confused plz clear....

Reply