Community
cancel
Showing results for 
Search instead for 
Did you mean: 
80 Views

Benchmark app throwing errors when using the CPU plugin

Hello everyone,

my system specifications are:

PC: Nuvo-5608VR (Intel i7-6700)

OS: Ubuntu 18.04

OpenVino: R5 (first Version)

Other: NCS 1

I have a question regarding the benchmark app that can be found in "/opt/intel/computer_vision_sdk_2018.5.445/inference_engine/samples/benchmark_app/". I tried it using the plugins for CPU and MYRIAD. On my end it seems only to work with the MYRIAD plugin. I tested the app with three networks: yolo_v3, mobilenets_ssd_v2 and mobilenets_ssd_v1_depth_075

All three networks worked fine using the MYRIAD plugin.

Using the CPU plugin I got the following errors:

yolo_v3: [ ERROR ] Unsupported primitive of type: RegionYolo name: detector/yolo-v3/Conv_22/BiasAdd/YoloRegion
mobilenets_ssd_v2: [ ERROR ] Unsupported primitive of type: PriorBoxClustered name: PriorBoxClustered_0
mobilenets_ssd_v1_d075: [ ERROR ] Unsupported primitive of type: PriorBoxClustered name: PriorBoxClustered_0

I never had any issues using the same IR of the networks above in any other sample application that comes with OpenVino R5 when using the CPU plugin. As stated in the documentation I used a FP32 IR for the CPU benchmark test as I normally do when using the CPU plugin.

Does anyone see my error here?

Is anyone able to reproduce this? (The networks I use are downloaded from the Tensorflow detection model zoo: https://github.com/tensorflow/models/blob/master/research/object_detection/g3doc/detection_model_zoo... )

Kind regards,

Benjamin Lange

 

0 Kudos
2 Replies
Shubha_R_Intel
Employee
80 Views

Hi Benjamin. When you built your *.xml and *.bin via Model Optimizer for yolo3, did you add the --tensorflow_use_custom_operations_config  switch ? deployment_tools\model_optimizer\extensions\front\tf\yolo_v3.json should be an argument to this switch.

There are some other threads about yolo_v3:

https://software.intel.com/en-us/forums/computer-vision/topic/800049

https://software.intel.com/en-us/forums/computer-vision/topic/801113

For instance, the second thread suggests the following MO commands:

python  C:\Intel\computer_vision_sdk_2018.4.420\deployment_tools\model_optimizer\mo_tf.py --input_model yolo_v3.pb --tensorflow_use_custom_operations_config  yolo_v3_changed.json --batch 1

or

python  C:\Intel\computer_vision_sdk_2018.4.420\deployment_tools\model_optimizer\mo_tf.py --input_model yolo_v3.pb --tensorflow_use_custom_operations_config  yolo_v3_changed.json --input_shape [1,416,416,3]

Tanys__Michele
Beginner
80 Views

Hello Benjamin,

Did you eventually solve the problem? I am facing the same issue while trying to run the Benchmark App with Mobilenet SSD v2. 

Unfortunately, Shubha's suggestions didn't work for me.

Best,

Michele