Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
509 Views

Could not open NCS device

I am using NCS2 on Ubuntu16.04 native, and I´ve already installed VINO environment. I tried make run in /examples/apps/hello_ncs_py, but it always gives me the error as below.

 

python3 hello_ncs.py; D : [ 0] ncDeviceCreate:307 ncDeviceCreate index 0 D : [ 0] ncDeviceCreate:307 ncDeviceCreate index 1 D : [ 0] ncDeviceOpen:501 File path /usr/local/lib/mvnc/MvNCAPI-ma2450.mvcmd W : [ 0] ncDeviceOpen:505 ncDeviceOpen() XLinkBootRemote returned error 3 Error - Could not open NCS device.

 

And if i tried make examples for all the examples, it always gives me the error as below.

 

Layer inception_3b/1x1 forced to im2col_v2, because its output is used in concat /usr/local/bin/ncsdk/Controllers/FileIO.py:65: UserWarning: You are using a large type. Consider reducing your data sizes for best performance Traceback (most recent call last): File "/usr/local/bin/mvNCCompile", line 169, in <module> create_graph(args.network, args.image, args.inputnode, args.outputnode, args.outfile, args.nshaves, args.inputsize, args.weights, args.explicit_concat, args.ma2480, args.scheduler, args.new_parser, args) File "/usr/local/bin/mvNCCompile", line 155, in create_graph graph_file.generate_v2(args) File "/usr/local/bin/ncsdk/Models/Blob.py", line 211, in generate_v2 with open(self.blob_name, 'wb') as f: PermissionError: [Errno 13] Permission denied: 'graph' Makefile:80: recipe for target 'compile' failed make[4]: *** [compile] Error 1 make[4]: Leaving directory '/home/ubuntu/Downloads/ncsdk-2.05.00.02/examples/caffe/GoogLeNet' cp: cannot create regular file './googlenet.graph': Permission denied Makefile:9: recipe for target 'googlenet' failed make[3]: *** [googlenet] Error 1 make[3]: Leaving directory '/home/ubuntu/Downloads/ncsdk-2.05.00.02/examples/apps/multistick_cpp' Makefile:13: recipe for target 'multistick_cpp/.' failed make[2]: *** [multistick_cpp/.] Error 2 make[2]: Leaving directory '/home/ubuntu/Downloads/ncsdk-2.05.00.02/examples/apps' Makefile:12: recipe for target 'apps/.' failed make[1]: *** [apps/.] Error 2 make[1]: Leaving directory '/home/ubuntu/Downloads/ncsdk-2.05.00.02/examples' Makefile:57: recipe for target 'examples' failed make: *** [examples] Error 2

 

Can anyone give me some advice about how I should fix it? Thanks.
0 Kudos
2 Replies
idata
Community Manager
130 Views

FYI, if I tried the procedure described in https://software.intel.com/en-us/neural-compute-stick/get-started, I used the following commands:

 

cd ~/intel/computer_vision_sdk/deployment_tools/demo ./demo_security_barrier_camera.sh -d MYRIAD

 

And the command runs successfully as below.

 

API version ............ 1.5 Build .................. 19154 Description ....... myriadPlugin [ INFO ] Loading network files for VehicleDetection [ INFO ] Batch size is forced to 1 [ INFO ] Checking Vehicle Detection inputs [ INFO ] Checking Vehicle Detection outputs [ INFO ] Loading Vehicle Detection model to the MYRIAD plugin [ INFO ] Loading network files for VehicleAttribs [ INFO ] Batch size is forced to 1 for Vehicle Attribs [ INFO ] Checking VehicleAttribs inputs [ INFO ] Checking Vehicle Attribs outputs [ INFO ] Loading Vehicle Attribs model to the MYRIAD plugin [ INFO ] Loading network files for Licence Plate Recognition (LPR) [ INFO ] Batch size is forced to 1 for LPR Network [ INFO ] Checking LPR Network inputs [ INFO ] Checking LPR Network outputs [ INFO ] Loading LPR model to the MYRIAD plugin [ INFO ] Start inference Avarage inference time: 80.2087 ms (12.4675 fps) Total execution time: 6976.94 [ INFO ] Execution successful

idata
Community Manager
130 Views

Hi @BenjaminLiu

 

Do you also have the NCSDK installed on your computer? The first two errors you're getting are from using the NCS2 with the NCSDK. The NCS2 is _only _compatible with OpenVINO, not the NCSDK. But it looks like you did successfully install OpenVINO.

 

If you have any further questions about OpenVINO with the NCS2, please post them here to the Computer Vision forum.

 

Best regards,

 

Sahira
Reply