Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
467 Views

Error Compiling Examples

When trying to compile any example using commands like:

 

making compile

 

mvNCCompile -w squeezenet_v1.0.caffemodel -s 12 deploy.prototxt

 

I get the following error:

 

Makefile:88: recipe for target 'compile' failed

 

make: *** [compile] Illegal instruction (core dumped)

 

I have

 

jose@computer:~/ncsdk/examples/caffe/SqueezeNet$ echo $PYTHONPATH

 

:/opt/movidius/caffe/python
Tags (2)
0 Kudos
8 Replies
idata
Community Manager
183 Views

@JosePerez What type of machine are you using the NCSDK on?

idata
Community Manager
183 Views

Hi @Tome_at_Intel I am also getting this when the make file for Facenet tries to compile the graph on Ubuntu 16.04 & 18.04 (On an UP Squared). I had seen similar errors with conflicting TF versions before so decided to try upgrade to 18.04 and reinstall everything but no change. ( I modified the NCSDK2 installer to allow 1804)

 

Running Facenet makefile:

 

_2018-10-29 13:24:40 (7,19 MB/s) - ‘20170512-110547.zip’ saved [191972345]

 

making model

 

Zip file exists.

 

Unzipping.

 

Archive: 20170512-110547.zip

 

inflating: 20170512-110547/20170512-110547.pb

 

inflating: 20170512-110547/model-20170512-110547.ckpt-250000.data-00000-of-00001

 

inflating: 20170512-110547/model-20170512-110547.ckpt-250000.index

 

inflating: 20170512-110547/model-20170512-110547.meta

 

Converted directory does not exist, doing conversion

 

Illegal instruction (core dumped)

 

making compile

 

/bin/sh: 7: cd: can't cd to 20170512-110547/facenet_celeb_ncs

 

Command line: mvNCCompile facenet_celeb_ncs.meta -w facenet_celeb_ncs -s 12 -in input -on output -o facenet_celeb_ncs.graph

 

/usr/local/lib/python3.6/dist-packages/skimage/init.py:60: DeprecationWarning: the imp module is deprecated in favour of importlib; see the module's documentation for alternative uses

 

import imp

 

Illegal instruction (core dumped)

 

cp: cannot stat 'facenet_celeb_ncs.graph': No such file or directory_
idata
Community Manager
183 Views

@AdamMiltonBarker Which CPU does your Up Squared board use? If it is an Atom CPU, it seems like the Intel Atom processors don't have AVX support and for TensorFlow 1.6 and higher, release binaries are prebuilt with AVX instructions. One option is to use TF 1.5 or below.

 

Another option that may work is to build TensorFlow yourself using docker: https://github.com/hadim/docker-tensorflow-builder

idata
Community Manager
183 Views

Intel NUC NUC5CPYH with 8 Gb of RAM. Running a new installation of Ubuntu 16.04

idata
Community Manager
183 Views

@Tome_at_Intel Will I be able to run in this platform?

idata
Community Manager
183 Views

@JosePerez You should be able to run it with that platform.

idata
Community Manager
183 Views

Any clue to solve this issue? As I mentioned, this is a brand new installation of Ubuntu and then the movidius installation. It is not makeany sence to have any error if we only have this installation from the scratch

idata
Community Manager
183 Views

@JosePerez I was mistaken, the Intel Celeron N3050 processor that comes with the Intel NUC NUC5CPYH doesn't have support for AVX instructions. As such the TensorFlow binaries that were prebuilt with AVX instructions (with pip) won't work on your machine. More information at https://github.com/tensorflow/tensorflow/issues/23520.

Reply