Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
437 Views

Error importing tensorflow despite installing prerequistes for intel neural stick 2 using OpenVino

System information

 

- Linux Ubuntu 16.04

 

     

  • TensorFlow installed from binary (pip install)
  •  

  • TensorFlow version:
  •  

  • Python version: 3.5
  •  

  • Installed using virtualenv? pip? conda?: pip and virtualenv
  •  

  • Bazel version (if compiling from source):
  •  

  • GCC/Compiler version (if compiling from source):
  •  

  • CUDA/cuDNN version:
  •  

  • GPU model and memory:
  •  

 

Problem described

 

i was following the tutorial for using intel neural stick 2 for object detection https://towardsdatascience.com/speed-up-predictions-on-low-power-devices-using-neural-compute-stick-...

 

in the example i install the prerequisites using the command

 

sudo ./opt/intel/computer_vision_sdk/deployment_tools/model_optimizer/install_prerequisites/install_prerequisites.sh

 

tensorflow was installed with the prerequisites , i also installed tensorflow using pip install , but when i run the next command

 

mo_tf.py \ --input_model ~/Downloads/ssd_mobilenet_v1_coco_2018_01_28/frozen_inference_graph.pb \ --tensorflow_use_custom_operations_config /opt/intel/computer_vision_sdk/deployment_tools/model_optimizer/extensions/front/tf/ssd_support.json \ --tensorflow_object_detection_api_pipeline_config ~/Downloads/ssd_mobilenet_v1_coco_2018_01_28/pipeline.config \ --data_type FP16

 

i get the following error

 

F tensorflow/core/platform/cpu_feature_guard.cc:37] The tensorflow library was compiled to use AVX instructions, but these aren't available in your machine Aborted (core dumped)

 

i am getting the same error when try and import tensorflow

 

what should i do to solve this error ?

Tags (1)
0 Kudos
1 Reply
idata
Community Manager
80 Views

Hi @Osama1995

 

What CPU are you running on? It looks like your CPU doesn't support AVX instructions, which is what the newer versions of Tensorflow use (v1.6 and later). Do you know what version of Tensorflow was installed on your computer? Uninstall any previously installed TF and then install any TF version lower than 1.6 and try again (v1.5 is a good option). Please let me know if this information was helpful!

 

Best Regards,

 

Sahira
Reply