Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
234 Views

Error in running demo_squeezenet_download_convert_run.sh

Hi,

I have installed the OpenVINO version 2019 R2.0.1.

The system configuration is as follows

Memory      : 3.8 GiB

Processor   : Intel® Celeron(R) CPU N3060 @ 1.60GHz × 2

Graphics     : Intel® HD Graphics 400 (Braswell)

GNOME       : 3.30.1

OS type       : 64-bit

Disk            : 983.4 GB

 

I followed the installation procedures in Install Intel® Distribution of OpenVINO™ toolkit for Linux*

When running the verification scripts I got the following error.

ioz@ioz-HP-Laptop-15-bs0xx:/opt/intel/openvino/deployment_tools/demo$ ./demo_squeezenet_download_convert_run.sh
target_precision = FP16
ls: cannot access '/opt/intel/openvino_2019.2.275/deployment_tools/inference_engine/lib/': No such file or directory
[setupvars.sh] OpenVINO environment initialized


###################################################



Downloading the Caffe model and the prototxt
Installing dependencies
Run sudo -E apt -y install build-essential python3-pip virtualenv cmake libcairo2-dev libpango1.0-dev libglib2.0-dev libgtk2.0-dev libswscale-dev libavcodec-dev libavformat-dev libgstreamer1.0-0 gstreamer1.0-plugins-base
Hit:1 http://in.archive.ubuntu.com/ubuntu cosmic InRelease                  
Hit:2 http://in.archive.ubuntu.com/ubuntu cosmic-updates InRelease                                   
Hit:3 http://in.archive.ubuntu.com/ubuntu cosmic-backports InRelease                                 
Hit:4 http://security.ubuntu.com/ubuntu cosmic-security InRelease              
Reading package lists... Done                     
Building dependency tree       
Reading state information... Done
All packages are up to date.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
build-essential is already the newest version (12.5ubuntu2).
cmake is already the newest version (3.12.1-1).
libgstreamer1.0-0 is already the newest version (1.14.4-1).
libgtk2.0-dev is already the newest version (2.24.32-3ubuntu1).
python3-pip is already the newest version (9.0.1-2.3).
virtualenv is already the newest version (15.1.0+ds-1.1).
gstreamer1.0-plugins-base is already the newest version (1.14.4-1ubuntu1.1).
libcairo2-dev is already the newest version (1.15.12-1ubuntu0.1).
libglib2.0-dev is already the newest version (2.58.1-2ubuntu0.2).
libpango1.0-dev is already the newest version (1.42.4-3ubuntu1).
libavcodec-dev is already the newest version (7:4.0.4-0ubuntu1).
libavformat-dev is already the newest version (7:4.0.4-0ubuntu1).
libswscale-dev is already the newest version (7:4.0.4-0ubuntu1).
The following packages were automatically installed and are no longer required:
  libncursesw5 libtinfo5
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libpng-dev is already the newest version (1.6.34-2ubuntu0.1).
The following packages were automatically installed and are no longer required:
  libncursesw5 libtinfo5
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
The directory '/home/ioz/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
The directory '/home/ioz/.cache/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
Requirement already satisfied: pyyaml in /usr/lib/python3/dist-packages
Requirement already satisfied: requests in /usr/local/lib/python3.6/dist-packages
Requirement already satisfied: idna<2.9,>=2.5 in /usr/lib/python3/dist-packages (from requests)
Requirement already satisfied: chardet<3.1.0,>=3.0.2 in /usr/lib/python3/dist-packages (from requests)
Requirement already satisfied: certifi>=2017.4.17 in /usr/lib/python3/dist-packages (from requests)
Requirement already satisfied: urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 in /usr/lib/python3/dist-packages (from requests)
The directory '/home/ioz/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
The directory '/home/ioz/.cache/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
Requirement already satisfied: networkx>=1.11 in /usr/local/lib/python3.6/dist-packages (from -r /opt/intel/openvino/deployment_tools/demo/../model_optimizer/requirements_caffe.txt (line 1))
Requirement already satisfied: numpy>=1.12.0 in /usr/local/lib/python3.6/dist-packages (from -r /opt/intel/openvino/deployment_tools/demo/../model_optimizer/requirements_caffe.txt (line 2))
Requirement already satisfied: protobuf==3.6.1 in /usr/local/lib/python3.6/dist-packages (from -r /opt/intel/openvino/deployment_tools/demo/../model_optimizer/requirements_caffe.txt (line 3))
Requirement already satisfied: test-generator==0.1.1 in /usr/local/lib/python3.6/dist-packages (from -r /opt/intel/openvino/deployment_tools/demo/../model_optimizer/requirements_caffe.txt (line 4))
Requirement already satisfied: defusedxml>=0.5.0 in /usr/local/lib/python3.6/dist-packages (from -r /opt/intel/openvino/deployment_tools/demo/../model_optimizer/requirements_caffe.txt (line 5))
Requirement already satisfied: decorator>=4.3.0 in /usr/local/lib/python3.6/dist-packages (from networkx>=1.11->-r /opt/intel/openvino/deployment_tools/demo/../model_optimizer/requirements_caffe.txt (line 1))
Requirement already satisfied: six>=1.9 in /usr/lib/python3/dist-packages (from protobuf==3.6.1->-r /opt/intel/openvino/deployment_tools/demo/../model_optimizer/requirements_caffe.txt (line 3))
Requirement already satisfied: setuptools in /usr/lib/python3/dist-packages (from protobuf==3.6.1->-r /opt/intel/openvino/deployment_tools/demo/../model_optimizer/requirements_caffe.txt (line 3))

Models have been loaded previously. Skip loading model step.
Model path: /home/ioz/openvino_models/models/FP16/classification/squeezenet/1.1/caffe/squeezenet1.1.prototxt


Target folder /home/ioz/openvino_models/ir/FP16//classification/squeezenet/1.1/caffe already exists. Skipping IR generation  with Model Optimizer.If you want to convert a model again, remove the entire /home/ioz/openvino_models/ir/FP16//classification/squeezenet/1.1/caffe folder. Then run the script again



###################################################

Build Inference Engine samples

-- The C compiler identification is GNU 8.3.0
-- The CXX compiler identification is GNU 8.3.0
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Looking for C++ include unistd.h
-- Looking for C++ include unistd.h - found
-- Looking for C++ include stdint.h
-- Looking for C++ include stdint.h - found
-- Looking for C++ include sys/types.h
-- Looking for C++ include sys/types.h - found
-- Looking for C++ include fnmatch.h
-- Looking for C++ include fnmatch.h - found
-- Looking for C++ include stddef.h
-- Looking for C++ include stddef.h - found
-- Check size of uint32_t
-- Check size of uint32_t - done
-- Looking for strtoll
-- Looking for strtoll - found
CMake Warning at common/format_reader/CMakeLists.txt:18 (message):
  OPENCV is disabled or not found, format_reader is built without OPENCV
  support


CMake Error at /usr/share/cmake-3.12/Modules/FindPackageHandleStandardArgs.cmake:137 (message):
  Some of mandatory Inference Engine components are not found.  Please
  consult InferenceEgnineConfig.cmake module's help page.  (missing:
  IE_RELEASE_LIBRARY) (Required is at least version "2.0")
Call Stack (most recent call first):
  /usr/share/cmake-3.12/Modules/FindPackageHandleStandardArgs.cmake:378 (_FPHSA_FAILURE_MESSAGE)
  /opt/intel/openvino_2019.2.275/deployment_tools/inference_engine/share/InferenceEngineConfig.cmake:92 (find_package_handle_standard_args)
  CMakeLists.txt:203 (find_package)


CMake Error at CMakeLists.txt:203 (find_package):
  Found package configuration file:

    /opt/intel/openvino_2019.2.275/deployment_tools/inference_engine/share/InferenceEngineConfig.cmake

  but it set InferenceEngine_FOUND to FALSE so package "InferenceEngine" is
  considered to be NOT FOUND.


-- Configuring incomplete, errors occurred!
See also "/home/ioz/inference_engine_samples_build/CMakeFiles/CMakeOutput.log".
Error on or near line 225; exiting with status 1

 

Can you please suggest me an idea to overcome this issue..

Thanks in advance

 

0 Kudos
1 Reply
Highlighted
234 Views

Looks like your install directory has been modified. I would run the uninstaller under /opt/intel/openvino_2019.2.275/openvino_toolkit_uninstaller/ and redownload and re-install openvino. 

Let me know if that solves your problem. 

0 Kudos