Community
cancel
Showing results for 
Search instead for 
Did you mean: 
SXian3
Beginner
157 Views

Error initializing DMA: not found on DevCloud FPGA instance

Hi, 

I was trying to run the object detection example from OpenVINO with FPGA support on DevCloud. However, the example dose not work as expected. 

The scripts I used for environment setup is as followed. I used fpga_runtime instance in interactive mode. There are many bitstreams in the installation folder with "SSD" or "RMNET" in their names, I just randomly chose one as the DLA_AOCX. Not sure if this is the cause.

qsub -I -l nodes=1:fpga_runtime:ppn=2 -d .
source /glob/development-tools/versions/oneapi/beta06/inteloneapi/setvars.sh sh
source /glob/deep-learning/versions/openvino_2019R1/openvino_fpga_2019.1.133/bin/setupvars.sh
export DLA_AOCX=/glob/deep-learning/versions/openvino_2019R1/openvino_2019.1.133/bitstreams/a10_dcp_bitstreams/2019R1_RC_FP11_SSD300.aocx

When I ran the example, I got the following error. The program complains that that it failed to initialize the DMA, and then hangs forever after logging "Start inference (1 iterations)". The Python example does not work either, the Inference gives out the same error and everything fallback to CPU execution.

$ ./object_detection_sample_ssd -m open_model_zoo/model_downloader/Retail/object_detection/pedestrian/rmnet_ssd/0013/dldt/person-detection-retail-0013.xml -i demo/car.png -d HETERO:FPGA,CPU

[ INFO ] InferenceEngine:
	API version ............ 1.6
	Build .................. custom_releases/2019/R1_ebce9728578ef3131f2f282b3fbc3232109c598e
Parsing input parameters
[ INFO ] Files were added: 1
[ INFO ]     openvino_demos/demo/car.png
[ INFO ] Loading plugin

	API version ............ 1.6
	Build .................. heteroPlugin
	Description ....... heteroPlugin
[ INFO ] Loading network files:
	open_model_zoo/model_downloader/Retail/object_detection/pedestrian/rmnet_ssd/0013/dldt/person-detection-retail-0013.xml
	open_model_zoo/model_downloader/Retail/object_detection/pedestrian/rmnet_ssd/0013/dldt/person-detection-retail-0013.bin
[ INFO ] Preparing input blobs
[ INFO ] Batch size is 1
[ INFO ] Preparing output blobs
[ INFO ] Loading model to the plugin
Error initializing DMA: not found
Error initializing DMA
[ WARNING ] Image is resized from (787, 259) to (544, 320)
[ INFO ] Batch size is 1
[ INFO ] Start inference (1 iterations)

Does anyone know hot to solve this issue? 

0 Kudos
1 Reply
Munesh_Intel
Moderator
157 Views

Hi Shaojie,

Since you have posted the same question in another thread, I will proceed to close this thread. 

Further communication/queries are to be posted to Thread 856728.

https://software.intel.com/en-us/forums/intel-distribution-of-openvino-toolkit/topic/856728

 

Regards,

Munesh

Reply