Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
12 Views

Error re-install ssd_detector training venv

I had previously able to train.

After some updates, I managed to mess up my venv and am trying to recreate venc.

Following the steps in https://github.com/opencv/openvino_training_extensions/tree/develop/tensorflow_toolkit/ssd_detector

i run following and got the error.

How can I install tensorflow version 1.13.1 when pip no longer allow it? I cant find the whl also.

Appreciate greatly advise.

Thank you.

=====

lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux bullseye/sid
Release:        unstable
Codename:       sid

 

===============

pip3 install -e .
Obtaining file:///deeplearning/openvino_training_extensions/tensorflow_toolkit/ssd_detector
Collecting cachetools==2.1.0
  Using cached cachetools-2.1.0-py2.py3-none-any.whl (12 kB)
Collecting cython==0.28.4
  Using cached Cython-0.28.4.tar.gz (1.9 MB)

Collecting jpeg4py==0.1.4
  Using cached jpeg4py-0.1.4.tar.gz (12 kB)
Collecting matplotlib==3.0.3
  Using cached matplotlib-3.0.3.tar.gz (36.6 MB)
Collecting opencv-python==3.4.8.29
  Using cached opencv_python-3.4.8.29-cp38-cp38-manylinux1_x86_64.whl (28.3 MB)
Collecting tensorboard==1.13.1
  Using cached tensorboard-1.13.1-py3-none-any.whl (3.2 MB)


ERROR: Could not find a version that satisfies the requirement tensorflow-gpu==1.13.1 (from ssd-detector==0.2.2.dev0) (from versions: 2.2.0rc1, 2.2.0rc2)
ERROR: No matching distribution found for tensorflow-gpu==1.13.1 (from ssd-detector==0.2.2.dev0)
 

0 Kudos
2 Replies
Highlighted
Employee
12 Views

Hi Richard,

Hi Richard,

Please refer to this discussion regarding a similar issue.

Hemanth Kumar G. (Intel) wrote:

For the latest wheel from Tensorflow site, you can try something like -

python3 -m pip install --upgrade https://storage.googleapis.com/tensorflow/linux/cpu/tensorflow-1.14.0-cp37-cp37m-linux_x86_64.whl

For python 3.7x, if no pip install works, try downgrading to python 3.6

 

0 Kudos
Highlighted
Beginner
12 Views

Thanks

Thanks

Managed to get it back after 2 days for trial and error

now xfce not working, xterm has no window borders, but thats another story

this case is closed

how do i buy you coffee?

0 Kudos