Intel® Distribution of OpenVINO™ Toolkit
Community support and discussions about the Intel® Distribution of OpenVINO™ toolkit, OpenCV, and all things computer vision-related on Intel® platforms.

Exception: mvncStatus.ERROR

idata
Community Manager
588 Views

Hi,

 

I've tried 'make examples' but failed with mvncStatus.ERROR.

 

Here is my error message after make run.

 

making compile mvNCCompile -w bvlc_googlenet.caffemodel -s 12 deploy.prototxt mvNCCompile v02.00, Copyright @ Movidius Ltd 2016 Layer inception_3b/1x1 forced to im2col_v2, because its output is used in concat Layer inception_3b/pool_proj forced to im2col_v3, because its output is used in concat Layer inception_4a/1x1 forced to im2col_v2, because its output is used in concat Layer inception_4a/pool_proj forced to im2col_v2, because its output is used in concat Layer inception_4b/1x1 forced to im2col_v2, because its output is used in concat Layer inception_4b/pool_proj forced to im2col_v2, because its output is used in concat Layer inception_4c/1x1 forced to im2col_v2, because its output is used in concat Layer inception_4c/pool_proj forced to im2col_v2, because its output is used in concat Layer inception_4d/1x1 forced to im2col_v2, because its output is used in concat Layer inception_4d/pool_proj forced to im2col_v2, because its output is used in concat Layer inception_4e/1x1 forced to im2col_v2, because its output is used in concat Layer inception_4e/pool_proj forced to im2col_v2, because its output is used in concat Layer inception_5a/1x1 forced to im2col_v2, because its output is used in concat Layer inception_5a/pool_proj forced to im2col_v2, because its output is used in concat Layer inception_5b/1x1 forced to im2col_v2, because its output is used in concat Layer inception_5b/pool_proj forced to im2col_v2, because its output is used in concat /usr/local/bin/ncsdk/Controllers/FileIO.py:52: UserWarning: You are using a large type. Consider reducing your data sizes for best performance "Consider reducing your data sizes for best performance\033[0m") making run ./run.py Device 0 Address: 3 - VID/PID 03e7:2150 Starting wait for connect with 2000ms timeout Found Address: 3 - VID/PID 03e7:2150 Found EP 0x81 : max packet size is 512 bytes Found EP 0x01 : max packet size is 512 bytes Found and opened device Performing bulk write of 865724 bytes... Successfully sent 865724 bytes of data in 1054.742965 ms (0.782768 MB/s) Boot successful, device address 3 Device 0 Address: 2 - VID/PID 03e7:f63b Found Address: 2 - VID/PID 03e7:f63b done Booted 2 -> VSC Traceback (most recent call last): File "./run.py", line 66, in <module> graph = device.AllocateGraph(blob) File "/usr/local/lib/python3.5/dist-packages/mvnc/mvncapi.py", line 203, in AllocateGraph raise Exception(Status(status)) Exception: mvncStatus.ERROR Makefile:91: recipe for target 'run' failed make: *** [run] Error 1

 

I think the device is connected successfully because I can compile ncsdk/examples/apps/hello_ncs_py.

 

Here are the logs I got.

 

ncsdk/eamples/apps/hello_ncs_py$ make run making run python3 hello_ncs.py; Hello NCS! Device opened normally. Goodbye NCS! Device closed normally. NCS device working.

 

I did re-clone NCSDK and reinstall, but still failed.

 

What should be my next debugging step?

 

Is there any driver I should install?

 

The followings are my environments details.

 

     

  • MV0212 EVM board with Myriad2 MA2450 (USB Device Boot mode 0x2)
  •  

  • Host Windows 7 64bits
  •  

  • Virtualbox Ubuntu 16.04 64bits
  •  

  • Two USB filters : Movidius NSC LoopbackDevice [0100] / Movidius Ltd. Movidius MA2X5X [0001]
  •  

 

Thanks,

 

Heera
0 Kudos
4 Replies
idata
Community Manager
199 Views

@hra.kim You may have to double check your USB filters. In your log below, I noticed that initially the device address number is 3 Device 0 Address 3 but the device address number changes after the Boot successful, device address 3 line. The Device address number should stay the same. @GoldenWings has some nice screenshots and tips @ https://ncsforum.movidius.com/discussion/comment/1052/#Comment_1052.

 

Snippet from your log:

 

Device 0 Address: 3 - VID/PID 03e7:2150 Starting wait for connect with 2000ms timeout Found Address: 3 - VID/PID 03e7:2150 Found EP 0x81 : max packet size is 512 bytes Found EP 0x01 : max packet size is 512 bytes Found and opened device Performing bulk write of 865724 bytes... Successfully sent 865724 bytes of data in 1054.742965 ms (0.782768 MB/s) Boot successful, device address 3 Device 0 Address: 2 - VID/PID 03e7:f63b Found Address: 2 - VID/PID 03e7:f63b

idata
Community Manager
199 Views

Thank you, this problem has been resolved

idata
Community Manager
199 Views

I am facing this same issue even after following the instructions by @Tome_at_Intel . Is there a fix for this?

idata
Community Manager
199 Views

Hi @Kaushik

 

Thank you for reaching out, I suggest you to start a new thread with the fill error message you are seeing.

 

If you can also provide additional details about your setup (Virtual Machine?, OS, SDK version, output of lsusb, etc).

 

Regards,

 

Jesus
Reply