Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Murakawa__Ryo
Beginner
227 Views

Faied for running "demo_squeezenet_download_convert_run.sh -d MYRIAD"

Hi

I just start using NCS2 on my Ubuntu 16.0.4 server. When I following the steps in the documentation and run "./demo_squeezenet_download_convert_run.sh -d MYRIAD", I got the error below.

target = MYRIAD
target_precision = FP16


###################################################

Downloading the Caffe model and the prototxt
Installing dependencies
Run sudo -E apt -y install build-essential python3-pip virtualenv cmake libpng12-dev libcairo2-dev libpango1.0-dev libglib2.0-dev libgtk2.0-dev libswscale-dev libavcodec-dev libavformat-dev libgstreamer1.0-0 gstreamer1.0-plugins-base
[sudo] password for murakawa:
Hit:1 http://ftp.jaist.ac.jp/pub/Linux/ubuntu xenial InRelease
Hit:2 http://ftp.jaist.ac.jp/pub/Linux/ubuntu xenial-updates InRelease         
Hit:3 http://ftp.jaist.ac.jp/pub/Linux/ubuntu xenial-backports InRelease       
Ign:4 http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1604/x86_64 ; InRelease
Hit:5 http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1604/x86_64 ; Release
Hit:7 http://security.ubuntu.com/ubuntu xenial-security InRelease
Reading package lists... Done
Building dependency tree       
Reading state information... Done
37 packages can be upgraded. Run 'apt list --upgradable' to see them.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
build-essential is already the newest version (12.1ubuntu2).
libcairo2-dev is already the newest version (1.14.6-1).
libpango1.0-dev is already the newest version (1.38.1-1).
cmake is already the newest version (3.5.1-1ubuntu3).
gstreamer1.0-plugins-base is already the newest version (1.8.3-1ubuntu0.2).
libglib2.0-dev is already the newest version (2.48.2-0ubuntu4.1).
libgstreamer1.0-0 is already the newest version (1.8.3-1~ubuntu0.1).
libgtk2.0-dev is already the newest version (2.24.30-1ubuntu1.16.04.2).
libpng12-dev is already the newest version (1.2.54-1ubuntu1.1).
libavcodec-dev is already the newest version (7:2.8.15-0ubuntu0.16.04.1).
libavformat-dev is already the newest version (7:2.8.15-0ubuntu0.16.04.1).
libswscale-dev is already the newest version (7:2.8.15-0ubuntu0.16.04.1).
python3-pip is already the newest version (8.1.1-2ubuntu0.4).
virtualenv is already the newest version (15.0.1+ds-3ubuntu1).
0 upgraded, 0 newly installed, 0 to remove and 37 not upgraded.
The directory '/home/murakawa/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
The directory '/home/murakawa/.cache/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
Requirement already satisfied: pyyaml in /usr/local/lib/python3.5/dist-packages (3.13)
Requirement already satisfied: requests in /usr/lib/python3/dist-packages (2.9.1)
Run /home/murakawa/intel/computer_vision_sdk/deployment_tools/demo/../model_downloader/downloader.py --name "squeezenet1.1" --output_dir "/home/murakawa/openvino_models/FP16"


###############|| Start downloading models ||###############

...100%, 9 KB, 74285 KB/s, 0 seconds passed ========= squeezenet1.1.prototxt ====> /home/murakawa/openvino_models/FP16/classification/squeezenet/1.1/caffe/squeezenet1.1.prototxt

###############|| Start downloading weights ||###############

...100%, 4834 KB, 5128 KB/s, 0 seconds passed ========= squeezenet1.1.caffemodel ====> /home/murakawa/openvino_models/FP16/classification/squeezenet/1.1/caffe/squeezenet1.1.caffemodel

###############|| Start downloading topologies in tarballs ||###############


###############|| Post processing ||###############

========= Changing input dimensions in squeezenet1.1.prototxt =========


###################################################

Configure Model Optimizer

INTEL_CVSDK_DIR environment variable is not set. Trying to run ./setvars.sh to set it.
[setupvars.sh] OpenVINO environment initialized


###################################################

Install Model Optimizer dependencies

Hit:1 http://ftp.jaist.ac.jp/pub/Linux/ubuntu xenial InRelease
Hit:2 http://ftp.jaist.ac.jp/pub/Linux/ubuntu xenial-updates InRelease         
Hit:3 http://ftp.jaist.ac.jp/pub/Linux/ubuntu xenial-backports InRelease       
Ign:4 http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1604/x86_64 ; InRelease
Hit:5 http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1604/x86_64 ; Release
Hit:7 http://security.ubuntu.com/ubuntu xenial-security InRelease             
Reading package lists... Done
Building dependency tree       
Reading state information... Done
37 packages can be upgraded. Run 'apt list --upgradable' to see them.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
python3-venv is already the newest version (3.5.1-3).
libgfortran3 is already the newest version (5.4.0-6ubuntu1~16.04.10).
python3-pip is already the newest version (8.1.1-2ubuntu0.4).
0 upgraded, 0 newly installed, 0 to remove and 37 not upgraded.
The directory '/home/murakawa/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
The directory '/home/murakawa/.cache/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
Requirement already satisfied: networkx>=1.11 in /usr/local/lib/python3.5/dist-packages (from -r /home/murakawa/intel/computer_vision_sdk_2018.4.420/deployment_tools/model_optimizer/install_prerequisites/../requirements_caffe.txt (line 1)) (2.2)
Requirement already satisfied: numpy>=1.12.0 in /usr/local/lib/python3.5/dist-packages (from -r /home/murakawa/intel/computer_vision_sdk_2018.4.420/deployment_tools/model_optimizer/install_prerequisites/../requirements_caffe.txt (line 2)) (1.15.4)
Requirement already satisfied: protobuf==3.5.1 in /usr/local/lib/python3.5/dist-packages (from -r /home/murakawa/intel/computer_vision_sdk_2018.4.420/deployment_tools/model_optimizer/install_prerequisites/../requirements_caffe.txt (line 3)) (3.5.1)
Requirement already satisfied: decorator>=4.3.0 in /usr/local/lib/python3.5/dist-packages (from networkx>=1.11->-r /home/murakawa/intel/computer_vision_sdk_2018.4.420/deployment_tools/model_optimizer/install_prerequisites/../requirements_caffe.txt (line 1)) (4.3.0)
Requirement already satisfied: setuptools in /usr/lib/python3/dist-packages (from protobuf==3.5.1->-r /home/murakawa/intel/computer_vision_sdk_2018.4.420/deployment_tools/model_optimizer/install_prerequisites/../requirements_caffe.txt (line 3)) (20.7.0)
Requirement already satisfied: six>=1.9 in /usr/lib/python3/dist-packages (from protobuf==3.5.1->-r /home/murakawa/intel/computer_vision_sdk_2018.4.420/deployment_tools/model_optimizer/install_prerequisites/../requirements_caffe.txt (line 3)) (1.10.0)
[WARNING] All Model Optimizer dependencies are installed globally.
[WARNING] If you want to keep Model Optimizer in separate sandbox
[WARNING] run install_prerequisites.sh venv {caffe|tf|mxnet|kaldi|onnx}


###################################################

Convert a model with Model Optimizer

Target folder /home/murakawa/openvino_models/ir/squeezenet1.1/FP16 already exists. Skipping IR generation../demo_squeezenet_download_convert_run.sh: line 181: If you want to convert a model again, remove the entire ${$ir_dir} folder. ${run_again}: bad substitution


###################################################

Build Inference Engine samples

Target folder /home/murakawa/inference_engine_samples already exists. Skipping samples building.If you want to rebuild samples, remove the entire /home/murakawa/inference_engine_samples folder. Then run the script again

###################################################

Run Inference Engine classification sample

Run ./classification_sample -d MYRIAD -i /home/murakawa/intel/computer_vision_sdk/deployment_tools/demo/../demo/car.png -m /home/murakawa/openvino_models/ir/squeezenet1.1/FP16/squeezenet1.1.xml

[ INFO ] InferenceEngine:
    API version ............ 1.4
    Build .................. 17328
[ INFO ] Parsing input parameters
[ INFO ] Files were added: 1
[ INFO ]     /home/murakawa/intel/computer_vision_sdk/deployment_tools/demo/../demo/car.png
[ INFO ] Loading plugin

    API version ............ 1.4
    Build .................. 17328
    Description ....... myriadPlugin
[ INFO ] Loading network files:
    /home/murakawa/openvino_models/ir/squeezenet1.1/FP16/squeezenet1.1.xml
    /home/murakawa/openvino_models/ir/squeezenet1.1/FP16/squeezenet1.1.bin
[ INFO ] Preparing input blobs
[BMP] file is not bmp type
[ WARNING ] Image /home/murakawa/intel/computer_vision_sdk/deployment_tools/demo/../demo/car.png cannot be read!
[ ERROR ] Valid input images were not found!
Error on or near line 215; exiting with status 1

I can find the file "/home/murakawa/intel/computer_vision_sdk/deployment_tools/demo/../demo/car.png" and this file is png type.

This log says this script assumes the file type is bmp.  Currently I can't find how to resolve this.

Any advice or comment is helpful for me.

 

Regards.

0 Kudos
6 Replies
nikogamulin
Beginner
227 Views

I had the same problem. After creating and running on new VM instance, it worked as expected.

Tegwyn_Twmffat
New Contributor I
227 Views

I have similar problem:

[ INFO ] InferenceEngine: 
	API version ............ 1.2
	Build .................. 13911
[ INFO ] Parsing input parameters
[ INFO ] Loading plugin

	API version ............ 1.2
	Build .................. 13911
	Description ....... myriadPlugin
[ INFO ] Loading network files:
	/home/tegwyn/openvino_models/ir/squeezenet1.1/squeezenet1.1.xml
	/home/tegwyn/openvino_models/ir/squeezenet1.1/squeezenet1.1.bin
[ INFO ] Preparing input blobs
[ WARNING ] Image is resized from (787, 259) to (227, 227)
[ INFO ] Batch size is 1
[ INFO ] Preparing output blobs
[ INFO ] Loading model to the plugin
[ ERROR ] The plugin does not support networks with FP32 format.
Supported format: FP16.
Error on or near line 210; exiting with status 1

It works OK with -d CPU but not -d MYRIAD .

cat <<EOF > 97-usbboot.rules
SUBSYSTEM=="usb", ATTRS{idProduct}=="2150", ATTRS{idVendor}=="03e7", GROUP="users", MODE="0666", ENV{ID_MM_DEVICE_IGNORE}="1"
SUBSYSTEM=="usb", ATTRS{idProduct}=="2485", ATTRS{idVendor}=="03e7", GROUP="users", MODE="0666", ENV{ID_MM_DEVICE_IGNORE}="1"
SUBSYSTEM=="usb", ATTRS{idProduct}=="f63b", ATTRS{idVendor}=="03e7", GROUP="users", MODE="0666", ENV{ID_MM_DEVICE_IGNORE}="1"
EOF


sudo cp 97-usbboot.rules /etc/udev/rules.d/
sudo udevadm control --reload-rules
sudo udevadm trigger
sudo ldconfig
rm 97-usbboot.rules

The above USB rules were set. I'm trying to test neural compute stick 2.

Any ideas at all would be much appreciated!

nikos1
Valued Contributor I
227 Views

Hi gg,

Please try FP16  IR for MYRIAD plugin on the NCS2

The plugin does not support networks with FP32 format.
Supported format: FP16.

 

227 Views

I just finished all the steps for the install and I am attempting to run ./demo_squeezenet_download_convert_run.sh -d MYRIAD

I am getting this error message.

[ ERROR ] The "/home/kaesgg/openvino_models/models/FP16/classification/squeezenet/1.1/caffe/squeezenet1.1.caffemodel" is not existing file

 

Any suggestions?
 

Melcon__Ruben
Beginner
227 Views

Hi Ryo:

The demo that you are trying to execute is trying to use an image, so you will need to install the opencv library. After this step, you should be able to execute the demo. Please, could you try this step and confirm that it works?

Thank you

manzano__juan
Beginner
227 Views

 

Did you fix it Michael RObinson?? I am having the same problem now and I can't find help

Robinson, Michael wrote:

I just finished all the steps for the install and I am attempting to run ./demo_squeezenet_download_convert_run.sh -d MYRIAD

I am getting this error message.

[ ERROR ] The "/home/kaesgg/openvino_models/models/FP16/classification/squeezenet/1.1/caffe/squeezenet1.1.caffemodel" is not existing file

 

Any suggestions?
 

Reply