Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Schotanus__Hans
Beginner
131 Views

Failed connection to device (3.2-ma2450) with error 5

Hi!

First of all, I'm not a Linux expert, and certainly not a CV adept. My intention is to see if a Synology DiskStation (Docker container) can handle adding some 'smart' to my surveillance cameras, using NCS (version 1) helps.

I created my own container, running Ubuntu 16, based on an example Dockerfile on this site. I also tried cortexa/openvino from Docker hub.

However, I can't get past this:

E: [ncAPI] [    633907] ncDeviceOpen:799 Failed connection to device (3.2-ma2450) with error 5

I installed the install_NCS_udev_rules.sh. I can see the NCS in dmesg, coming online as 2150 when plugged in. I get the error when I run ./demo_squeezenet_download_convert_run.sh -d MYRIAD

It seems like phase one, connecting to the NCS, is working, because during the demo, I can see NCS disconnects as 03e7:2150 and comes back online as 03e7:f63b

I'm running as root, so tried to change the group from users to root in /etc/udev/rules.d/97-myriad-usbboot.rules, followed by:

udevadm control --reload-rules
udevadm trigger
ldconfig

I have only Mac computers, but the NCS is not supported natively on that. I tried Ubuntu using VirtualBox, and the NCS connected to my iMac, get the same error 5 (with the USB filters in place). I had an older container, running ncsdk. I could run the hello test program on that, and it would tell me the NCS worked. Installed OpenVINO on that, got the same error 5.

So, question is, what's this error 5? Any idea what I am missing here?

0 Kudos
2 Replies
Schotanus__Hans
Beginner
131 Views

Oke, never mind this one, I got it working. I re-downloaded the Ubuntu Xenial image from Docker hub, although this was probably not the fix. I then performed all the Dockerfile installation steps manually, and noticed this message:

A chroot environment has been detected, udev not started.

So in the end, I started udev, and it worked under root. I had to change the permissions in the rule file from 0660 to 0666 to get it to work as a non-root user.

Case closed!

Shubha_R_Intel
Employee
131 Views

Dear Schotanus, Hans,

Thank you for reporting your success story here.

And thanks for using OpenVino !

Shubha

Reply