Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Wang__Ting
Beginner
157 Views

Failed to create plugin libliaPlugin.so for device FPGA

Hello,

I was trying to run the yolov3 model with FPGA(Openvino Starter Kit) with the api (object_detection_yolov3_async.py) provided by openvino toolkit 2020_1, and the error comes as the image showed. The error seemed to happen due to the loss of libliaPlugin.so, and I didn't find the file in the folder of inference_engine/lib/intel64. Can anyone tell me how to solve the problem?

Regards,

Ting

117634712_323604858834815_7050041793641190929_n.png117163522_612157522772394_4666907995705796922_n.png

0 Kudos
2 Replies
Iffa_Intel
Moderator
146 Views

Greetings,


Our Latest OpenVino which is Version 2020.4 has provided respective OS with FPGA support in the toolkit itself.



For Linux:

1.Install Intel® Distribution of OpenVINO™ toolkit for Linux* with FPGA Support:

https://docs.openvinotoolkit.org/latest/openvino_docs_install_guides_installing_openvino_linux_fpga....


2.Configuration Guide for the Intel® Distribution of OpenVINO™ toolkit 2020.4 and the Intel® Vision Accelerator Design with an Intel® Arria® 10 FPGA SG2 (IEI's Mustang-F100-A10) on Linux*:

https://docs.openvinotoolkit.org/latest/openvino_docs_install_guides_VisionAcceleratorFPGA_Configure...


3.Configuration Guide for Intel® Distribution of OpenVINO™ toolkit 2020.4 and the Intel® Programmable Acceleration Card with Intel® Arria® 10 GX FPGA on CentOS or Ubuntu*:

https://docs.openvinotoolkit.org/latest/openvino_docs_install_guides_PAC_Configure.html


Also note that Intel® Distribution of OpenVINO™ toolkit 2020.3.X LTS release will continue to support Intel® Vision Accelerator Design with an Intel® Arria® 10 FPGA and the Intel® Programmable Acceleration Card with Intel® Arria® 10 GX FPGA.


Meanwhile, future standard releases (i.e., non-LTS releases) of Intel® Distribution of OpenVINO™ toolkit will no longer include the Intel® Vision Accelerator Design with an Intel® Arria® 10 FPGA and the Intel® Programmable Acceleration Card with Intel® Arria® 10 GX FPGA.


Hence, it is recommended to use the version of 2020.3


Sincerely,

Iffa


Iffa_Intel
Moderator
125 Views

Greetings,


Intel will no longer monitor this thread since we have provided a solution. If you need any additional information from Intel, please submit a new question.


Sincerely,

Iffa


Reply