Community
cancel
Showing results for 
Search instead for 
Did you mean: 
jiapei100
Beginner
529 Views

How to build NCSDK with manually-installed OpenCV and existing Python3 packages?

Jump to solution

Is there a way for me to build NCSDK with existing manually-installed OpenCV and existing Python3 packages?

 

 

make install

seems to generate a file install-ncsdk.sh

under folder /opt/movidius/NCSDK.

 

However, it seems NCSDK ignores my manually-installed OpenCV 4.1.0, but trying to install an old OpenCV 3.2 ??? Isn't there a way for me to build NCSDK with existing OpenCV ?

Installer NCSDK version: 1.12.01.01 Creating setup directory... Remove previous NCSDK references from PYTHONPATH...done Hit:1 https://jevois.usc.edu/apt disco InRelease Hit:2 https://packages.microsoft.com/repos/vscode stable InRelease Hit:3 http://security.ubuntu.com/ubuntu disco-security InRelease Hit:4 http://debian.sur5r.net/i3 disco InRelease Hit:5 http://ca.archive.ubuntu.com/ubuntu disco InRelease Hit:6 http://ca.archive.ubuntu.com/ubuntu disco-updates InRelease Get:7 http://ca.archive.ubuntu.com/ubuntu disco-backports InRelease [88.8 kB] Fetched 88.8 kB in 2s (54.6 kB/s) Reading package lists... Reading package lists... Building dependency tree... Reading state information... coreutils is already the newest version (8.30-1ubuntu1). git is already the newest version (1:2.20.1-2ubuntu1). python3 is already the newest version (3.7.3-1). unzip is already the newest version (6.0-22ubuntu1). python3-pip is already the newest version (18.1-5). curl is already the newest version (7.64.0-2ubuntu1.1). The following packages were automatically installed and are no longer required: dkms fluidr3mono-gm-soundfont libcapnp-0.7.0 libfizmo-common libfizmo-dev libflac-dev libfluidsynth1 libibus-1.0-dev libmbim-glib4 libmbim-proxy libmircommon7 libmircookie-dev libmircookie2 libmircore-dev libmircore1 libopenmpt-dev libopusfile0 libqmi-glib5 libqmi-proxy libsdl2-image-2.0-0 libsdl2-mixer-2.0-0 libsdl2-net-2.0-0 libsndfile1-dev libsndio-dev libxss-dev libxv-dev usb-modeswitch usb-modeswitch-data x11proto-scrnsaver-dev Use 'sudo apt autoremove' to remove them. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. Reading package lists... Building dependency tree... Reading state information... automake is already the newest version (1:1.16.1-4ubuntu3). automake set to manually installed. cmake is already the newest version (3.13.4-1). gfortran is already the newest version (4:8.3.0-1ubuntu3). gfortran set to manually installed. git is already the newest version (1:2.20.1-2ubuntu1). libleveldb-dev is already the newest version (1.20-2.1). libsnappy-dev is already the newest version (1.1.7-1). libxml2-dev is already the newest version (2.9.4+dfsg1-7ubuntu3). libxml2-dev set to manually installed. libxslt1-dev is already the newest version (1.1.32-2ubuntu0.1). lsb-release is already the newest version (10.2019031300ubuntu1). lsb-release set to manually installed. python3-dev is already the newest version (3.7.3-1). python3-dev set to manually installed. python3-numpy is already the newest version (1:1.16.2-1ubuntu1). python3-numpy set to manually installed. python3-yaml is already the newest version (3.13-2). python3-yaml set to manually installed. graphviz is already the newest version (2.40.1-6). libatlas-base-dev is already the newest version (3.10.3-8). libgflags-dev is already the newest version (2.2.2-1). libgflags-dev set to manually installed. libgoogle-glog-dev is already the newest version (0.3.5-1). libhdf5-dev is already the newest version (1.10.4+repack-10). liblmdb-dev is already the newest version (0.9.23-0ubuntu1). python3-pip is already the newest version (18.1-5). swig3.0 is already the newest version (3.0.12-2). swig3.0 set to manually installed. The following packages were automatically installed and are no longer required: dkms fluidr3mono-gm-soundfont libcapnp-0.7.0 libfizmo-common libfizmo-dev libflac-dev libfluidsynth1 libibus-1.0-dev libmbim-glib4 libmbim-proxy libmircommon7 libmircookie-dev libmircookie2 libmircore-dev libmircore1 libopenmpt-dev libopusfile0 libqmi-glib5 libqmi-proxy libsdl2-image-2.0-0 libsdl2-mixer-2.0-0 libsdl2-net-2.0-0 libsndfile1-dev libsndio-dev libxss-dev libxv-dev usb-modeswitch usb-modeswitch-data x11proto-scrnsaver-dev Use 'sudo apt autoremove' to remove them. The following additional packages will be installed: libavresample-dev libnetcdf-c++4 libopencv-calib3d-dev libopencv-calib3d3.2 libopencv-contrib-dev libopencv-contrib3.2 libopencv-core-dev libopencv-core3.2 libopencv-features2d-dev libopencv-features2d3.2 libopencv-flann-dev libopencv-flann3.2 libopencv-highgui-dev libopencv-highgui3.2 libopencv-imgcodecs-dev libopencv-imgcodecs3.2 libopencv-imgproc-dev libopencv-imgproc3.2 libopencv-ml-dev libopencv-ml3.2 libopencv-objdetect-dev libopencv-objdetect3.2 libopencv-photo-dev libopencv-photo3.2 libopencv-shape-dev libopencv-shape3.2 libopencv-stitching-dev libopencv-stitching3.2 libopencv-superres-dev libopencv-superres3.2 libopencv-ts-dev libopencv-video-dev libopencv-video3.2 libopencv-videoio-dev libopencv-videoio3.2 libopencv-videostab-dev libopencv-videostab3.2 libopencv-viz-dev libopencv-viz3.2 libopencv3.2-java libopencv3.2-jni libprotoc17 libpython-all-dev libpython-dev libpython2-dev libpython2.7 libpython2.7-dev libtbb-dev libtbb2 libvtk6.3 opencv-data python-all python-all-dev python-asn1crypto python-cffi-backend python-configparser python-crypto python-cryptography python-dbus python-dev python-entrypoints python-enum34 python-gi python-idna python-ipaddress python-keyring python-keyrings.alt python-pkg-resources python-secretstorage python-setuptools python-six python-wheel python-xdg python2-dev python2.7-dev python3-decorator Suggested packages: opencv-doc tbb-examples libtbb-doc mpi-default-bin vtk6-doc vtk6-examples python-crypto-doc python-cryptography-doc python-cryptography-vectors python-dbus-dbg python-dbus-doc python-enum34-doc python-gi-cairo gir1.2-gnomekeyring-1.0 python-gdata python-keyczar python-pytest python-numpy-dbg python-numpy-doc python-secretstorage-doc python-setuptools-doc python-nose-doc python-scipy-doc The following NEW packages will be installed: byacc libavresample-dev libnetcdf-c++4 libopencv-calib3d-dev libopencv-calib3d3.2 libopencv-contrib-dev libopencv-contrib3.2 libopencv-core-dev libopencv-core3.2 libopencv-dev libopencv-features2d-dev libopencv-features2d3.2 libopencv-flann-dev libopencv-flann3.2 libopencv-highgui-dev libopencv-highgui3.2 libopencv-imgcodecs-dev libopencv-imgcodecs3.2 libopencv-imgproc-dev libopencv-imgproc3.2 libopencv-ml-dev libopencv-ml3.2 libopencv-objdetect-dev libopencv-objdetect3.2 libopencv-photo-dev libopencv-photo3.2 libopencv-shape-dev libopencv-shape3.2 libopencv-stitching-dev libopencv-stitching3.2 libopencv-superres-dev libopencv-superres3.2 libopencv-ts-dev libopencv-video-dev libopencv-video3.2 libopencv-videoio-dev libopencv-videoio3.2 libopencv-videostab-dev libopencv-videostab3.2 libopencv-viz-dev libopencv-viz3.2 libopencv3.2-java libopencv3.2-jni libprotobuf-dev libprotoc17 libpython-all-dev libpython-dev libpython2-dev libpython2.7 libpython2.7-dev libtbb-dev libtbb2 libvtk6.3 opencv-data protobuf-compiler python-all python-all-dev python-asn1crypto python-cffi-backend python-configparser python-crypto python-cryptography python-dbus python-dev python-entrypoints python-enum34 python-gi python-idna python-ipaddress python-keyring python-keyrings.alt python-numpy python-pip python-pkg-resources python-secretstorage python-setuptools python-six python-wheel python-xdg python2-dev python2.7-dev python3-decorator python3-nose python3-scipy 0 upgraded, 84 newly installed, 0 to remove and 0 not upgraded. Need to get 93.2 MB/97.4 MB of archives. After this operation, 388 MB of additional disk space will be used. Get:1 http://ca.archive.ubuntu.com/ubuntu disco/universe amd64 libopencv-core-dev amd64 3.2.0+dfsg-6 [1,171 kB]

 

Cheers

Pei

0 Kudos
1 Solution
JesusE_Intel
Moderator
141 Views

Hi Pei,

 

Other users have done this in the past, however, we have not validated those version with the NCSDK. Take a look at the following discussion for additional details.

https://forums.intel.com/s/question/0D50P00004NM0TMSA1/is-it-possible-for-ncsdk-to-support-opencv-40...

 

Hope this helps!

 

Regards,

Jesus

View solution in original post

1 Reply
JesusE_Intel
Moderator
142 Views

Hi Pei,

 

Other users have done this in the past, however, we have not validated those version with the NCSDK. Take a look at the following discussion for additional details.

https://forums.intel.com/s/question/0D50P00004NM0TMSA1/is-it-possible-for-ncsdk-to-support-opencv-40...

 

Hope this helps!

 

Regards,

Jesus

View solution in original post

Reply