Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
310 Views

How to enable Neural Compute Stick in VMs created by Qemu&KVM?

hi,

 

I am using Intel Compute Stick 2. The stick works well on the host. My target is to use the stick in my VM which was created by KVM/QEMU. My host and guest OS are both ubuntu 16.04. By usb passthrough, I already passed the stick to my guest os.

 

When run "lsusb" in the guest, I can see

 

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 001 Device 002: ID 03e7:2485 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

 

I tried the sample app "hello_ncs_cpp" included in ncsdk. I got below error

 

making run cd cpp; ./hello_ncs_cpp; cd .. W: [ 0] ncDeviceOpen:528 ncDeviceOpen() XLinkBootRemote returned error 3 Error- ncDeviceOpen failed ncStatus value: -2

 

Anybody has some experiences on this? Many thanks!

0 Kudos
1 Reply
idata
Community Manager
122 Views

I just learned that NCSDK doesn't support NCS2, and OpenVINO does support.

 

I tried OpenVINO R4, still not work. When I ran a openvino demo. I got below error

 

`[ INFO ] Loading model to the plugin` E: [ncAPI] [ 0] ncDeviceOpen:668 failed to find device [ ERROR ] Can not init USB device: NC_DEVICE_NOT_FOUND

 

A strange phenomenon is at host side

 

by dmesg, I found the stick was unplugged and plunged again.

 

by lsusb, I found the usb device was change from "ID 03e7:2485" to "ID 03e7:f63b"

 

who know the reasons?

Reply