Intel® Distribution of OpenVINO™ Toolkit
Community assistance about the Intel® Distribution of OpenVINO™ toolkit, OpenCV, and all aspects of computer vision-related on Intel® platforms.
6415 Discussions

IMMEDIATE -- how to compile F-RCNN inception v2


I trained a faster_rcnn_inception_v2_coco with TesorFlow and now I need to compile it and detect objects on a raspberry with NCS.


However, when I do:


mvNCCompile Desktop/stuff/model.ckpt.meta




mvNCCompile Desktop/stuff/frozen_inference_graph.pb


I get an error: No op named NonMaxSuppressionV3 in defined operations


I somewhere later read that NCS does not support rcnn_inception_v2 (5 months old thread) but I don't believe it as there are literally rcnn_inception_v2 models in the NCAPPZOO git repo.


I need help immediately!!


Do I have to train a new model in another network? Should I use Caffe? Can I then use RCNN? Why can't I compile my current model?
0 Kudos
2 Replies

I updated tensorflow, and now the NonMaxSuppressionV3 issue is gone.


I just trained for a very short time new Mobile SSD v2 model AND I CANNOT COMPILE IT EITHER


Could someone give DETAILED explanation on how to compile a ".meta" or ".pb" or whatnot file to the "graph"?



  1. In which directory should I place them

  3. What commands should I run

  5. Which directory does terminal have to be in


My files "model.ckpt.meta" and "frozen_inference_graph.pb" (which i created by following this tutorial are currently in /Desktop/newSSD/ on ubuntu 16 virtual machine.


When I run:


"mvNCCompile frozen_inference_graph.pb"


it gives error:


KeyError: "The name "input:0" refers to a tensor which does not exist. The operation, "input", does not exist in the graph."
0 Kudos
VirtualBox:~/Desktop/newSSD$ mvNCCompile frozen_inference_graph.pb mvNCCompile v02.00, Copyright @ Movidius Ltd 2016 /home/mov1/.local/lib/python3.5/site-packages/tensorflow/python/util/ DeprecationWarning: inspect.getargspec() is deprecated, use inspect.signature() instead return _inspect.getargspec(target) Traceback (most recent call last): File "/usr/local/bin/mvNCCompile", line 118, in <module> create_graph(, args.inputnode, args.outputnode, args.outfile, args.nshaves, args.inputsize, args.weights) File "/usr/local/bin/mvNCCompile", line 104, in create_graph net = parse_tensor(args, myriad_config) File "/usr/local/bin/ncsdk/Controllers/", line 227, in parse_tensor inputTensor = graph.get_tensor_by_name(inputnode + ':0') File "/home/mov1/.local/lib/python3.5/site-packages/tensorflow/python/framework/", line 3666, in get_tensor_by_name return self.as_graph_element(name, allow_tensor=True, allow_operation=False) File "/home/mov1/.local/lib/python3.5/site-packages/tensorflow/python/framework/", line 3490, in as_graph_element return self._as_graph_element_locked(obj, allow_tensor, allow_operation) File "/home/mov1/.local/lib/python3.5/site-packages/tensorflow/python/framework/", line 3532, in _as_graph_element_locked "graph." % (repr(name), repr(op_name))) KeyError: "The name 'input:0' refers to a Tensor which does not exist. The operation, 'input', does not exist in the graph.
0 Kudos