Intel® Distribution of OpenVINO™ Toolkit
Community support and discussions about the Intel® Distribution of OpenVINO™ toolkit, OpenCV, and all things computer vision-related on Intel® platforms.
5530 Discussions

Is Neural Compute Stick not compatible with USB 3.1?

idata
Community Manager
402 Views

I just received my NCS yesterday (2018/5/30). I've tried the "make examples" and it seems to work fine on my laptop (Asus UX410UQ) if I plug NCS into a USB 2.0 or 3.0 port. If I plug my NCS into the USB 3.1 port (which is actually is type C, so a type A to type C adapter cable is required), then during "make examples" error messages like this will appear:

 

_[Error 7] Toolkit Error: USB Failure. Code: No devices found_

 

With NCS plugged into USB 3.1 port, the command "lsusb" failed to find it. However, if it is plugged into USB 2.0 or 3.0 ports, lsusb can find and reports NCS as following:

 

_Bus 001 Device 035: ID 03e7:2150_

 

I understand that NCS's specification doesn't say it is USB 3.1 compatible (only 2.0 & 3.0 is supported). However, all of my USB 2.0 & 3.0 devices (Wireless Keyboard & mouse transceiver, USB drives, USB hub, etc.) all work fine with it. I'm wondering if NCS does indeed NOT support USB 3.1?

 

System specifications:

 

Intel® Core™ i5-7200U CPU @ 2.50GHz × 4 , Ubuntu 17.10

 

NCSDK version:

 

latest version of V.1.*

 

Python version:

 

2.7.14

 

Installation Error Log:

 

No error

 

Miscellaneous Error Log with error message(s):

 

_[Error 7] Toolkit Error: USB Failure. Code: No devices found_

 

Link to Neural Network for debugging purposes (prototxt file, caffe weights, github, pb files):

 

No

 

Any additional relevant information:
0 Kudos
3 Replies
idata
Community Manager
124 Views

@oliver.chen Thanks for reporting the issue. I was unable to reproduce the issue on my end, however I was wondering if you could link your dmesg log by using the following steps:

 

     

  1. Make sure your USB-C to USB-A adapter is unplugged and run the following command to clear your dmesg log: sudo dmesg -C
  2.  

  3. Plug in your USB-C to USB-A adapter.
  4.  

  5. Plug in your NCS device to the USB-A female port of your adapter and type in dmesg to see if the device properly enumerates.
  6.  

  7. Save the dmesg log from the previous step and if possible, paste the output in this forum thread.
  8.  

idata
Community Manager
124 Views

Hi Tome,

 

First thank you for your prompt reply.

 

I just tried your suggestion and found dmesg print NOTHING if NCS is plug into that USB 3.1 port with that adapter cable.

 

As this sounds unreasonable, after doing some experiments, finally I found that adapter cable seemed not "compatible" with NCS due to bad contact, which can be solved by carefully adjusting how I plug NCS to that cable.

 

Fortunately this issue is solved. Thanks for your help and I wish you a good day!

 

Regards,

 

Oliver

idata
Community Manager
124 Views

@oliver.chen Glad you were able to solve the issue.

Reply