Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
91 Views

Model Optimizer Tool Not Recognizing Satisfied Dependencies

I am trying to implement the YOLOv3 algorithm for object detection on a Raspberry Pi 4. I'm using the Intel Neural Compute Stick 2 for acceleration, and am stuck at trying to convert my .pb file to IR. When I try to run mo_tf.py on my protobuf file, I get the following error:

 

[ ERROR ]

Detected not satisfied dependencies:

     networkx: installed: 2.4, required: 2.4

 

I cannot run the install_prerequisites.sh script either, because it gives an error, so I have installed all of the required libraries manually. I have also verified that they are installed into python 3.7, which is what I am using to run mo_tf.py. 

0 Kudos
2 Replies
Highlighted
Moderator
91 Views

Hi Joshua,

Could you install networkx version 2.3? Are you running the model optimizer on the Raspberry Pi? The Raspberry Pi should only be used to deploy the application with your model. The model optimization should be done on a system running the full version of the OpenVINO toolkit. Also, which version of the OpenVINO toolkit are you using?

Regards,

Jesus

0 Kudos
Highlighted
Employee
82 Views

Encountered the same problem on my setup. I am trying to run model optimizer for onnx and it complains about networkx 2.4. Openvino version is 2019.3.376.

However, I went and looked at requirements_onnx.txt in the openvino installation directory and found that the required version of networkx is < 2.4. So, I installed networkx-2.3 and everything now works.

@openvino dev team: please make sure the error messages reflect the actual problem. So the actual descriptive error message should look like this:

Unsatisfied dependencies detected:

networkx: installed: 2.4 required: <2.4

0 Kudos